summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/smarty
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-09-27 10:03:33 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-27 11:34:56 -0700
commite06935c6c13cbec3b8765d849e82bef891a2350d (patch)
tree2dff99748722a00c6ba90ca6a4ab14e90bf54796 /meta-oe/recipes-support/smarty
parent437513e8eec7d8ee14221f4bed7b0d2abf5e8fc0 (diff)
downloadmeta-openembedded-e06935c6c13cbec3b8765d849e82bef891a2350d.tar.gz
smarty: Add recipe
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/smarty')
-rw-r--r--meta-oe/recipes-support/smarty/smarty_3.1.39.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/smarty/smarty_3.1.39.bb b/meta-oe/recipes-support/smarty/smarty_3.1.39.bb
new file mode 100644
index 000000000..50d995838
--- /dev/null
+++ b/meta-oe/recipes-support/smarty/smarty_3.1.39.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "the compiling PHP template engine"
2SECTION = "console/network"
3HOMEPAGE = "https://www.smarty.net/"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
7
8DEPENDS = "php"
9
10SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;tag=v${PV}"
11
12FILES:${PN} = "${datadir}/php/smarty3/"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${datadir}/php/smarty3/libs/
18 install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
19
20 install -d ${D}${datadir}/php/smarty3/libs/plugins
21 install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
22
23 install -d ${D}${datadir}/php/smarty3/libs/sysplugins
24 install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
25}