summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/sg3-utils
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-08-09 12:16:43 +0000
committerKhem Raj <raj.khem@gmail.com>2018-08-11 20:16:52 -0700
commit3c37bdcea6b6950662bade837f33ec674ea64b06 (patch)
tree7c23a6517909afc1cedf781ce7297d1a211cd55c /meta-oe/recipes-support/sg3-utils
parent72220d60882fc0066e09849e7d58cd3838fba04a (diff)
downloadmeta-openembedded-3c37bdcea6b6950662bade837f33ec674ea64b06.tar.gz
sg3-utils: fix build with glibc-2.28
Fixes: http://errors.yoctoproject.org/Errors/Details/185896/ TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: sg_map26.o: in function `nd_match_scandir_select': /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:359: undefined reference to `major' TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:361: undefined reference to `minor' TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: sg_map26.o: in function `nt_typ_from_filename': /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:218: undefined reference to `major' TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:219: undefined reference to `minor' collect2: error: ld returned 1 exit status Makefile:806: recipe for target 'sg_map26' failed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/sg3-utils')
-rw-r--r--meta-oe/recipes-support/sg3-utils/sg3-utils/glibc-2.28.patch24
-rw-r--r--meta-oe/recipes-support/sg3-utils/sg3-utils_1.42.bb4
2 files changed, 27 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/sg3-utils/sg3-utils/glibc-2.28.patch b/meta-oe/recipes-support/sg3-utils/sg3-utils/glibc-2.28.patch
new file mode 100644
index 000000000..fbad4135d
--- /dev/null
+++ b/meta-oe/recipes-support/sg3-utils/sg3-utils/glibc-2.28.patch
@@ -0,0 +1,24 @@
1Fixes:
2http://errors.yoctoproject.org/Errors/Details/185896/
3
4TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: sg_map26.o: in function `nd_match_scandir_select':
5/usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:359: undefined reference to `major'
6TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:361: undefined reference to `minor'
7TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: sg_map26.o: in function `nt_typ_from_filename':
8/usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:218: undefined reference to `major'
9TOPDIR/tmp-glibc/work/core2-64-oe-linux/sg3-utils/1.42-r0/recipe-sysroot-native/usr/bin/x86_64-oe-linux/../../libexec/x86_64-oe-linux/gcc/x86_64-oe-linux/8.2.0/ld: /usr/src/debug/sg3-utils/1.42-r0/sg3_utils-1.42/src/sg_map26.c:219: undefined reference to `minor'
10collect2: error: ld returned 1 exit status
11Makefile:806: recipe for target 'sg_map26' failed
12
13Upstream-Status: Pending
14
15--- sg3_utils-1.42.orig/src/sg_map26.c 2018-08-09 11:53:26.907493996 +0000
16+++ sg3_utils-1.42/src/sg_map26.c 2018-08-09 11:51:56.713490763 +0000
17@@ -33,6 +33,7 @@
18 #include <sys/ioctl.h>
19 #include <sys/types.h>
20 #include <sys/stat.h>
21+#include <sys/sysmacros.h>
22 #include <linux/major.h>
23
24 #ifdef HAVE_CONFIG_H
diff --git a/meta-oe/recipes-support/sg3-utils/sg3-utils_1.42.bb b/meta-oe/recipes-support/sg3-utils/sg3-utils_1.42.bb
index f14a5314a..c37c5e952 100644
--- a/meta-oe/recipes-support/sg3-utils/sg3-utils_1.42.bb
+++ b/meta-oe/recipes-support/sg3-utils/sg3-utils_1.42.bb
@@ -8,7 +8,9 @@ SECTION = "console/admin"
8LICENSE = "GPLv2+ & BSD" 8LICENSE = "GPLv2+ & BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=f90da7fc52172599dbf082d7620f18ca" 9LIC_FILES_CHKSUM = "file://COPYING;md5=f90da7fc52172599dbf082d7620f18ca"
10 10
11SRC_URI = "http://sg.danny.cz/sg/p/sg3_utils-${PV}.tgz" 11SRC_URI = "http://sg.danny.cz/sg/p/sg3_utils-${PV}.tgz \
12 file://glibc-2.28.patch \
13"
12MIRRORS += "http://sg.danny.cz/sg/p https://fossies.org/linux/misc" 14MIRRORS += "http://sg.danny.cz/sg/p https://fossies.org/linux/misc"
13 15
14UPSTREAM_CHECK_REGEX = "sg3_utils-(?P<pver>\d+(\.\d+)+)\.tgz" 16UPSTREAM_CHECK_REGEX = "sg3_utils-(?P<pver>\d+(\.\d+)+)\.tgz"