summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/serial-utils
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/serial-utils
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/serial-utils')
-rw-r--r--meta-oe/recipes-support/serial-utils/pty-forward-native.bb20
-rw-r--r--meta-oe/recipes-support/serial-utils/serial-forward_git.bb12
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/serial-utils/pty-forward-native.bb b/meta-oe/recipes-support/serial-utils/pty-forward-native.bb
new file mode 100644
index 000000000..b2b878d34
--- /dev/null
+++ b/meta-oe/recipes-support/serial-utils/pty-forward-native.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Receive a forwarded serial from serial-forward and provide a PTY"
2AUTHOR = "Holger 'Zecke' Freyther"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
5SECTION = "console/network"
6SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
7PV = "1.1+gitr${SRCPV}"
8
9SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia"
10S = "${WORKDIR}/git/tools/serial_forward"
11
12inherit autotools native
13
14do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}"
15do_deploy() {
16 install -d ${DEPLOY_DIR_IMAGE}
17 install -m 0755 ${S}/src/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
18}
19
20addtask deploy before do_package after do_install
diff --git a/meta-oe/recipes-support/serial-utils/serial-forward_git.bb b/meta-oe/recipes-support/serial-utils/serial-forward_git.bb
new file mode 100644
index 000000000..129a3be8a
--- /dev/null
+++ b/meta-oe/recipes-support/serial-utils/serial-forward_git.bb
@@ -0,0 +1,12 @@
1SUMMARY = "Forward a serial using TCP/IP"
2AUTHOR = "Holger 'Zecke' Freyther'"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07"
5SECTION = "console/devel"
6SRCREV = "00dbec2636ae0385ad028587e20e446272ff97ec"
7PV = "1.1+gitr${SRCPV}"
8
9SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia"
10S = "${WORKDIR}/git/tools/serial_forward"
11
12inherit autotools