summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/sdparm
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/sdparm
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/sdparm')
-rw-r--r--meta-oe/recipes-support/sdparm/files/make-sysroot-work.patch27
-rw-r--r--meta-oe/recipes-support/sdparm/sdparm_1.08.bb23
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sdparm/files/make-sysroot-work.patch b/meta-oe/recipes-support/sdparm/files/make-sysroot-work.patch
new file mode 100644
index 000000000..5405ed802
--- /dev/null
+++ b/meta-oe/recipes-support/sdparm/files/make-sysroot-work.patch
@@ -0,0 +1,27 @@
1[PATCH] make sysroot work
2
3Upstream-Status: Pending
4
5Add = before the included dir to make sysroot work
6
7Signed-off-by: Roy.Li <rongqing.li@windriver.com>
8---
9 src/Makefile.am | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/src/Makefile.am b/src/Makefile.am
13index c83788c..9f62115 100644
14--- a/src/Makefile.am
15+++ b/src/Makefile.am
16@@ -32,7 +32,7 @@ sglib_SOURCES = ../lib/sg_lib.c \
17 ../lib/sg_pt_common.c
18
19 if HAVE_SGUTILS
20-INCLUDES = -I/usr/include/scsi
21+INCLUDES = -I=@includedir@/scsi
22 sdparm_LDADD = @GETOPT_O_FILES@ @os_libs@ @SGUTILS_LIBS@
23 sdparm_DEPENDENCIES = @GETOPT_O_FILES@
24 else
25--
261.9.1
27
diff --git a/meta-oe/recipes-support/sdparm/sdparm_1.08.bb b/meta-oe/recipes-support/sdparm/sdparm_1.08.bb
new file mode 100644
index 000000000..b603a5682
--- /dev/null
+++ b/meta-oe/recipes-support/sdparm/sdparm_1.08.bb
@@ -0,0 +1,23 @@
1SUMMARY = "fetch and change SCSI mode pages"
2DESCRIPTION = "The sdparm utility accesses and optionally modifies \
3SCSI devices' mode page and inquiry data."
4HOMEPAGE = "http://sg.danny.cz/sg/sdparm.html"
5SECTION = "console/utils"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ecab6c36b7ba82c675581dd0afde36f7 \
8 file://lib/BSD_LICENSE;md5=1d52f4a66f1e0ed96776bf354ab7a2ed"
9DEPENDS="sg3-utils"
10SRC_URI = "http://sg.danny.cz/sg/p/${BPN}-${PV}.tgz \
11 file://make-sysroot-work.patch \
12 "
13
14PACKAGES =+ "${PN}-scripts"
15RDEPENDS_${PN}-scripts += "bash ${PN}"
16
17SRC_URI[md5sum] = "be5786f37499018ef44f409597c92d42"
18SRC_URI[sha256sum] = "376b78a414b1a9c47f3f13dbeb963e7a3ec7be126f83927d6856b5f7ac425e57"
19
20inherit autotools
21
22# Put the bash scripts to ${PN}-scripts
23FILES_${PN}-scripts = "${bindir}/sas_disk_blink ${bindir}/scsi_ch_swp"