summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/samsung-soc-utils
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 13:24:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 14:43:41 +0200
commit89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch)
treeb073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-support/samsung-soc-utils
parente66079da37992abd54486488aa06a99bf7a4198c (diff)
downloadmeta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-support/samsung-soc-utils')
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb19
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb19
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb34
3 files changed, 72 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb
new file mode 100644
index 000000000..b813f76b1
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPL"
5SRCREV = "4949"
6PV = "1.0+svnr${SRCPV}"
7PR = "r2"
8
9SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
10S = "${WORKDIR}/gpio"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c
14}
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${PN} ${D}${sbindir}
19}
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
new file mode 100644
index 000000000..f8ca7947f
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A user-space tool to show and modify the state of GPIOs on the S3c64xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPL"
5SRCREV = "4949"
6PV = "1.0+svnr${SRCPV}"
7PR = "r0"
8
9SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;proto=http"
10S = "${WORKDIR}/gpio"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c
14}
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${PN} ${D}${sbindir}
19}
diff --git a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
new file mode 100644
index 000000000..b71231617
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "JTAG utility to interface w/ a S3C2410 device"
2SECTION = "devel"
3AUTHOR = "Harald Welte <laforge@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://parport.c;endline=19;md5=b5681091b0fd8c5f7068835c441bf0c8"
6SRCREV = "4268"
7PV = "0.1+svnr${SRCPV}"
8PR = "r1"
9
10SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=sjf2410-linux;proto=http"
11S = "${WORKDIR}/sjf2410-linux"
12
13inherit native deploy
14do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
15
16CFLAGS += "-DLINUX_PPDEV"
17
18NATIVE_INSTALL_WORKS = "1"
19
20do_compile() {
21 oe_runmake
22}
23
24do_install() {
25 install -d ${D}/${bindir}
26 install -m 0755 sjf2410 ${D}/${bindir}
27}
28
29do_deploy() {
30 install -d ${DEPLOY_DIR_TOOLS}
31 install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV}
32}
33
34addtask deploy before do_build after do_install