diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/samsung-soc-utils | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/samsung-soc-utils')
3 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb index d46580338..ca98ab5ce 100644 --- a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb +++ b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb | |||
@@ -11,10 +11,10 @@ SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http" | |||
11 | S = "${WORKDIR}/gpio" | 11 | S = "${WORKDIR}/gpio" |
12 | 12 | ||
13 | do_compile() { | 13 | do_compile() { |
14 | ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c | 14 | ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c |
15 | } | 15 | } |
16 | 16 | ||
17 | do_install() { | 17 | do_install() { |
18 | install -d ${D}${sbindir} | 18 | install -d ${D}${sbindir} |
19 | install -m 0755 ${PN} ${D}${sbindir} | 19 | install -m 0755 ${PN} ${D}${sbindir} |
20 | } | 20 | } |
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb index 96285e944..a0dbef468 100644 --- a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb +++ b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb | |||
@@ -11,10 +11,10 @@ SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http" | |||
11 | S = "${WORKDIR}/gpio" | 11 | S = "${WORKDIR}/gpio" |
12 | 12 | ||
13 | do_compile() { | 13 | do_compile() { |
14 | ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c | 14 | ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c |
15 | } | 15 | } |
16 | 16 | ||
17 | do_install() { | 17 | do_install() { |
18 | install -d ${D}${sbindir} | 18 | install -d ${D}${sbindir} |
19 | install -m 0755 ${PN} ${D}${sbindir} | 19 | install -m 0755 ${PN} ${D}${sbindir} |
20 | } | 20 | } |
diff --git a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb index 9e0c087d4..a6ec087d0 100644 --- a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb +++ b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb | |||
@@ -16,17 +16,17 @@ do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}" | |||
16 | CFLAGS += "-DLINUX_PPDEV" | 16 | CFLAGS += "-DLINUX_PPDEV" |
17 | 17 | ||
18 | do_compile() { | 18 | do_compile() { |
19 | oe_runmake | 19 | oe_runmake |
20 | } | 20 | } |
21 | 21 | ||
22 | do_install() { | 22 | do_install() { |
23 | install -d ${D}/${bindir} | 23 | install -d ${D}/${bindir} |
24 | install -m 0755 sjf2410 ${D}/${bindir} | 24 | install -m 0755 sjf2410 ${D}/${bindir} |
25 | } | 25 | } |
26 | 26 | ||
27 | do_deploy() { | 27 | do_deploy() { |
28 | install -d ${DEPLOY_DIR_TOOLS} | 28 | install -d ${DEPLOY_DIR_TOOLS} |
29 | install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV} | 29 | install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV} |
30 | } | 30 | } |
31 | 31 | ||
32 | addtask deploy before do_build after do_install | 32 | addtask deploy before do_build after do_install |