summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/samsung-soc-utils
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/samsung-soc-utils
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/samsung-soc-utils')
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb20
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb19
-rw-r--r--meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb32
3 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb
new file mode 100644
index 000000000..269c1b75e
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c24xx-gpio_svn.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://gpio.c;endline=12;md5=cfb91c686857b2e60852b4925d90a3e1"
6SRCREV = "4949"
7PV = "1.0+svnr${SRCPV}"
8PR = "r2"
9
10SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
11S = "${WORKDIR}/gpio"
12
13do_compile() {
14 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio.c
15}
16
17do_install() {
18 install -d ${D}${sbindir}
19 install -m 0755 ${PN} ${D}${sbindir}
20}
diff --git a/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
new file mode 100644
index 000000000..256da092d
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/s3c64xx-gpio_svn.bb
@@ -0,0 +1,19 @@
1SUMMARY = "A user-space tool to show and modify the state of GPIOs on the S3c64xx platform"
2SECTION = "console/utils"
3AUTHOR = "Werner Almesberger <werner@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://gpio-s3c6410.c;endline=12;md5=060cda1be945ad9194593f11d56d55c7"
6SRCREV = "4949"
7PV = "1.0+svnr${SRCPV}"
8
9SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http"
10S = "${WORKDIR}/gpio"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} -static -o ${PN} gpio-s3c6410.c
14}
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 ${PN} ${D}${sbindir}
19}
diff --git a/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
new file mode 100644
index 000000000..2d5935dd3
--- /dev/null
+++ b/meta-oe/recipes-support/samsung-soc-utils/sjf2410-linux-native_svn.bb
@@ -0,0 +1,32 @@
1SUMMARY = "JTAG utility to interface w/ a S3C2410 device"
2SECTION = "devel"
3AUTHOR = "Harald Welte <laforge@openmoko.org>"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://parport.c;endline=19;md5=b5681091b0fd8c5f7068835c441bf0c8"
6SRCREV = "4268"
7PV = "0.1+svnr${SRCPV}"
8PR = "r1"
9
10SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=sjf2410-linux;protocol=http"
11S = "${WORKDIR}/sjf2410-linux"
12
13inherit native deploy
14do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
15
16CFLAGS += "-DLINUX_PPDEV"
17
18do_compile() {
19 oe_runmake
20}
21
22do_install() {
23 install -d ${D}/${bindir}
24 install -m 0755 sjf2410 ${D}/${bindir}
25}
26
27do_deploy() {
28 install -d ${DEPLOY_DIR_TOOLS}
29 install -m 0755 sjf2410 ${DEPLOY_DIR_TOOLS}/sjf2410-${PV}
30}
31
32addtask deploy before do_build after do_install