summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/rsnapshot
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/rsnapshot
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/rsnapshot')
-rw-r--r--meta-oe/recipes-support/rsnapshot/rsnapshot/configure-fix-cmd_rsync.patch44
-rw-r--r--meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb42
2 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/rsnapshot/rsnapshot/configure-fix-cmd_rsync.patch b/meta-oe/recipes-support/rsnapshot/rsnapshot/configure-fix-cmd_rsync.patch
new file mode 100644
index 000000000..7b2361b4a
--- /dev/null
+++ b/meta-oe/recipes-support/rsnapshot/rsnapshot/configure-fix-cmd_rsync.patch
@@ -0,0 +1,44 @@
1From 26ad431e19788898fb4ed19ff91392e8b20f1bab Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Thu, 16 Oct 2014 04:06:55 -0400
4Subject: [PATCH] fix cmd_rsync
5
6Don't break configure if rsync is not installed on host.
7
8rsync is a runtime dependency and this change is only used for
9generating rsnapshot.conf.default. It allows cmd_rsync to use
10default path if options --without-rsync is specfied.
11
12Upstream-Status: Pending
13
14Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
15---
16 configure.ac | 5 +++--
17 1 file changed, 3 insertions(+), 2 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index bc9df9e..2a33d29 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -55,7 +55,7 @@ AC_ARG_WITH(rsync,
24 AC_MSG_ERROR(rsync not found)
25 fi
26 else
27- AC_MSG_ERROR(rsync is required)
28+ RSYNC=no
29 fi
30 ]
31 )
32@@ -67,7 +67,8 @@ if test "$RSYNC" = ""; then
33 fi
34 dnl bail out if we can't find it
35 if test "$RSYNC" = "no"; then
36- AC_MSG_ERROR(rsync is required)
37+ RSYNC=/usr/bin/rsync
38+ AC_SUBST(CMD_RSYNC, "cmd_rsync $RSYNC")
39 fi
40
41
42--
431.7.9.5
44
diff --git a/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb b/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
new file mode 100644
index 000000000..3f919b568
--- /dev/null
+++ b/meta-oe/recipes-support/rsnapshot/rsnapshot_git.bb
@@ -0,0 +1,42 @@
1SUMMARY = "A filesystem snapshot utility based on rsync"
2HOMEPAGE = "http://www.rsnapshot.org"
3BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
8
9RDEPENDS_${PN} = "rsync \
10 perl \
11 perl-module-dirhandle \
12 perl-module-cwd \
13 perl-module-getopt-std \
14 perl-module-file-path \
15 perl-module-file-stat \
16 perl-module-posix \
17 perl-module-fcntl \
18 perl-module-io-file \
19 perl-module-constant \
20 perl-module-overloading \
21 "
22
23SRCREV = "1047cbb57937c29233388e2fcd847fecd3babe74"
24PV = "1.3.1+git${SRCPV}"
25
26SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=git \
27 file://configure-fix-cmd_rsync.patch \
28 "
29
30S = "${WORKDIR}/git"
31
32inherit autotools
33
34# Fix rsnapshot.conf.default:
35# don't inject the host path into target configs.
36EXTRA_OECONF += "--without-cp \
37 --without-rm \
38 --without-du \
39 --without-ssh \
40 --without-logger \
41 --without-rsync \
42 "