diff options
author | aehs29@gmail.com <aehs29@gmail.com> | 2019-09-04 15:57:57 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-09-07 11:29:02 -0700 |
commit | ace2fc4938312981ee1440448f94068fbce65f02 (patch) | |
tree | afac36ec2fda591cabb15ea04838ff4dc9444ee2 /meta-oe/recipes-support/remmina | |
parent | 48471748f3f892949a70012a4f9efcdc7407f4e6 (diff) | |
download | meta-openembedded-ace2fc4938312981ee1440448f94068fbce65f02.tar.gz |
remmina: Add recipe for the remmina remote desktop client
Remmina has become one of the most widely used RDP clients,
it uses freeRDP 2.0 as a backend and also supports multiple
network protocols like RSP, VNC, SPICE, NX, and SSH.
Link with libexecinfo explicitly on musl
limit to x86/x86_64 alone since spice is limited to these architectures
Signed-off-by: Alejandro Enedino Hernandez Samaniego <aehs29@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/remmina')
-rw-r--r-- | meta-oe/recipes-support/remmina/remmina_1.3.6.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/remmina/remmina_1.3.6.bb b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb new file mode 100644 index 000000000..b95c400b2 --- /dev/null +++ b/meta-oe/recipes-support/remmina/remmina_1.3.6.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+" | ||
2 | HOMEPAGE = "https://remmina.org" | ||
3 | SECTION = "Support" | ||
4 | LICENSE = "GPLv2 & openssl" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769" | ||
6 | DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi-ui libsodium libssh vte json-glib libsoup-2.4 libvncserver spice spice-protocol libsecret" | ||
7 | |||
8 | DEPENDS_append_libc-musl = "libexecinfo" | ||
9 | LDFLAGS_append_libc-musl = " -lexecinfo" | ||
10 | |||
11 | SRC_URI = "https://gitlab.com/Remmina/Remmina/-/archive/v${PV}/Remmina-v${PV}.tar.bz2 \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "6da599c3a5cab2df37a70f8fba2f5438" | ||
14 | SRC_URI[sha256sum] = "fbed745438bb0c21467b60cbd67c8148a9289b5ebc7482d06db443bea556af1a" | ||
15 | |||
16 | S = "${WORKDIR}/Remmina-v${PV}" | ||
17 | |||
18 | inherit cmake | ||
19 | |||
20 | EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF" | ||
21 | |||
22 | do_install_append(){ | ||
23 | # We dont need the extra stuff form other desktop environments | ||
24 | rm -rf ${D}/${datadir}/xsessions | ||
25 | rm -rf ${D}/${datadir}/metainfo | ||
26 | rm -rf ${D}/${datadir}/gnome-session | ||
27 | } | ||
28 | |||
29 | RDEPENDS_${PN} = "bash" | ||
30 | |||
31 | FILES_${PN}_append = " ${datadir}/icons/hicolor/*" | ||
32 | |||
33 | COMPATIBLE_HOST = '(x86_64|i.86).*-linux' | ||