summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/read-edid
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/read-edid
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/read-edid')
-rw-r--r--meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch28
-rw-r--r--meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb23
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch b/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch
new file mode 100644
index 000000000..440800235
--- /dev/null
+++ b/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch
@@ -0,0 +1,28 @@
1From eb7590cc2cdd5c35403af4567d8524e017010f1c Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 11 May 2013 07:58:17 +0200
4Subject: [PATCH] configure: remove check for x86.h, we don't build get-edid
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-status: Inappropriate [OE specific]
9---
10 configure.in | 2 --
11 1 file changed, 2 deletions(-)
12
13diff --git a/configure.in b/configure.in
14index ac85a21..f53e904 100644
15--- a/configure.in
16+++ b/configure.in
17@@ -8,8 +8,6 @@ dnl Checks for programs
18
19 AC_PROG_CC
20
21-AC_CHECK_HEADER([libx86.h], [], [AC_MSG_ERROR([libx86.h not found])])
22-
23 dnl Simple, huh?
24
25 AC_OUTPUT([Makefile])
26--
271.8.1.4
28
diff --git a/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb b/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb
new file mode 100644
index 000000000..b002906fa
--- /dev/null
+++ b/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "read-edid elucidates various very useful informations from a conforming PnP monitor"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d0bf70fa1ef81fe4741ec0e6231dadfd"
4
5SRC_URI = "http://polypux.org/projects/read-edid/read-edid-${PV}.tar.gz \
6 file://0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch"
7
8SRC_URI[md5sum] = "586e7fa1167773b27f4e505edc93274b"
9SRC_URI[sha256sum] = "246ec14ec509e09ac26fe6862b120481b2cc881e2f142ba40886d6eec15e77e8"
10
11inherit autotools
12
13do_compile() {
14 oe_runmake parse-edid
15}
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 parse-edid ${D}${bindir}
20}
21
22PACKAGES =+ "parse-edid"
23FILES_parse-edid = "${bindir}/parse-edid"