diff options
author | Armin Kuster <akuster@mvista.com> | 2014-06-03 21:29:30 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-06-10 12:29:00 +0200 |
commit | a97e06713ece10b4da7fc11e5f11bf1eca02cdf9 (patch) | |
tree | 65c1535b9fbfbbfec0b4fc6d03064e8cbe2ec073 /meta-oe/recipes-support/postgresql | |
parent | a3142cd44b322ce10bb719be1ceff44bef3300c2 (diff) | |
download | meta-openembedded-a97e06713ece10b4da7fc11e5f11bf1eca02cdf9.tar.gz |
postgresql: B!=S fix
This fixes a configure issue do to incorrect directory reference.
Signed-off-by: Armin Kuster <akuster@mvista.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/postgresql')
-rw-r--r-- | meta-oe/recipes-support/postgresql/postgresql.inc | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc index e1374fb75f..2858a844e3 100644 --- a/meta-oe/recipes-support/postgresql/postgresql.inc +++ b/meta-oe/recipes-support/postgresql/postgresql.inc | |||
@@ -107,14 +107,14 @@ do_configure() { | |||
107 | # do_configure_append | 107 | # do_configure_append |
108 | # workaround perl package related bugs | 108 | # workaround perl package related bugs |
109 | sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \ | 109 | sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \ |
110 | ${S}/src/Makefile.global | 110 | ${B}/src/Makefile.global |
111 | LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native" | 111 | LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native" |
112 | LIBNA="\${STAGING_LIBDIR_NATIVE}" | 112 | LIBNA="\${STAGING_LIBDIR_NATIVE}" |
113 | BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}" | 113 | BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}" |
114 | sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 114 | sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
115 | ${S}/src/Makefile.global | 115 | ${B}/src/Makefile.global |
116 | sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 116 | sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
117 | ${S}/src/Makefile.global | 117 | ${B}/src/Makefile.global |
118 | # remove the rpath, replace with correct lib path | 118 | # remove the rpath, replace with correct lib path |
119 | sed -i \ | 119 | sed -i \ |
120 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \ | 120 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \ |
@@ -124,7 +124,7 @@ do_configure() { | |||
124 | -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 124 | -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
125 | -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \ | 125 | -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \ |
126 | -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \ | 126 | -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \ |
127 | ${S}/src/Makefile.global | 127 | ${B}/src/Makefile.global |
128 | 128 | ||
129 | # workaround perl package's libperl.so problem | 129 | # workaround perl package's libperl.so problem |
130 | # we are using perlnative so this perl should have same version | 130 | # we are using perlnative so this perl should have same version |
@@ -158,11 +158,11 @@ do_install_append() { | |||
158 | oe_runmake DESTDIR=${D} -C contrib install | 158 | oe_runmake DESTDIR=${D} -C contrib install |
159 | # install tutorial | 159 | # install tutorial |
160 | install -d -m 0755 ${D}${libdir}/${BPN}/tutorial | 160 | install -d -m 0755 ${D}${libdir}/${BPN}/tutorial |
161 | install ${S}/src/tutorial/* ${D}${libdir}/${BPN}/tutorial | 161 | install ${B}/src/tutorial/* ${D}${libdir}/${BPN}/tutorial |
162 | 162 | ||
163 | # install COPYRIGHT README HISTORY | 163 | # install COPYRIGHT README HISTORY |
164 | install -d -m 0755 ${D}${docdir}/${BPN} | 164 | install -d -m 0755 ${D}${docdir}/${BPN} |
165 | for i in ${S}/{COPYRIGHT,README,HISTORY} ${S}/doc/{KNOWN_BUGS,MISSING_FEATURES,README*,bug.template}; do | 165 | for i in ${B}/{COPYRIGHT,README,HISTORY} ${B}/doc/{KNOWN_BUGS,MISSING_FEATURES,README*,bug.template}; do |
166 | [ -f $i ] && install $i ${D}${docdir}/${BPN} | 166 | [ -f $i ] && install $i ${D}${docdir}/${BPN} |
167 | done | 167 | done |
168 | 168 | ||