summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/postgresql/postgresql.inc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/postgresql/postgresql.inc
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/postgresql/postgresql.inc')
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc395
1 files changed, 395 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
new file mode 100644
index 000000000..1397f564d
--- /dev/null
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -0,0 +1,395 @@
1SUMMARY = "PostgreSQL is a powerful, open source relational database system."
2DESCRIPTION = "\
3 PostgreSQL is an advanced Object-Relational database management system \
4 (DBMS) that supports almost all SQL constructs (including \
5 transactions, subselects and user-defined types and functions). The \
6 postgresql package includes the client programs and libraries that \
7 you'll need to access a PostgreSQL DBMS server. These PostgreSQL \
8 client programs are programs that directly manipulate the internal \
9 structure of PostgreSQL databases on a PostgreSQL server. These client \
10 programs can be located on the same machine with the PostgreSQL \
11 server, or may be on a remote machine which accesses a PostgreSQL \
12 server over a network connection. This package contains the docs \
13 in HTML for the whole package, as well as command-line utilities for \
14 managing PostgreSQL databases on a PostgreSQL server. \
15 \
16 If you want to manipulate a PostgreSQL database on a local or remote \
17 PostgreSQL server, you need this package. You also need to install \
18 this package if you're installing the postgresql-server package. \
19 "
20HOMEPAGE = "http://www.postgresql.com"
21LICENSE = "BSD"
22DEPENDS = "zlib readline tzcode-native"
23INC_PR = "r0"
24
25ARM_INSTRUCTION_SET = "arm"
26
27SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \
28 file://postgresql.init \
29 file://postgresql-bashprofile \
30 file://postgresql.pam \
31 file://postgresql-setup \
32 file://postgresql.service \
33 file://0001-Use-pkg-config-for-libxml2-detection.patch \
34 file://0002-Predict-integer-overflow-to-avoid-buffer-overruns.patch \
35 file://0003-Shore-up-ADMIN-OPTION-restrictions.patch \
36 file://0004-Prevent-privilege-escalation-in-explicit-calls-to-PL.patch \
37 file://0005-Avoid-repeated-name-lookups-during-table-and-index-D.patch \
38 file://0006-Fix-handling-of-wide-datetime-input-output.patch \
39 file://0007-Make-pqsignal-available-to-pg_regress-of-ECPG-and-is.patch \
40 file://0008-Prevent-potential-overruns-of-fixed-size-buffers.patch \
41 "
42
43LEAD_SONAME = "libpq.so"
44
45# LDFLAGS for shared libraries
46export LDFLAGS_SL = "${LDFLAGS}"
47
48inherit autotools pkgconfig perlnative pythonnative useradd update-rc.d systemd
49
50SYSTEMD_SERVICE_${PN} = "postgresql.service"
51SYSTEMD_AUTO_ENABLE_${PN} = "disable"
52
53DEPENDS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-systemctl-native', '', d)}"
54pkg_postinst_${PN} () {
55 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd sysvinit', 'true', 'false', d)}; then
56 if [ -n "$D" ]; then
57 OPTS="--root=$D"
58 fi
59 systemctl $OPTS mask postgresql-server.service
60 fi
61}
62
63enable_pam = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
64PACKAGECONFIG ??= "${enable_pam} openssl python uuid libxml tcl nls libxml perl"
65PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
66PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
67PACKAGECONFIG[python] = "--with-python,--without-python,python,python"
68PACKAGECONFIG[uuid] = "--with-ossp-uuid,--without-ossp-uuid,ossp-uuid,"
69# when tcl native package is fixed change WORKDIR to STAGING_BINDIR_CROSS
70PACKAGECONFIG[tcl] = \
71 "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl,"
72PACKAGECONFIG[nls] = "--enable-nls,--disable-nls,,"
73PACKAGECONFIG[libxml] = "--with-libxml,--without-libxml,libxml2,libxml2"
74PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl"
75
76EXTRA_OECONF += "--enable-thread-safety --disable-rpath \
77 --datadir=${datadir}/${BPN} \
78 --sysconfdir=${sysconfdir}/${BPN} \
79 --without-krb5 \
80"
81EXTRA_OECONF_sh4 += "--disable-spinlocks"
82EXTRA_OECONF_aarch64 += "--disable-spinlocks"
83
84PACKAGES_DYNAMIC += "^${PN}-plperl ^${PN}-plperl-dbg \
85 ^${PN}-pltcl ^${PN}-pltcl-dbg \
86 ^${PN}-plpython ^${PN}-plpython-dbg \
87"
88
89python populate_packages_prepend() {
90
91 def fill_more(name, dbg=True):
92 if name is None or name.strip() == "":
93 return
94
95 fpack=d.getVar('PACKAGES') or ""
96 fpack="${PN}-" + name + " " + fpack
97 if dbg:
98 fpack="${PN}-" + name + "-dbg" + " " + fpack
99 d.setVar('PACKAGES', fpack)
100
101 conf=(d.getVar('PACKAGECONFIG', True) or "").split()
102 pack=d.getVar('PACKAGES') or ""
103 bb.debug(1, "PACKAGECONFIG=%s" % conf)
104 bb.debug(1, "PACKAGES1=%s" % pack )
105
106 if "perl" in conf :
107 fill_more("plperl")
108
109 if "tcl" in conf:
110 fill_more("pltcl")
111
112 if "python" in conf:
113 fill_more("plpython")
114
115 pack=d.getVar('PACKAGES', True) or ""
116 bb.debug(1, "PACKAGES2=%s" % pack)
117
118}
119
120do_configure() {
121 # do_configure_prepend
122 # make sure configure finds python includdirs with these envs
123 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
124 STAGING_INCDIR=${STAGING_INCDIR} \
125 STAGING_LIBDIR=${STAGING_LIBDIR}
126
127 # do_configure
128 autotools_do_configure
129
130 # do_configure_append
131 # workaround perl package related bugs
132 sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \
133 ${B}/src/Makefile.global
134 LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native"
135 LIBNA="\${STAGING_LIBDIR_NATIVE}"
136 BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}"
137 sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
138 ${B}/src/Makefile.global
139 sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
140 ${B}/src/Makefile.global
141 # remove the rpath, replace with correct lib path
142 sed -i \
143 -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \
144 -e "/^perl_embed_ldflags/s:-Wl,-rpath,${BLIBNA}::g" \
145 -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${LIBNA}::g" \
146 -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${BLIBNA}::g" \
147 -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \
148 -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \
149 -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \
150 ${B}/src/Makefile.global
151
152 # workaround perl package's libperl.so problem
153 # we are using perlnative so this perl should have same version
154 perl_version=`perl -v 2>/dev/null | \
155 sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'`
156 if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \
157 ! -h "${STAGING_LIBDIR}/libperl.so" ]; then
158 ln -sf ../../../libperl.so.5 \
159 ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so
160 fi
161}
162
163do_compile_append() {
164 oe_runmake -C contrib all
165}
166
167# server needs to configure user and group
168usernum = "28"
169groupnum = "28"
170USERADD_PACKAGES = "${PN}"
171USERADD_PARAM_${PN} = "-M -g postgres -o -r -d ${localstatedir}/lib/${BPN} \
172 -s /bin/bash -c 'PostgreSQL Server' -u ${usernum} postgres"
173GROUPADD_PARAM_${PN} = "-g ${groupnum} -o -r postgres"
174
175INITSCRIPT_PACKAGES = "${PN}"
176INITSCRIPT_NAME = "${BPN}-server"
177INITSCRIPT_PARAMS = "start 64 . stop 36 0 1 2 3 4 5 6 ."
178
179do_install_append() {
180 # install contrib
181 oe_runmake DESTDIR=${D} -C contrib install
182 # install tutorial
183 install -d -m 0755 ${D}${libdir}/${BPN}/tutorial
184 install ${B}/src/tutorial/* ${D}${libdir}/${BPN}/tutorial
185
186 # install COPYRIGHT README HISTORY
187 install -d -m 0755 ${D}${docdir}/${BPN}
188 for i in ${B}/{COPYRIGHT,README,HISTORY} ${B}/doc/{KNOWN_BUGS,MISSING_FEATURES,README*,bug.template}; do
189 [ -f $i ] && install $i ${D}${docdir}/${BPN}
190 done
191
192 # install dirs and server init
193 install -d ${D}${sysconfdir}/init.d
194 install -m 0755 ${WORKDIR}/${BPN}.init ${D}${sysconfdir}/init.d/${BPN}-server
195 sed -i -e "s/^PGVERSION=.*$/PGVERSION=${PV}/g" ${D}${sysconfdir}/init.d/${BPN}-server
196 install -m 0755 ${WORKDIR}/${BPN}-setup ${D}${bindir}/${BPN}-setup
197 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/data
198 install -d -m 700 ${D}${localstatedir}/lib/${BPN}/backups
199 install -m 644 ${WORKDIR}/${BPN}-bashprofile ${D}${localstatedir}/lib/${BPN}/.bash_profile
200 chown -R postgres:postgres ${D}${localstatedir}/lib/${BPN}
201 # multiple server config directory
202 install -d -m 700 ${D}${sysconfdir}/default/${BPN}
203
204 if [ "${@d.getVar('enable_pam', True)}" = "pam" ]; then
205 install -d ${D}${sysconfdir}/pam.d
206 install -m 644 ${WORKDIR}/postgresql.pam ${D}${sysconfdir}/pam.d/postgresql
207 fi
208
209 # Install systemd unit files
210 install -d ${D}${systemd_unitdir}/system
211 install -m 0644 ${WORKDIR}/postgresql.service ${D}${systemd_unitdir}/system
212 sed -i -e 's,@BINDIR@,${bindir},g' \
213 ${D}${systemd_unitdir}/system/postgresql.service
214}
215
216SSTATE_SCAN_FILES += "Makefile.global"
217
218PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \
219 libecpg-compat-dbg libecpg-compat libecpg-compat-dev \
220 libecpg-dbg libecpg libecpg-dev libecpg-staticdev libecpg-doc \
221 libpq-dbg libpq libpq-dev libpq-staticdev \
222 libpgtypes-dbg libpgtypes libpgtypes-staticdev libpgtypes-dev \
223 ${PN}-contrib ${PN}-contrib-dbg \
224"
225
226FILES_${PN} += "${sysconfdir}/init.d/${BPN}-server \
227 ${localstatedir}/lib/${BPN}/data ${localstatedir}/lib/${BPN}/backups \
228 ${localstatedir}/lib/${BPN}/.bash_profile ${sysconfdir}/default/${BPN} \
229 ${libdir}/${BPN}/dict_snowball.so ${libdir}/${BPN}/plpgsql.so \
230 ${libdir}/${BPN}/euc2004_sjis2004.so \
231 ${libdir}/${BPN}/libpqwalreceiver.so \
232 ${libdir}/${BPN}/*_and_*.so \
233 ${@'${sysconfdir}/pam.d/postgresql' \
234 if 'pam' == d.getVar('enable_pam', True) \
235 else ''} \
236"
237
238FILES_${PN}-dbg += " ${libdir}/${BPN}/.debug/dict_snowball.so \
239 ${libdir}/${BPN}/.debug/plpgsql.so \
240 ${libdir}/${BPN}/.debug/euc2004_sjis2004.so \
241 ${libdir}/${BPN}/.debug/libpqwalreceiver.so \
242 ${libdir}/${BPN}/.debug/*_and_*.so \
243"
244
245FILES_${PN}-client = "${bindir}/clusterdb \
246 ${bindir}/createdb \
247 ${bindir}/createlang \
248 ${bindir}/createuser \
249 ${bindir}/dropdb \
250 ${bindir}/droplang \
251 ${bindir}/dropuser \
252 ${bindir}/pg_dump \
253 ${bindir}/pg_dumpall \
254 ${bindir}/pg_restore \
255 ${bindir}/psql \
256 ${bindir}/reindexdb \
257 ${bindir}/vacuumdb \
258 ${bindir}/vacuumlo \
259 ${datadir}/${BPN}/psqlrc.sample"
260
261FILES_${PN}-client-doc = "${mandir}/man1/clusterdb.* \
262 ${mandir}/man1/createdb.* ${mandir}/man1/createlang.* \
263 ${mandir}/man1/createuser.* ${mandir}/man1/dropdb.* \
264 ${mandir}/man1/droplang.* ${mandir}/man1/dropuser.* \
265 ${mandir}/man1/pg_dump.* ${mandir}/man1/pg_dumpall.* \
266 ${mandir}/man1/pg_restore.* ${mandir}/man1/psql.* \
267 ${mandir}/man1/reindexdb.* ${mandir}/man1/vacuumdb.* \
268 ${mandir}/man7/* \
269"
270
271FILES_${PN}-doc += "${docdir}/${BPN}/html ${libdir}/${BPN}/tutorial/ \
272 ${mandir}/man1/initdb.* ${mandir}/man1/pg_controldata.* \
273 ${mandir}/man1/pg_ctl.* ${mandir}/man1/pg_resetxlog.* \
274 ${mandir}/man1/postgres.* ${mandir}/man1/postmaster.* \
275"
276
277FILES_${PN}-timezone = "${datadir}/${BPN}/timezone \
278 ${datadir}/${BPN}/timezonesets \
279"
280RDEPENDS_${PN} += "${PN}-timezone"
281FILES_${PN}-server-dev = "${includedir}/${BPN}/server"
282
283FILES_libecpg = "${libdir}/libecpg*${SOLIBS}"
284FILES_libecpg-dbg = "${libdir}/.debug/libecpg*"
285FILES_libecpg-dev = "${libdir}/libecpg*${SOLIBSDEV} \
286 ${libdir}/libpgtypes*${SOLIBSDEV} \
287 ${includedir}/ecpg*.h ${includedir}/${BPN}/ecpg*.h \
288 ${includedir}/pgtypes*.h ${includedir}/${BPN}/informix \
289 ${includedir}/sql3types.h ${includedir}/sqlca.h"
290FILES_libecpg-doc = "${mandir}/man1/ecpg.*"
291FILES_libecpg-staticdev = "${libdir}/libecpg*.a"
292SECTION_libecpg-staticdev = "devel"
293RDEPENDS_libecpg-staticdev = "libecpg-dev (= ${EXTENDPKGV})"
294
295FILES_libpq = "${libdir}/libpq*${SOLIBS}"
296FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${BPN}/pgxs/src/test/regress/.debug/*"
297FILES_libpq-dev = "${libdir}/libpq*${SOLIBSDEV} \
298 ${includedir}"
299FILES_libpq-staticdev = "${libdir}/libpq*.a ${libdir}/libpgport.a"
300SECTION_libpq-staticdev = "devel"
301RDEPENDS_libpq-staticdev = "libpq-dev (= ${EXTENDPKGV})"
302
303FILES_libecpg-compat = "${libdir}/libecpg_compat*${SOLIBS}"
304FILES_libecpg-compat-dbg = "${libdir}/.debug/libecpg_compat*"
305FILES_libecpg-compat-dev = "${libdir}/libecpg_compat*${SOLIBS}"
306FILES_libpgtypes = "${libdir}/libpgtypes*${SOLIBS}"
307FILES_libpgtypes-dbg = "${libdir}/.debug/libpgtypes*"
308FILES_libpgtypes-staticdev = "${libdir}/libpgtypes*.a"
309FILES_libpgtypes-dev = "${libdir}/libpgtypes*${SOLIBS} ${includedir}/pgtypes*.h"
310
311FILES_${PN}-contrib = " ${bindir}/oid2name ${bindir}/pg_standby \
312 ${bindir}/pgbench ${bindir}/vacuumlo \
313 ${S}/contrib/spi/*.example \
314 ${libdir}/${BPN}/_int.so ${libdir}/${BPN}/adminpack.so \
315 ${libdir}/${BPN}/autoinc.so ${libdir}/${BPN}/auto_explain.so \
316 ${libdir}/${BPN}/auth_delay.so ${libdir}/${BPN}/btree_gin.so \
317 ${libdir}/${BPN}/btree_gist.so ${libdir}/${BPN}/.so \
318 ${libdir}/${BPN}/chkpass.so ${libdir}/${BPN}/citext.so \
319 ${libdir}/${BPN}/cube.so ${libdir}/${BPN}/dblink.so \
320 ${libdir}/${BPN}/dict_int.so ${libdir}/${BPN}/dict_xsyn.so \
321 ${libdir}/${BPN}/dummy_seclabel.so ${libdir}/${BPN}/earthdistance.so \
322 ${libdir}/${BPN}/file_fdw.so ${libdir}/${BPN}/fuzzystrmatch.so \
323 ${libdir}/${BPN}/hstore.so ${libdir}/${BPN}/insert_username.so \
324 ${libdir}/${BPN}/isn.so ${libdir}/${BPN}/lo.so \
325 ${libdir}/${BPN}/ltree.so ${libdir}/${BPN}/moddatetime.so \
326 ${libdir}/${BPN}/pageinspect.so ${libdir}/${BPN}/pg_buffercache.so \
327 ${libdir}/${BPN}/pg_freespacemap.so ${libdir}/${BPN}/pg_trgm.so \
328 ${libdir}/${BPN}/pgcrypto.so ${libdir}/${BPN}/pgrowlocks.so \
329 ${libdir}/${BPN}/pgstattuple.so ${libdir}/${BPN}/pg_stat_statements.so \
330 ${libdir}/${BPN}/refint.so ${libdir}/${BPN}/seg.so \
331 ${libdir}/${BPN}/sslinfo.so \
332 ${libdir}/${BPN}/tablefunc.so \
333 ${libdir}/${BPN}/test_parser.so ${libdir}/${BPN}/timetravel.so \
334 ${libdir}/${BPN}/tsearch2.so ${libdir}/${BPN}/uuid-ossp.so \
335 ${libdir}/${BPN}/pgxml.so ${libdir}/${BPN}/passwordcheck.so \
336 ${libdir}/${BPN}/pg_upgrade_support.so ${libdir}/${BPN}/.so \
337 ${libdir}/${BPN}/unaccent.so \
338"
339FILES_${PN}-contrib-dbg = " \
340 ${libdir}/${BPN}/.debug/_int.so ${libdir}/${BPN}/.debug/adminpack.so \
341 ${libdir}/${BPN}/.debug/autoinc.so ${libdir}/${BPN}/.debug/auto_explain.so \
342 ${libdir}/${BPN}/.debug/auth_delay.so ${libdir}/${BPN}/.debug/btree_gin.so \
343 ${libdir}/${BPN}/.debug/btree_gist.so ${libdir}/${BPN}/.debug/.so \
344 ${libdir}/${BPN}/.debug/chkpass.so ${libdir}/${BPN}/.debug/citext.so \
345 ${libdir}/${BPN}/.debug/cube.so ${libdir}/${BPN}/.debug/dblink.so \
346 ${libdir}/${BPN}/.debug/dict_int.so ${libdir}/${BPN}/.debug/dict_xsyn.so \
347 ${libdir}/${BPN}/.debug/dummy_seclabel.so \
348 ${libdir}/${BPN}/.debug/earthdistance.so \
349 ${libdir}/${BPN}/.debug/file_fdw.so ${libdir}/${BPN}/.debug/fuzzystrmatch.so \
350 ${libdir}/${BPN}/.debug/hstore.so ${libdir}/${BPN}/.debug/insert_username.so \
351 ${libdir}/${BPN}/.debug/isn.so ${libdir}/${BPN}/.debug/lo.so \
352 ${libdir}/${BPN}/.debug/ltree.so ${libdir}/${BPN}/.debug/moddatetime.so \
353 ${libdir}/${BPN}/.debug/pageinspect.so \
354 ${libdir}/${BPN}/.debug/pg_buffercache.so \
355 ${libdir}/${BPN}/.debug/pg_freespacemap.so \
356 ${libdir}/${BPN}/.debug/pg_trgm.so \
357 ${libdir}/${BPN}/.debug/pgcrypto.so ${libdir}/${BPN}/.debug/pgrowlocks.so \
358 ${libdir}/${BPN}/.debug/pgstattuple.so \
359 ${libdir}/${BPN}/.debug/pg_stat_statements.so \
360 ${libdir}/${BPN}/.debug/refint.so ${libdir}/${BPN}/.debug/seg.so \
361 ${libdir}/${BPN}/.debug/sslinfo.so \
362 ${libdir}/${BPN}/.debug/tablefunc.so \
363 ${libdir}/${BPN}/.debug/test_parser.so ${libdir}/${BPN}/.debug/timetravel.so \
364 ${libdir}/${BPN}/.debug/tsearch2.so ${libdir}/${BPN}/.debug/uuid-ossp.so \
365 ${libdir}/${BPN}/.debug/pgxml.so ${libdir}/${BPN}/.debug/passwordcheck.so \
366 ${libdir}/${BPN}/.debug/pg_upgrade_support.so \
367 ${libdir}/${BPN}/.debug/unaccent.so \
368"
369DESCRIPTION_${PN}-contrib = "The postgresql-contrib package contains \
370 contributed packages that are included in the PostgreSQL distribution."
371
372FILES_${PN}-pltcl = "${libdir}/${BPN}/pltcl.so ${bindir}/pltcl_delmod \
373 ${binddir}/pltcl_listmod ${bindir}/pltcl_loadmod \
374 ${datadir}/${BPN}/unknown.pltcl"
375FILES_${PN}-pltcl-dbg = "${libdir}/${BPN}/.debug/pltcl.so"
376SUMMARY_${PN}-pltcl = "The Tcl procedural language for PostgreSQL"
377DESCRIPTION_${PN}-pltcl = "PostgreSQL is an advanced Object-Relational \
378 database management system. The postgresql-pltcl package contains the PL/Tcl \
379 procedural language for the backend."
380
381FILES_${PN}-plperl = "${libdir}/${BPN}/plperl.so"
382FILES_${PN}-plperl-dbg = "${libdir}/${BPN}/.debug/plperl.so"
383SUMMARY_${PN}-plperl = "The Perl procedural language for PostgreSQL"
384DESCRIPTION_${PN}-plperl = "PostgreSQL is an advanced Object-Relational \
385 database management system. The postgresql-plperl package contains the \
386 PL/Perl procedural language for the backend."
387
388# In version 8, it will be plpython.so
389# In version 9, it might be plpython{2,3}.so depending on python2 or 3
390FILES_${PN}-plpython = "${libdir}/${BPN}/plpython*.so"
391FILES_${PN}-plpython-dbg = "${libdir}/${BPN}/.debug/plpython*.so"
392SUMMARY_${PN}-plpython = "The Python procedural language for PostgreSQL"
393DESCRIPTION_${PN}-plpython = "PostgreSQL is an advanced Object-Relational \
394 database management system. The postgresql-plpython package contains \
395 the PL/Python procedural language for the backend."