diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-07-26 18:23:27 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-07-27 08:54:40 -0700 |
commit | 769d79278403a193bdc4fbb68c9e21aab6cb71d1 (patch) | |
tree | 19a04c84b5b4a0d3f23f582d12e6a31e247baeab /meta-oe/recipes-support/portaudio | |
parent | 8af2f17a6fa8bf282c4c27054adbea1bf0873069 (diff) | |
download | meta-openembedded-769d79278403a193bdc4fbb68c9e21aab6cb71d1.tar.gz |
portaudio-v19: Update to latest tip of trunk
The patches are already upstreamed therefore deleted.
Additionally it fixes shared library versioning scheme which
in turn fixes build of dependent package python3-pyaudio failing with
QA Issue: /usr/lib/python3.11/site-packages/pyaudio/_portaudio.cpython-311-x86_64-linux-gnu.so contained in package python3-pyaudio requires libportaudio.so.2()(64bit), but no providers found in RDEPENDS:python3-pyaudio? [file-rdeps]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/portaudio')
3 files changed, 6 insertions, 91 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch deleted file mode 100644 index d6c6300ec..000000000 --- a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-Find-jack.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 8ec1b100afda5b3e31f9d44af04b04b16dfff2e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com> | ||
3 | Date: Tue, 18 May 2021 00:15:46 +0200 | ||
4 | Subject: [PATCH] Find jack with pkgconfig | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> | ||
12 | --- | ||
13 | CMakeLists.txt | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
17 | index 122fe93..ab7d7f5 100644 | ||
18 | --- a/CMakeLists.txt | ||
19 | +++ b/CMakeLists.txt | ||
20 | @@ -274,7 +274,8 @@ ELSE() | ||
21 | |||
22 | ELSEIF(UNIX) | ||
23 | |||
24 | - FIND_PACKAGE(Jack) | ||
25 | + find_package(PkgConfig REQUIRED) | ||
26 | + pkg_check_modules (JACK jack) | ||
27 | IF(JACK_FOUND) | ||
28 | OPTION(PA_USE_JACK "Enable support for Jack" ON) | ||
29 | ELSE() | ||
30 | -- | ||
31 | 2.31.1 | ||
32 | |||
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch deleted file mode 100644 index 892399de7..000000000 --- a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From ced7af0420c1df0ac02f0c25e7c3534431ebd7fd Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 4 Jul 2021 17:09:49 -0700 | ||
4 | Subject: [PATCH] cmake: Use GNUInstallDirs | ||
5 | |||
6 | Helps install cmakefiles in right libdir | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/PortAudio/portaudio/pull/610] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | CMakeLists.txt | 12 +++++++----- | ||
12 | 1 file changed, 7 insertions(+), 5 deletions(-) | ||
13 | |||
14 | --- a/CMakeLists.txt | ||
15 | +++ b/CMakeLists.txt | ||
16 | @@ -6,6 +6,8 @@ | ||
17 | |||
18 | CMAKE_MINIMUM_REQUIRED(VERSION 2.8) | ||
19 | |||
20 | +include(GNUInstallDirs) | ||
21 | + | ||
22 | # Check if the user is building PortAudio stand-alone or as part of a larger | ||
23 | # project. If this is part of a larger project (i.e. the CMakeLists.txt has | ||
24 | # been imported by some other CMakeLists.txt), we don't want to trump over | ||
25 | @@ -452,18 +454,18 @@ IF(NOT PA_OUTPUT_OSX_FRAMEWORK AND NOT P | ||
26 | CONFIGURE_FILE(cmake_support/portaudio-2.0.pc.in ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc @ONLY) | ||
27 | INSTALL(FILES README.md DESTINATION share/doc/portaudio) | ||
28 | INSTALL(FILES LICENSE.txt DESTINATION share/doc/portaudio) | ||
29 | - INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION lib/pkgconfig) | ||
30 | + INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig) | ||
31 | INSTALL(FILES ${PA_PUBLIC_INCLUDES} DESTINATION include) | ||
32 | INSTALL(TARGETS ${PA_TARGETS} | ||
33 | EXPORT portaudio-targets | ||
34 | - RUNTIME DESTINATION bin | ||
35 | - LIBRARY DESTINATION lib | ||
36 | - ARCHIVE DESTINATION lib) | ||
37 | - INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "lib/cmake/portaudio") | ||
38 | + RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR} | ||
39 | + LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} | ||
40 | + ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}) | ||
41 | + INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio") | ||
42 | EXPORT(TARGETS ${PA_TARGETS} FILE "${PROJECT_BINARY_DIR}/cmake/portaudio/portaudioTargets.cmake") | ||
43 | INSTALL(FILES "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfig.cmake" | ||
44 | "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfigVersion.cmake" | ||
45 | - DESTINATION "lib/cmake/portaudio") | ||
46 | + DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio") | ||
47 | |||
48 | IF (NOT TARGET uninstall) | ||
49 | CONFIGURE_FILE( | ||
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb index f34912ed2..c49a2599a 100644 --- a/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb +++ b/meta-oe/recipes-support/portaudio/portaudio-v19_19.7.0.bb | |||
@@ -3,18 +3,17 @@ SECTION = "libs/multimedia" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df" |
5 | 5 | ||
6 | PV = "v190700" | 6 | PV .= "+git${SRCPV}" |
7 | |||
8 | SRC_URI = "git://github.com/PortAudio/portaudio.git;branch=master;protocol=https" | ||
9 | SRCREV = "929e2e8f7af281c5eb4fa07758930d542ec43d97" | ||
7 | 10 | ||
8 | SRC_URI = " \ | ||
9 | git://github.com/PortAudio/portaudio.git;branch=master;protocol=https \ | ||
10 | file://0001-Find-jack.patch \ | ||
11 | file://0001-cmake-Use-GNUInstallDirs.patch \ | ||
12 | " | ||
13 | SRCREV = "147dd722548358763a8b649b3e4b41dfffbcfbb6" | ||
14 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
15 | 12 | ||
16 | inherit cmake pkgconfig | 13 | inherit cmake pkgconfig |
17 | 14 | ||
15 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" | ||
16 | |||
18 | PACKAGECONFIG ??= "alsa jack" | 17 | PACKAGECONFIG ??= "alsa jack" |
19 | PACKAGECONFIG[alsa] = ",,alsa-lib" | 18 | PACKAGECONFIG[alsa] = ",,alsa-lib" |
20 | PACKAGECONFIG[jack] = ",,jack" | 19 | PACKAGECONFIG[jack] = ",,jack" |
@@ -28,6 +27,3 @@ do_install:append() { | |||
28 | done | 27 | done |
29 | fi | 28 | fi |
30 | } | 29 | } |
31 | |||
32 | FILES_SOLIBSDEV = "" | ||
33 | FILES:${PN} += "${libdir}/libportaudio.so" | ||