diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/poppler | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-data_0.4.5.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler.inc | 10 |
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-data_0.4.5.bb b/meta-oe/recipes-support/poppler/poppler-data_0.4.5.bb index cbb02b478..56a30e4e5 100644 --- a/meta-oe/recipes-support/poppler/poppler-data_0.4.5.bb +++ b/meta-oe/recipes-support/poppler/poppler-data_0.4.5.bb | |||
@@ -11,7 +11,7 @@ do_compile() { | |||
11 | } | 11 | } |
12 | 12 | ||
13 | do_install() { | 13 | do_install() { |
14 | oe_runmake install DESTDIR=${D} | 14 | oe_runmake install DESTDIR=${D} |
15 | } | 15 | } |
16 | 16 | ||
17 | FILES_${PN} += "${datadir}" | 17 | FILES_${PN} += "${datadir}" |
diff --git a/meta-oe/recipes-support/poppler/poppler.inc b/meta-oe/recipes-support/poppler/poppler.inc index a624c1b95..d0c0074f9 100644 --- a/meta-oe/recipes-support/poppler/poppler.inc +++ b/meta-oe/recipes-support/poppler/poppler.inc | |||
@@ -8,11 +8,11 @@ SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" | |||
8 | inherit autotools pkgconfig | 8 | inherit autotools pkgconfig |
9 | 9 | ||
10 | EXTRA_OECONF = "\ | 10 | EXTRA_OECONF = "\ |
11 | --enable-xpdf-headers \ | 11 | --enable-xpdf-headers \ |
12 | --disable-gtk-test \ | 12 | --disable-gtk-test \ |
13 | --disable-poppler-qt \ | 13 | --disable-poppler-qt \ |
14 | --disable-poppler-qt4 \ | 14 | --disable-poppler-qt4 \ |
15 | --enable-zlib \ | 15 | --enable-zlib \ |
16 | " | 16 | " |
17 | 17 | ||
18 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | 18 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points |