diff options
author | Joshua Lock <joshua.lock@collabora.co.uk> | 2015-12-10 15:32:34 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-12-18 12:36:56 +0100 |
commit | 58739d4a7986f14b4776ef1173a2d02778cfafdf (patch) | |
tree | 8833a904da82f37a09b90e8a9478bab17ef49b79 /meta-oe/recipes-support/poppler | |
parent | c9ceac8eac58ea3879d22b9cfe240b4690c2e253 (diff) | |
download | meta-openembedded-58739d4a7986f14b4776ef1173a2d02778cfafdf.tar.gz |
poppler-data: install CMap resources for CJK glyph support
CID-keyed fonts, as commonly used to support pictographic East
Asian character sets require Character Maps which unidirectionally
map character codes (i.e. Unicode encoding) to CID (the glyphs in
the font face).
Without a CMap poppler isn't able to correctly PDF files in
Chinese, Japanese or Korean without embedded fonts.
This change installs a copy of the Identity files from Adobe's
CMap Resources[1] based on a similar change in Fedora's
poppler-data[2][3].
This is an updated version of the v2 patch originally created and sent
by my colleague, Joshua Lock.
1. https://github.com/adobe-type-tools/cmap-resources
2. http://pkgs.fedoraproject.org/cgit/poppler-data.git/tree/poppler-data.spec#n18
3. https://bugzilla.redhat.com/show_bug.cgi?id=842351
Co-Authored-By: Bob Ham <bob.ham@collabora.com>
Signed-off-by: Bob Ham <bob.ham@collabora.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb | 21 |
1 files changed, 18 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb b/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb index 4f55e9f2d..27c411028 100644 --- a/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb +++ b/meta-oe/recipes-support/poppler/poppler-data_0.4.7.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base" | 1 | SUMMARY = "Encoding files for Poppler" |
2 | LICENSE = "Adobe" | 2 | DESCRIPTION = "Encoding files for use with poppler that enable poppler to \ |
3 | correctly render CJK and Cyrrilic." | ||
4 | LICENSE = "BSD & GPLv2 & GPLv3+" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \ | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \ |
4 | file://COPYING.adobe;md5=63c6a8a9df204c00461fa5f163d8a663 \ | 6 | file://COPYING.adobe;md5=63c6a8a9df204c00461fa5f163d8a663 \ |
5 | file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \ | 7 | file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \ |
@@ -7,15 +9,28 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \ | |||
7 | 9 | ||
8 | inherit allarch | 10 | inherit allarch |
9 | 11 | ||
10 | SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.gz" | 12 | INHIBIT_DEFAULT_DEPS = "1" |
13 | |||
14 | CMAP_RESOURCES_BASE = "https://github.com/adobe-type-tools/cmap-resources/raw/0561ebca035813ed04c3485bca636a0aa7abdc1d/cmapresources_identity-0/CMap" | ||
15 | |||
16 | SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.gz \ | ||
17 | ${CMAP_RESOURCES_BASE}/Identity-H;name=idh \ | ||
18 | ${CMAP_RESOURCES_BASE}/Identity-V;name=idv" | ||
19 | |||
11 | SRC_URI[md5sum] = "636a8f2b9f6df9e7ced8ec0946961eaf" | 20 | SRC_URI[md5sum] = "636a8f2b9f6df9e7ced8ec0946961eaf" |
12 | SRC_URI[sha256sum] = "e752b0d88a7aba54574152143e7bf76436a7ef51977c55d6bd9a48dccde3a7de" | 21 | SRC_URI[sha256sum] = "e752b0d88a7aba54574152143e7bf76436a7ef51977c55d6bd9a48dccde3a7de" |
22 | SRC_URI[idh.md5sum] = "009c93cf0141ab7bd6acb7eea14306cc" | ||
23 | SRC_URI[idh.sha256sum] = "ae702c203a82ea124e9b96590f821db6fbf8754e2c4547a9dba0e82f94739e95" | ||
24 | SRC_URI[idv.md5sum] = "2f32a45d43d001c26eeac6b878855fbf" | ||
25 | SRC_URI[idv.sha256sum] = "89a85daf7031e93c883e76b9168a226dfd585bf5506e9e1956772163f15cb082" | ||
13 | 26 | ||
14 | do_compile() { | 27 | do_compile() { |
15 | } | 28 | } |
16 | 29 | ||
17 | do_install() { | 30 | do_install() { |
18 | oe_runmake install DESTDIR=${D} | 31 | oe_runmake install DESTDIR=${D} |
32 | install -d ${D}${datadir}/poppler/cMap | ||
33 | install -m644 ${WORKDIR}/Identity-* ${D}${datadir}/poppler/cMap/ | ||
19 | } | 34 | } |
20 | 35 | ||
21 | FILES_${PN} += "${datadir}" | 36 | FILES_${PN} += "${datadir}" |