diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-04-10 13:24:47 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2011-04-10 14:43:41 +0200 |
commit | 89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch) | |
tree | b073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-support/poppler | |
parent | e66079da37992abd54486488aa06a99bf7a4198c (diff) | |
download | meta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz |
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-support/poppler')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb | 24 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler-fpu.inc | 6 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler.inc | 25 | ||||
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_0.12.3.bb | 10 |
4 files changed, 65 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb b/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb new file mode 100644 index 0000000000..e3fd54b726 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler-data_0.4.0.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base." | ||
2 | LICENSE = "Adobe" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4870b98343f0bbb25fa43b9d2ba59448 \ | ||
4 | file://COPYING.adobe;md5=63c6a8a9df204c00461fa5f163d8a663 \ | ||
5 | file://COPYING.gpl2;md5=751419260aa954499f7abaabaa882bbe \ | ||
6 | " | ||
7 | |||
8 | PR = "r1" | ||
9 | |||
10 | SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" | ||
11 | |||
12 | do_compile() { | ||
13 | } | ||
14 | |||
15 | do_install() { | ||
16 | oe_runmake install DESTDIR=${D} | ||
17 | } | ||
18 | |||
19 | FILES_${PN} += "${datadir}" | ||
20 | PACKAGE_ARCH = "all" | ||
21 | |||
22 | |||
23 | SRC_URI[md5sum] = "6975bf8e9ea2cfb42b9ecdbcc257cf57" | ||
24 | SRC_URI[sha256sum] = "5caf7e10b7b0c6a4e1e753af09be52224e88bb8fbcb47794ad72b99b9e24b109" | ||
diff --git a/meta-oe/recipes-support/poppler/poppler-fpu.inc b/meta-oe/recipes-support/poppler/poppler-fpu.inc new file mode 100644 index 0000000000..a26273020a --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler-fpu.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | |||
2 | def get_poppler_fpu_setting(bb, d): | ||
3 | if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]: | ||
4 | return "--enable-fixedpoint" | ||
5 | return "" | ||
6 | |||
diff --git a/meta-oe/recipes-support/poppler/poppler.inc b/meta-oe/recipes-support/poppler/poppler.inc new file mode 100644 index 0000000000..85c3983160 --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler.inc | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base." | ||
2 | DEPENDS = "fontconfig jpeg zlib gtk+ cairo" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
5 | |||
6 | SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | EXTRA_OECONF = "\ | ||
11 | --enable-xpdf-headers \ | ||
12 | --disable-gtk-test \ | ||
13 | --disable-poppler-qt \ | ||
14 | --disable-poppler-qt4 \ | ||
15 | --enable-zlib \ | ||
16 | " | ||
17 | |||
18 | # check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | ||
19 | require poppler-fpu.inc | ||
20 | EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}" | ||
21 | |||
22 | PACKAGES =+ "libpoppler libpoppler-glib" | ||
23 | FILES_libpoppler = "${libdir}/libpoppler.so.*" | ||
24 | FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*" | ||
25 | |||
diff --git a/meta-oe/recipes-support/poppler/poppler_0.12.3.bb b/meta-oe/recipes-support/poppler/poppler_0.12.3.bb new file mode 100644 index 0000000000..ce1952e1ed --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler_0.12.3.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | require poppler.inc | ||
2 | |||
3 | DEPENDS += "lcms" | ||
4 | |||
5 | EXTRA_OECONF_append = " --disable-abiword-output " | ||
6 | |||
7 | RDEPENDS_${PN} = "poppler-data" | ||
8 | |||
9 | SRC_URI[md5sum] = "d0ca8344d8d94e27aaba6d432688365d" | ||
10 | SRC_URI[sha256sum] = "7a4ffe6d2950c446c285700d3b2dc399540a27ce635dd712aff646f02f8dfbcc" | ||