summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pngcheck
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/pngcheck
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/pngcheck')
-rw-r--r--meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
new file mode 100644
index 000000000..445e8ad8e
--- /dev/null
+++ b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
@@ -0,0 +1,22 @@
1SUMMARY = "pngcheck verifies the integrity of PNG, JNG and MNG files"
2HOMEPAGE = "http://www.libpng.org/pub/png/apps/pngcheck.html"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://gpl/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = "zlib libpng"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/project/png-mng/${BPN}/${PV}/${BPN}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "980bd6d9a3830fdce746d7fe3c9166ee"
10SRC_URI[sha256sum] = "77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db25690f35f"
11
12do_compile() {
13 oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS=${STAGING_DIR_HOST}${libdir}/libz.a
14}
15
16do_install() {
17 install -d ${D}${bindir}
18 install pngcheck ${D}${bindir}
19 install png-fix-IDAT-windowsize ${D}${bindir}
20 install pngsplit ${D}${bindir}
21}
22