diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-05 16:58:59 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:40:27 +0200 |
commit | 9087a59b1c3f9708642a2327b0cf6ecceac0a66f (patch) | |
tree | bd06baf32b5a7414c084be5a6e04af98fd674fb4 /meta-oe/recipes-support/pidgin | |
parent | fc1ee271f457ae2dd0ec50b4d2f8caf5b01a2cbe (diff) | |
download | meta-openembedded-9087a59b1c3f9708642a2327b0cf6ecceac0a66f.tar.gz |
pidgin: use pkg-config instead of hardcoded paths or python-config
* also fix following QA warning:
WARNING: pidgin-2.10.12-r0 do_package: QA Issue: pidgin: Files/directories were installed but not shipped in any package:
/usr/share/appdata
/usr/share/appdata/pidgin.appdata.xml
Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
pidgin: 2 installed and not shipped files. [installed-vs-shipped]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pidgin')
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch | 51 | ||||
-rw-r--r-- | meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb | 2 |
2 files changed, 30 insertions, 23 deletions
diff --git a/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch index cfc681cd8..72bf4ed41 100644 --- a/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch +++ b/meta-oe/recipes-support/pidgin/pidgin/pidgin-cross-python-265.patch | |||
@@ -1,27 +1,34 @@ | |||
1 | From 428836ba7f9048970626ef0d6b805107f7c52d33 Mon Sep 17 00:00:00 2001 | 1 | Use pkg-config instead of ${PYTHON}-config to find python |
2 | From: Herrie <github.com@herrie.org> | ||
3 | Date: Thu, 5 May 2016 13:33:29 +0200 | ||
4 | Subject: [PATCH] Updated python patch | ||
5 | 2 | ||
6 | --- | 3 | diff -uNr pidgin-2.10.12.orig/configure.ac pidgin-2.10.12/configure.ac |
7 | configure.ac | 6 +++--- | 4 | --- pidgin-2.10.12.orig/configure.ac 2016-01-01 00:19:40.000000000 +0100 |
8 | 1 file changed, 3 insertions(+), 3 deletions(-) | 5 | +++ pidgin-2.10.12/configure.ac 2016-05-05 16:55:13.258945925 +0200 |
9 | 6 | @@ -1585,20 +1585,15 @@ | |
10 | diff --git a/configure.ac b/configure.ac | 7 | dnl Check for Python headers (currently useful only for libgnt) |
11 | index 94ea8cf..2285adb 100644 | 8 | dnl (Thanks to XChat) |
12 | --- a/configure.ac | ||
13 | +++ b/configure.ac | ||
14 | @@ -1587,9 +1587,9 @@ dnl (Thanks to XChat) | ||
15 | if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then | 9 | if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then |
16 | AC_MSG_CHECKING(for Python compile flags) | 10 | - AC_MSG_CHECKING(for Python compile flags) |
17 | if test -f ${PYTHON}-config; then | 11 | - if test -f ${PYTHON}-config; then |
18 | - PY_CFLAGS=`${PYTHON}-config --includes` | 12 | - PY_CFLAGS=`${PYTHON}-config --includes` |
19 | - PY_LIBS=`${PYTHON}-config --libs` | 13 | - PY_LIBS=`${PYTHON}-config --libs` |
20 | - AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.]) | 14 | - AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.]) |
21 | + m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$]) | 15 | - AC_MSG_RESULT(ok) |
22 | + PY_LIBS="-L$PKG_CONFIG_SYSROOT_DIR/usr/lib/python$PY_VERSION/config -lpython$PY_VERSION" | 16 | - else |
23 | + PY_CFLAGS="-I$PKG_CONFIG_SYSROOT_DIR/usr/include/python$PY_VERSION" AC_DEFINE(USE_PYTHON, [1], [Define if python headers are available.]) | 17 | - AC_MSG_RESULT([Cannot find ${PYTHON}-config]) |
24 | AC_MSG_RESULT(ok) | 18 | - PY_CFLAGS="" |
25 | else | 19 | - PY_LIBS="" |
26 | AC_MSG_RESULT([Cannot find ${PYTHON}-config]) | 20 | - fi |
27 | 21 | + AC_MSG_CHECKING(for Python compile flags) | |
22 | + PKG_CHECK_MODULES(PY, python, [ | ||
23 | + AC_SUBST(PY_CFLAGS) | ||
24 | + AC_SUBST(PY_LIBS) | ||
25 | + ], [ | ||
26 | + AC_MSG_RESULT(no) | ||
27 | + AC_MSG_ERROR([Can't find python]) | ||
28 | + ]) | ||
29 | fi | ||
30 | -AC_SUBST(PY_CFLAGS) | ||
31 | -AC_SUBST(PY_LIBS) | ||
32 | |||
33 | dnl ####################################################################### | ||
34 | dnl # Check for Mono support | ||
diff --git a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb index ac0871fb4..cd4614070 100644 --- a/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb +++ b/meta-oe/recipes-support/pidgin/pidgin_2.10.12.bb | |||
@@ -83,7 +83,7 @@ FILES_${PN} = "${bindir} ${datadir}/${PN} ${libdir}/${PN}/*.so \ | |||
83 | ${datadir}/applications" | 83 | ${datadir}/applications" |
84 | RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-irc libpurple-protocol-xmpp" | 84 | RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-irc libpurple-protocol-xmpp" |
85 | 85 | ||
86 | FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons" | 86 | FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons ${datadir}/appdata" |
87 | FILES_${PN}-dev += "${libdir}/${PN}/*.la" | 87 | FILES_${PN}-dev += "${libdir}/${PN}/*.la" |
88 | 88 | ||
89 | PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*" | 89 | PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*" |