summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pcsc-lite
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2011-12-02 15:09:55 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-06 16:37:26 +0100
commit62222b77754745a4ed3087f0f2dcf01ba2592993 (patch)
tree08ead9de05bfb474221d3d49a9779d0f3d47bd4e /meta-oe/recipes-support/pcsc-lite
parent4128ddd54f15293ebcb5fe920f0451ae9557b074 (diff)
downloadmeta-openembedded-62222b77754745a4ed3087f0f2dcf01ba2592993.tar.gz
pcsc-lite: clean recipe
we get the following log at boot : Configuring pcsc-lite. update-rc.d: /etc/init.d/pcscd: file does not exist as the init script is no more nedded (autoload feature of the daemon by the clients), we can remove the previously unused init script and clean the recipe in order not to have any update-rc interaction. Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/pcsc-lite')
-rw-r--r--meta-oe/recipes-support/pcsc-lite/files/pcscd.init32
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.7.2.bb7
2 files changed, 2 insertions, 37 deletions
diff --git a/meta-oe/recipes-support/pcsc-lite/files/pcscd.init b/meta-oe/recipes-support/pcsc-lite/files/pcscd.init
deleted file mode 100644
index 92385ab19..000000000
--- a/meta-oe/recipes-support/pcsc-lite/files/pcscd.init
+++ /dev/null
@@ -1,32 +0,0 @@
1#!/bin/sh
2DAEMON=/usr/sbin/pcscd
3NAME=pcscd
4DESC="PCSC Daemon"
5PIDFILE=/var/run/pcscd/pcscd.pid
6ARGS=""
7
8test -f $DAEMON || exit 0
9
10case "$1" in
11 start)
12 echo -n "Starting $DESC: $NAME"
13 start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- $ARGS
14 echo "."
15 ;;
16 stop)
17 echo -n "Stopping $DESC: $NAME"
18 start-stop-daemon --stop --quiet --pidfile $PIDFILE --exec $DAEMON
19 echo "."
20 ;;
21 restart)
22 $0 stop
23 sleep 1
24 $0 start
25 ;;
26 *)
27 echo "Usage: $0 {start|stop|restart}"
28 exit 1
29 ;;
30esac
31
32exit 0
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.7.2.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.7.2.bb
index 14a0ba0cb..de980ff80 100644
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.7.2.bb
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.7.2.bb
@@ -4,14 +4,14 @@ LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c8e551349dc346258274f0007679e149" 4LIC_FILES_CHKSUM = "file://COPYING;md5=c8e551349dc346258274f0007679e149"
5DEPENDS = "udev" 5DEPENDS = "udev"
6RDEPENDS += "ccid" 6RDEPENDS += "ccid"
7PR = "r1" 7PR = "r2"
8 8
9SRC_URI = "https://alioth.debian.org/frs/download.php/3533/pcsc-lite-${PV}.tar.bz2" 9SRC_URI = "https://alioth.debian.org/frs/download.php/3533/pcsc-lite-${PV}.tar.bz2"
10 10
11SRC_URI[md5sum] = "47e7055cfc14399fdaa1b7a4aa06e5aa" 11SRC_URI[md5sum] = "47e7055cfc14399fdaa1b7a4aa06e5aa"
12SRC_URI[sha256sum] = "41f13d552eaa2c3978fbb6f2125e81903a0767011d999052fd1a6ee03880b398" 12SRC_URI[sha256sum] = "41f13d552eaa2c3978fbb6f2125e81903a0767011d999052fd1a6ee03880b398"
13 13
14inherit autotools update-rc.d 14inherit autotools
15 15
16EXTRA_OECONF = " \ 16EXTRA_OECONF = " \
17 --disable-libusb \ 17 --disable-libusb \
@@ -23,7 +23,4 @@ S = "${WORKDIR}/pcsc-lite-${PV}"
23 23
24PACKAGES =+ "${PN}-lib" 24PACKAGES =+ "${PN}-lib"
25 25
26INITSCRIPT_NAME = "pcscd"
27INITSCRIPT_PARAMS = "defaults"
28
29FILES_${PN}-lib = "${libdir}/lib*${SOLIBS}" 26FILES_${PN}-lib = "${libdir}/lib*${SOLIBS}"