summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/p910nd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/p910nd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/p910nd')
-rw-r--r--meta-oe/recipes-support/p910nd/p910nd/fix-var-lock.patch30
-rw-r--r--meta-oe/recipes-support/p910nd/p910nd_0.95.bb22
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/p910nd/p910nd/fix-var-lock.patch b/meta-oe/recipes-support/p910nd/p910nd/fix-var-lock.patch
new file mode 100644
index 000000000..aa84e180e
--- /dev/null
+++ b/meta-oe/recipes-support/p910nd/p910nd/fix-var-lock.patch
@@ -0,0 +1,30 @@
1Use /var/lock instead of /var/lock/subsys
2
3Upstream-Status: Inappropriate [configuration]
4
5Index: p910nd/p910nd.8
6===================================================================
7--- p910nd.orig/p910nd.8 2011-11-14 22:41:41.904615879 +0100
8+++ p910nd/p910nd.8 2011-11-14 22:49:52.299047607 +0100
9@@ -83,7 +83,7 @@
10 .SH "SEE ALSO"
11 printcap(5), hosts_access(5)
12 .SH FILES
13-/var/run/p9100d.pid, /var/lock/subsys/p9100d, /etc/hosts.allow, /etc/hosts.deny
14+/var/run/p9100d.pid, /var/lock/p9100d, /etc/hosts.allow, /etc/hosts.deny
15 .SH COPYRIGHT
16 .I p910nd
17 is under the GNU Public License Version 2
18Index: p910nd/p910nd.c
19===================================================================
20--- p910nd.orig/p910nd.c 2011-11-14 22:47:41.986401420 +0100
21+++ p910nd/p910nd.c 2011-11-14 22:49:27.274923524 +0100
22@@ -122,7 +122,7 @@
23 #ifdef LOCKFILE_DIR
24 #define LOCKFILE LOCKFILE_DIR "/p910%cd"
25 #else
26-#define LOCKFILE "/var/lock/subsys/p910%cd"
27+#define LOCKFILE "/var/lock/p910%cd"
28 #endif
29 #ifndef PRINTERFILE
30 #define PRINTERFILE "/dev/lp%c"
diff --git a/meta-oe/recipes-support/p910nd/p910nd_0.95.bb b/meta-oe/recipes-support/p910nd/p910nd_0.95.bb
new file mode 100644
index 000000000..5ebbb29e1
--- /dev/null
+++ b/meta-oe/recipes-support/p910nd/p910nd_0.95.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A small network printer daemon for embedded situations that passes the job directly to the printer"
2HOMEPAGE = "http://p910nd.sourceforge.net/"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
6
7PR = "r2"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/p910nd/p910nd-${PV}.tar.bz2 \
10 file://fix-var-lock.patch"
11
12SRC_URI[md5sum] = "c7ac6afdf7730ac8387a8e87198d4491"
13SRC_URI[sha256sum] = "7d78642c86dc247fbdef1ff85c56629dcdc6b2a457c786420299e284fffcb029"
14
15do_compile () {
16 ${CC} ${LDFLAGS} -o p910nd p910nd.c
17}
18
19do_install () {
20 install -D -m 0755 ${S}/p910nd ${D}${sbindir}/p910nd
21 install -D -m 0644 ${S}/p910nd.conf ${D}${sysconfdir}/p910nd.conf
22}