summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openmotif
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-12-19 16:32:09 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-19 17:48:25 +0100
commit353af14e4318811c4302abc253a81e9b401c0cde (patch)
treea65c9b3407f79617eff00d8d718add1ad963ebfc /meta-oe/recipes-support/openmotif
parent481c76f5da6f815d847ff5a4f93a8e40e9d653e1 (diff)
downloadmeta-openembedded-353af14e4318811c4302abc253a81e9b401c0cde.tar.gz
Revert "openmotif: remove due to lack of libxp in repository"
This reverts commit 14b68506078a4133e743491d35245775a58a1317. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/openmotif')
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif/configure.patch15
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb38
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openmotif/openmotif/configure.patch b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
new file mode 100644
index 000000000..8868e805a
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
@@ -0,0 +1,15 @@
1--- a/configure.ac~ 2009-10-27 14:10:23.000000000 -0200
2+++ b/configure.ac 2011-05-31 10:51:00.207232036 -0300
3@@ -3,12 +3,6 @@
4 AC_CONFIG_SRCDIR([lib/Xm/Form.c])
5 AC_PREREQ(2.52)
6 AC_CONFIG_AUX_DIR(.)
7-AC_CHECK_FILE(/usr/X/include/X11/X.h,
8- AC_PREFIX_DEFAULT(/usr/X),
9- AC_PREFIX_DEFAULT(/usr))
10-AC_CHECK_FILE(/usr/X11R6/include/X11/X.h,
11- AC_PREFIX_DEFAULT(/usr/X11R6),
12- AC_PREFIX_DEFAULT(/usr))
13
14 dnl AM_MAINTAINER_MODE
15 AC_CANONICAL_TARGET
diff --git a/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
new file mode 100644
index 000000000..2e9c2de9f
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
@@ -0,0 +1,38 @@
1SECTION = "libs"
2DESCRIPTION = "OSM/Motif implementation."
3LICENSE = "OGPL"
4DEPENDS = "xbitmaps virtual/libx11 libxt libxp"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=14f692c82491db3d52419929d2f3b343"
7
8SRC_URI = "http://openmotif.com/files/public_downloads/openmotif/2.3/2.3.3/openmotif-2.3.3.tar.gz \
9 file://configure.patch;patch=1"
10
11SRC_URI[md5sum] = "fd27cd3369d6c7d5ef79eccba524f7be"
12SRC_URI[sha256sum] = "c85f5545e218fa0c59a3789192132d472fc5a33e914a221a568eee4fc10cd103"
13
14inherit autotools
15
16PACKAGES += "${PN}-bin"
17
18FILES_${PN}-bin = "${bindir}"
19
20do_compile() {
21 (
22 # HACK: build a native binaries need during the build
23 unset CC LD CXX CCLD CFLAGS
24 oe_runmake -C config/util CC="${BUILD_CC}" LD="${BUILD_LD}" CXX="${BUILD_CXX}" LIBS="" makestrs
25 )
26 if [ "$?" != "0" ]; then
27 exit 1
28 fi
29 oe_runmake -C lib
30 oe_runmake -C include
31}
32
33do_install() {
34 oe_runmake DESTDIR=${D} -C lib install
35 oe_runmake DESTDIR=${D} -C include install
36}
37
38LEAD_SONAME = "libXm.so.4"