summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openmotif
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/openmotif
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/openmotif')
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif/configure.patch15
-rw-r--r--meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb48
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openmotif/openmotif/configure.patch b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
new file mode 100644
index 000000000..8868e805a
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif/configure.patch
@@ -0,0 +1,15 @@
1--- a/configure.ac~ 2009-10-27 14:10:23.000000000 -0200
2+++ b/configure.ac 2011-05-31 10:51:00.207232036 -0300
3@@ -3,12 +3,6 @@
4 AC_CONFIG_SRCDIR([lib/Xm/Form.c])
5 AC_PREREQ(2.52)
6 AC_CONFIG_AUX_DIR(.)
7-AC_CHECK_FILE(/usr/X/include/X11/X.h,
8- AC_PREFIX_DEFAULT(/usr/X),
9- AC_PREFIX_DEFAULT(/usr))
10-AC_CHECK_FILE(/usr/X11R6/include/X11/X.h,
11- AC_PREFIX_DEFAULT(/usr/X11R6),
12- AC_PREFIX_DEFAULT(/usr))
13
14 dnl AM_MAINTAINER_MODE
15 AC_CANONICAL_TARGET
diff --git a/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
new file mode 100644
index 000000000..2baeda025
--- /dev/null
+++ b/meta-oe/recipes-support/openmotif/openmotif_2.3.3.bb
@@ -0,0 +1,48 @@
1SECTION = "libs"
2SUMMARY = "OSM/Motif implementation"
3LICENSE = "OGPL"
4DEPENDS = "xbitmaps virtual/libx11 libxt libxft xproto"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=14f692c82491db3d52419929d2f3b343"
7
8PR = "r3"
9
10PNBLACKLIST[openmotif] ?= "BROKEN: doesn't build with B!=S"
11
12SRC_URI = "http://motif.ics.com/sites/default/files/openmotif-2.3.3.tar.gz \
13 file://configure.patch;patch=1"
14
15SRC_URI[md5sum] = "fd27cd3369d6c7d5ef79eccba524f7be"
16SRC_URI[sha256sum] = "c85f5545e218fa0c59a3789192132d472fc5a33e914a221a568eee4fc10cd103"
17
18inherit autotools
19
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
22PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
23
24EXTRA_OECONF = "X_CFLAGS=-I${STAGING_INCDIR} --disable-printing"
25
26PACKAGES += "${PN}-bin"
27
28FILES_${PN}-bin = "${bindir}"
29
30do_compile() {
31 (
32 # HACK: build a native binaries need during the build
33 unset CC LD CXX CCLD CFLAGS
34 oe_runmake -C config/util CC="${BUILD_CC}" LD="${BUILD_LD}" CXX="${BUILD_CXX}" LIBS="" makestrs
35 )
36 if [ "$?" != "0" ]; then
37 exit 1
38 fi
39 oe_runmake -C lib
40 oe_runmake -C include
41}
42
43do_install() {
44 oe_runmake DESTDIR=${D} -C lib install
45 oe_runmake DESTDIR=${D} -C include install
46}
47
48LEAD_SONAME = "libXm.so.4"