diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-27 11:04:51 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-31 10:18:33 +0200 |
commit | ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch) | |
tree | e16d2a838f4561d5538928a58f805e5f1373225a /meta-oe/recipes-support/opencv | |
parent | 6775acb048dabd624c5c8197b683aba45ed91569 (diff) | |
download | meta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz |
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long
time and nobody showed any interest to fix them
* remove all unused .patch and .inc files as well
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv')
3 files changed, 0 insertions, 196 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb deleted file mode 100644 index 107184be4..000000000 --- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "Opencv : The Open Computer Vision Library" | ||
2 | HOMEPAGE = "http://opencv.willowgarage.com/wiki/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "BSD" | ||
5 | |||
6 | DEPENDS = "opencv" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14 \ | ||
9 | " | ||
10 | SRCREV = "6fae07ba8867b8fd2c53344a774aab669afa7c5e" | ||
11 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ | ||
12 | " | ||
13 | PV = "2.4.3+git${SRCPV}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_install() { | ||
18 | cd samples/c | ||
19 | install -d ${D}/${bindir} | ||
20 | install -d ${D}/${datadir}/opencv/samples | ||
21 | |||
22 | cp * ${D}/${datadir}/opencv/samples || true | ||
23 | |||
24 | for i in *.c; do | ||
25 | echo "compiling $i" | ||
26 | ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .c` $i `pkg-config --libs opencv` || true | ||
27 | install -m 0755 `basename $i .c` ${D}/${bindir} || true | ||
28 | rm ${D}/${datadir}/opencv/samples/`basename $i .c` || true | ||
29 | done | ||
30 | for i in *.cpp; do | ||
31 | echo "compiling $i" | ||
32 | ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .cpp` $i `pkg-config --libs opencv` || true | ||
33 | install -m 0755 `basename $i .cpp` ${D}/${bindir} || true | ||
34 | rm ${D}/${datadir}/opencv/samples/`basename $i .cpp` || true | ||
35 | done | ||
36 | } | ||
37 | |||
38 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" | ||
39 | FILES_${PN} += "${bindir} ${datadir}/opencv" | ||
40 | |||
41 | PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||
diff --git a/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch b/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch deleted file mode 100644 index 7f809bce1..000000000 --- a/meta-oe/recipes-support/opencv/opencv/0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 711f07a34ceb504e8f75e978692201efa58268ca Mon Sep 17 00:00:00 2001 | ||
2 | From: Dinar Valeev <dvaleev@suse.com> | ||
3 | Date: Thu, 16 Jan 2014 21:53:49 +0100 | ||
4 | Subject: [PATCH] Use __vector instead of vector as suggests Eigen | ||
5 | |||
6 | This fixes build on PowerPC where Eigen unsets vector, bool and pixel | ||
7 | |||
8 | Signed-off-by: Dinar Valeev <dvaleev@suse.com> | ||
9 | |||
10 | This patch is already part of OpenCV v3.0. The patch can be obtained | ||
11 | from: | ||
12 | |||
13 | https://github.com/Itseez/opencv/commit/711f07a34ceb504e8f75e978692201efa58268ca.patch | ||
14 | |||
15 | Upstream-Status: Backport [commit 711f07a34c, part of version 3.0] | ||
16 | |||
17 | Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | ||
18 | --- | ||
19 | 3rdparty/include/opencl/1.2/CL/cl_platform.h | 14 +++++++------- | ||
20 | 1 file changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/3rdparty/include/opencl/1.2/CL/cl_platform.h b/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
23 | index e94949a..42c35d5 100644 | ||
24 | --- a/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
25 | +++ b/3rdparty/include/opencl/1.2/CL/cl_platform.h | ||
26 | @@ -332,13 +332,13 @@ typedef unsigned int cl_GLenum; | ||
27 | /* Define basic vector types */ | ||
28 | #if defined( __VEC__ ) | ||
29 | #include <altivec.h> /* may be omitted depending on compiler. AltiVec spec provides no way to detect whether the header is required. */ | ||
30 | - typedef vector unsigned char __cl_uchar16; | ||
31 | - typedef vector signed char __cl_char16; | ||
32 | - typedef vector unsigned short __cl_ushort8; | ||
33 | - typedef vector signed short __cl_short8; | ||
34 | - typedef vector unsigned int __cl_uint4; | ||
35 | - typedef vector signed int __cl_int4; | ||
36 | - typedef vector float __cl_float4; | ||
37 | + typedef __vector unsigned char __cl_uchar16; | ||
38 | + typedef __vector signed char __cl_char16; | ||
39 | + typedef __vector unsigned short __cl_ushort8; | ||
40 | + typedef __vector signed short __cl_short8; | ||
41 | + typedef __vector unsigned int __cl_uint4; | ||
42 | + typedef __vector signed int __cl_int4; | ||
43 | + typedef __vector float __cl_float4; | ||
44 | #define __CL_UCHAR16__ 1 | ||
45 | #define __CL_CHAR16__ 1 | ||
46 | #define __CL_USHORT8__ 1 | ||
47 | -- | ||
48 | 1.9.3 | ||
49 | |||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb deleted file mode 100644 index d17c640ac..000000000 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ /dev/null | |||
@@ -1,106 +0,0 @@ | |||
1 | SUMMARY = "Opencv : The Open Computer Vision Library" | ||
2 | HOMEPAGE = "http://opencv.org/" | ||
3 | SECTION = "libs" | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14" | ||
7 | |||
8 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
9 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||
10 | |||
11 | DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0" | ||
12 | |||
13 | SRCREV = "2c9547e3147779001811d01936aed38f560929fc" | ||
14 | SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \ | ||
15 | file://0001-Use-__vector-instead-of-vector-as-suggests-Eigen.patch" | ||
16 | |||
17 | PV = "2.4.11+git${SRCPV}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | # Do an out-of-tree build | ||
22 | OECMAKE_SOURCEPATH = "${S}" | ||
23 | OECMAKE_BUILDPATH = "${WORKDIR}/build-${TARGET_ARCH}" | ||
24 | |||
25 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ | ||
26 | -DBUILD_PYTHON_SUPPORT=ON \ | ||
27 | -DWITH_GSTREAMER=OFF \ | ||
28 | -DWITH_1394=OFF \ | ||
29 | -DCMAKE_SKIP_RPATH=ON \ | ||
30 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ | ||
31 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \ | ||
32 | ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \ | ||
33 | ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ | ||
34 | ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \ | ||
35 | " | ||
36 | |||
37 | PACKAGECONFIG ??= "eigen jpeg png tiff v4l libv4l \ | ||
38 | ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk", "", d)} \ | ||
39 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "libav", "", d)}" | ||
40 | |||
41 | PACKAGECONFIG[eigen] = "-DWITH_EIGEN=ON,-DWITH_EIGEN=OFF,libeigen," | ||
42 | PACKAGECONFIG[gtk] = "-DWITH_GTK=ON,-DWITH_GTK=OFF,gtk+," | ||
43 | PACKAGECONFIG[jasper] = "-DWITH_JASPER=ON,-DWITH_JASPER=OFF,jasper," | ||
44 | PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON,-DWITH_JPEG=OFF,jpeg," | ||
45 | PACKAGECONFIG[libav] = "-DWITH_FFMPEG=ON,-DWITH_FFMPEG=OFF,libav," | ||
46 | PACKAGECONFIG[libv4l] = "-DWITH_LIBV4L=ON,-DWITH_LIBV4L=OFF,v4l-utils," | ||
47 | PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng," | ||
48 | PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff," | ||
49 | PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils," | ||
50 | |||
51 | inherit distutils-base pkgconfig cmake | ||
52 | |||
53 | export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" | ||
54 | export PYTHON="${STAGING_BINDIR_NATIVE}/python" | ||
55 | |||
56 | TARGET_CC_ARCH += "-I${S}/include " | ||
57 | |||
58 | PACKAGES += "${PN}-apps python-opencv" | ||
59 | |||
60 | python populate_packages_prepend () { | ||
61 | cv_libdir = d.expand('${libdir}') | ||
62 | cv_libdir_dbg = d.expand('${libdir}/.debug') | ||
63 | do_split_packages(d, cv_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev', allow_links=True) | ||
64 | do_split_packages(d, cv_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | ||
65 | do_split_packages(d, cv_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'OpenCV %s development package', extra_depends='${PN}-dev') | ||
66 | do_split_packages(d, cv_libdir, '^lib(.*)\.so\.*', 'lib%s', 'OpenCV %s library', extra_depends='', allow_links=True) | ||
67 | |||
68 | pn = d.getVar('PN') | ||
69 | metapkg = pn + '-dev' | ||
70 | d.setVar('ALLOW_EMPTY_' + metapkg, "1") | ||
71 | blacklist = [ metapkg ] | ||
72 | metapkg_rdepends = [ ] | ||
73 | packages = d.getVar('PACKAGES').split() | ||
74 | for pkg in packages[1:]: | ||
75 | if not pkg in blacklist and not pkg in metapkg_rdepends and pkg.endswith('-dev'): | ||
76 | metapkg_rdepends.append(pkg) | ||
77 | d.setVar('RRECOMMENDS_' + metapkg, ' '.join(metapkg_rdepends)) | ||
78 | } | ||
79 | |||
80 | PACKAGES_DYNAMIC += "^libopencv-.*" | ||
81 | |||
82 | FILES_${PN} = "" | ||
83 | FILES_${PN}-apps = "${bindir}/* ${datadir}/OpenCV" | ||
84 | FILES_${PN}-dbg += "${libdir}/.debug" | ||
85 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig" | ||
86 | FILES_${PN}-doc = "${datadir}/OpenCV/doc" | ||
87 | |||
88 | ALLOW_EMPTY_${PN} = "1" | ||
89 | |||
90 | SUMMARY_python-opencv = "Python bindings to opencv" | ||
91 | FILES_python-opencv = "${PYTHON_SITEPACKAGES_DIR}/*" | ||
92 | RDEPENDS_python-opencv = "python-core python-numpy" | ||
93 | |||
94 | do_install_append() { | ||
95 | cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/ | ||
96 | sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h | ||
97 | |||
98 | # Move Python files into correct library folder (for multilib build) | ||
99 | if [ "$libdir" != "/usr/lib" ]; then | ||
100 | mv ${D}/usr/lib/* ${D}/${libdir}/ | ||
101 | rm -rf ${D}/usr/lib | ||
102 | fi | ||
103 | } | ||
104 | |||
105 | # http://errors.yoctoproject.org/Errors/Details/40660/ | ||
106 | PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3 - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||