diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:35:16 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:36:45 +0200 |
commit | cdb428e7c49899675ee7b7a43f6cecdb5b4c2546 (patch) | |
tree | 42c4f0752df5a0bae2c3aeec8362faa029adc792 /meta-oe/recipes-support/opencv | |
parent | 2af18f934cd6764ef87977c8b23a924a5cb7fbf7 (diff) | |
download | meta-openembedded-cdb428e7c49899675ee7b7a43f6cecdb5b4c2546.tar.gz |
recipes: add removal date to PNBLACKLIST messages
* based on discussion in pndeprecated thread:
https://patchwork.openembedded.org/patch/137573/
update the messages to warn possible users that the
recipe will be removed before the end of the next development
cycle (before Yocto 2.4 is released).
* updated with:
sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs`
* then noticed couple recipes being blacklisted only based on
DISTRO_FEATURES, so removed those:
meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb
meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb
meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb
meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb
meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
meta-oe/recipes-navigation/gypsy/gypsy.inc
meta-oe/recipes-navigation/navit/navit.inc
meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
* if it isn't fixed by this date, it's fair game to be removed
whenever someone gets around to i
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv-samples_2.4.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.bb | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb index b8e3a2d20..107184be4 100644 --- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb | |||
@@ -38,4 +38,4 @@ do_install() { | |||
38 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" | 38 | FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*" |
39 | FILES_${PN} += "${bindir} ${datadir}/opencv" | 39 | FILES_${PN} += "${bindir} ${datadir}/opencv" |
40 | 40 | ||
41 | PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv" | 41 | PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv - the recipe will be removed on 2017-09-01 unless the issue is fixed" |
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb index de2f0529e..d17c640ac 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb | |||
@@ -103,4 +103,4 @@ do_install_append() { | |||
103 | } | 103 | } |
104 | 104 | ||
105 | # http://errors.yoctoproject.org/Errors/Details/40660/ | 105 | # http://errors.yoctoproject.org/Errors/Details/40660/ |
106 | PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3" | 106 | PNBLACKLIST[opencv] ?= "Not compatible with currently used ffmpeg 3 - the recipe will be removed on 2017-09-01 unless the issue is fixed" |