diff options
author | Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net> | 2012-12-18 10:51:48 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-19 17:48:16 +0100 |
commit | 6335366c1f8870f638b7de381251432f2d2404f1 (patch) | |
tree | 94b48033ab92422369f1eb18f98ff9b3e505a7fb /meta-oe/recipes-support/opencv | |
parent | 2b4ec7cd91de4620abe5694d5aac6407bb143835 (diff) | |
download | meta-openembedded-6335366c1f8870f638b7de381251432f2d2404f1.tar.gz |
opencv: fix pkg-config file generation
Replace absolute library path with library name spec and library search
path option in pkg-config file.
Signed-off-by: Stefan Herbrechtsmeier <stefan@herbrechtsmeier.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch | 44 | ||||
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_2.4.3.bb | 3 |
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch b/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch new file mode 100644 index 000000000..d352778c9 --- /dev/null +++ b/meta-oe/recipes-support/opencv/opencv/opencv-fix-pkgconfig-generation.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | Fix pkg-config generation | ||
2 | |||
3 | Replace absolute library path with library name spec and library search | ||
4 | path option. | ||
5 | |||
6 | The fix has been provided by Ray Rashif (code.opencv.org/issues/1925) | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | |||
10 | diff -Nbaur OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake | ||
11 | --- OpenCV-2.4.3.orig/cmake/OpenCVGenPkgconfig.cmake 2012-11-04 08:40:14.243505926 +0000 | ||
12 | +++ OpenCV-2.4.3/cmake/OpenCVGenPkgconfig.cmake 2012-11-04 08:40:42.286649120 +0000 | ||
13 | @@ -10,7 +10,7 @@ | ||
14 | # ------------------------------------------------------------------------------------------- | ||
15 | set(prefix "${CMAKE_INSTALL_PREFIX}") | ||
16 | set(exec_prefix "\${prefix}") | ||
17 | -set(libdir "") #TODO: need link paths for OpenCV_EXTRA_COMPONENTS | ||
18 | +set(libdir "\${prefix}/${OPENCV_LIB_INSTALL_PATH}") | ||
19 | set(includedir "\${prefix}/${OPENCV_INCLUDE_INSTALL_PATH}") | ||
20 | set(VERSION ${OPENCV_VERSION}) | ||
21 | |||
22 | @@ -36,10 +36,11 @@ | ||
23 | ocv_list_reverse(OpenCV_EXTRA_COMPONENTS) | ||
24 | |||
25 | #build the list of components | ||
26 | -set(OpenCV_LIB_COMPONENTS_ "") | ||
27 | +set(OpenCV_LIB_COMPONENTS_ "-L\${libdir}") | ||
28 | foreach(CVLib ${OpenCV_LIB_COMPONENTS}) | ||
29 | get_target_property(libpath ${CVLib} LOCATION_${CMAKE_BUILD_TYPE}) | ||
30 | get_filename_component(libname "${libpath}" NAME) | ||
31 | + get_filename_component(lname "${libpath}" NAME_WE) | ||
32 | |||
33 | if(INSTALL_TO_MANGLED_PATHS) | ||
34 | set(libname "${libname}.${OPENCV_VERSION}") | ||
35 | @@ -52,7 +53,8 @@ | ||
36 | set(installDir "${OPENCV_LIB_INSTALL_PATH}") | ||
37 | endif() | ||
38 | |||
39 | - set(OpenCV_LIB_COMPONENTS_ "${OpenCV_LIB_COMPONENTS_} \${exec_prefix}/${installDir}/${libname}") | ||
40 | + string(REPLACE "libopencv" "-lopencv" lname "${lname}") | ||
41 | + set(OpenCV_LIB_COMPONENTS_ "${OpenCV_LIB_COMPONENTS_} ${lname}") | ||
42 | endforeach() | ||
43 | |||
44 | # add extra dependencies required for OpenCV | ||
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.3.bb b/meta-oe/recipes-support/opencv/opencv_2.4.3.bb index 513e147bc..77d75da75 100644 --- a/meta-oe/recipes-support/opencv/opencv_2.4.3.bb +++ b/meta-oe/recipes-support/opencv/opencv_2.4.3.bb | |||
@@ -10,11 +10,14 @@ ARM_INSTRUCTION_SET = "arm" | |||
10 | DEPENDS = "python-numpy v4l-utils libav gtk+ libtool swig swig-native python jpeg bzip2 zlib libpng tiff glib-2.0" | 10 | DEPENDS = "python-numpy v4l-utils libav gtk+ libtool swig swig-native python jpeg bzip2 zlib libpng tiff glib-2.0" |
11 | 11 | ||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/opencvlibrary/opencv-unix/${PV}/OpenCV-${PV}.tar.bz2 \ | 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/opencvlibrary/opencv-unix/${PV}/OpenCV-${PV}.tar.bz2 \ |
13 | file://opencv-fix-pkgconfig-generation.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | SRC_URI[md5sum] = "c0a5af4ff9d0d540684c0bf00ef35dbe" | 16 | SRC_URI[md5sum] = "c0a5af4ff9d0d540684c0bf00ef35dbe" |
16 | SRC_URI[sha256sum] = "f8fbe985978d4eae73e8c3b526ed40a37d4761d2029a5b035233f58146f6f59b" | 17 | SRC_URI[sha256sum] = "f8fbe985978d4eae73e8c3b526ed40a37d4761d2029a5b035233f58146f6f59b" |
17 | 18 | ||
19 | PR = "r1" | ||
20 | |||
18 | S = "${WORKDIR}/OpenCV-${PV}" | 21 | S = "${WORKDIR}/OpenCV-${PV}" |
19 | 22 | ||
20 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ | 23 | EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/include \ |