summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:04:51 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commitec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (patch)
treee16d2a838f4561d5538928a58f805e5f1373225a /meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
parent6775acb048dabd624c5c8197b683aba45ed91569 (diff)
downloadmeta-openembedded-ec9e5ed06256ad92c818474cdb490dc0d3a0d0a3.tar.gz
recipes: remove blacklisted recipes
* as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv-samples_2.4.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv-samples_2.4.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb b/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
deleted file mode 100644
index 107184be4..000000000
--- a/meta-oe/recipes-support/opencv/opencv-samples_2.4.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "Opencv : The Open Computer Vision Library"
2HOMEPAGE = "http://opencv.willowgarage.com/wiki/"
3SECTION = "libs"
4LICENSE = "BSD"
5
6DEPENDS = "opencv"
7
8LIC_FILES_CHKSUM = "file://include/opencv2/opencv.hpp;endline=41;md5=6d690d8488a6fca7a2c192932466bb14 \
9"
10SRCREV = "6fae07ba8867b8fd2c53344a774aab669afa7c5e"
11SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \
12 "
13PV = "2.4.3+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 cd samples/c
19 install -d ${D}/${bindir}
20 install -d ${D}/${datadir}/opencv/samples
21
22 cp * ${D}/${datadir}/opencv/samples || true
23
24 for i in *.c; do
25 echo "compiling $i"
26 ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .c` $i `pkg-config --libs opencv` || true
27 install -m 0755 `basename $i .c` ${D}/${bindir} || true
28 rm ${D}/${datadir}/opencv/samples/`basename $i .c` || true
29 done
30 for i in *.cpp; do
31 echo "compiling $i"
32 ${CXX} ${CFLAGS} ${LDFLAGS} -ggdb `pkg-config --cflags opencv` -o `basename $i .cpp` $i `pkg-config --libs opencv` || true
33 install -m 0755 `basename $i .cpp` ${D}/${bindir} || true
34 rm ${D}/${datadir}/opencv/samples/`basename $i .cpp` || true
35 done
36}
37
38FILES_${PN}-dev += "${datadir}/opencv/samples/*.c* ${datadir}/opencv/samples/*.vcp* ${datadir}/opencv/samples/build*"
39FILES_${PN} += "${bindir} ${datadir}/opencv"
40
41PNBLACKLIST[opencv-samples] ?= "Depends on blacklisted opencv - the recipe will be removed on 2017-09-01 unless the issue is fixed"