summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-06-23 15:48:42 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:25 +0200
commit443c441443999eb7d11b01587bbc02af0038488d (patch)
tree0affb486dbd58dfdd89b33e08cd14be61269dc4d /meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
parent6b0ac39453c7c39faf685747e60cb68754148e3c (diff)
downloadmeta-openembedded-443c441443999eb7d11b01587bbc02af0038488d.tar.gz
open-vm-tools: remove kernel module logic
All the modules are upstream for Linux >= 4.0, so no modules are being built anyway. We can safely remove the build logic for them. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb')
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb23
1 files changed, 6 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
index 76d3840e6..24c8e9300 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_10.1.5.bb
@@ -23,41 +23,30 @@ LICENSE_modules/solaris = "CDDLv1"
23SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \ 23SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
24 file://tools.conf \ 24 file://tools.conf \
25 file://vmtoolsd.service \ 25 file://vmtoolsd.service \
26 file://0001-Fix-kernel-detection.patch \ 26 file://0001-configure.ac-don-t-use-dnet-config.patch \
27 file://0002-configure.ac-don-t-use-dnet-config.patch \ 27 file://0002-add-include-sys-sysmacros.h.patch \
28 file://0003-add-include-sys-sysmacros.h.patch \
29 " 28 "
30 29
31SRCREV = "854c0bb374612f7e633b448ca273f970f154458b" 30SRCREV = "854c0bb374612f7e633b448ca273f970f154458b"
32 31
33S = "${WORKDIR}/git/open-vm-tools" 32S = "${WORKDIR}/git/open-vm-tools"
34 33
35DEPENDS = "virtual/kernel glib-2.0 glib-2.0-native util-linux libdnet procps" 34DEPENDS = "glib-2.0 glib-2.0-native util-linux libdnet procps"
36RDEPENDS_${PN} = "util-linux libdnet kernel-module-vmhgfs" 35RDEPENDS_${PN} = "util-linux libdnet"
37 36
38inherit module-base kernel-module-split autotools pkgconfig systemd 37inherit autotools pkgconfig systemd
39
40# from module.bbclass...
41addtask make_scripts after do_patch before do_compile
42do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
43do_make_scripts[depends] = "virtual/kernel:do_shared_workdir"
44# add all splitted modules to PN RDEPENDS, PN can be empty now
45KERNEL_MODULES_META_PACKAGE = "${PN}"
46 38
47SYSTEMD_SERVICE_${PN} = "vmtoolsd.service" 39SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
48 40
49EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs --disable-tests \ 41EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs --disable-tests \
50 --without-gtkmm --without-xerces --without-pam \ 42 --without-gtkmm --without-xerces --without-pam \
51 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \ 43 --disable-grabbitmqproxy --disable-vgauth --disable-deploypkg \
52 --with-linuxdir=${STAGING_KERNEL_DIR} --with-kernel-release=${KERNEL_VERSION} --without-root-privileges" 44 --without-root-privileges --without-kernel-modules"
53 45
54NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3" 46NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
55X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf" 47X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
56PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}" 48PACKAGECONFIG[x11] = ",${NO_X11_FLAGS},${X11_DEPENDS}"
57 49
58EXTRA_OEMAKE = "KERNEL_RELEASE=${KERNEL_VERSION}"
59
60
61CFLAGS += '-Wno-error=deprecated-declarations' 50CFLAGS += '-Wno-error=deprecated-declarations'
62 51
63FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \ 52FILES_${PN} += "/usr/lib/open-vm-tools/plugins/vmsvc/lib*.so \