summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ode
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/ode
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/ode')
-rw-r--r--meta-oe/recipes-support/ode/ode/configure.patch13
-rw-r--r--meta-oe/recipes-support/ode/ode/install.patch23
-rw-r--r--meta-oe/recipes-support/ode/ode_0.13.bb28
3 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ode/ode/configure.patch b/meta-oe/recipes-support/ode/ode/configure.patch
new file mode 100644
index 000000000..246b2e2c2
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode/configure.patch
@@ -0,0 +1,13 @@
1Index: ode-0.13/libccd/configure.ac
2===================================================================
3--- ode-0.13.orig/libccd/configure.ac 2013-08-19 17:48:03.000000000 +0000
4+++ ode-0.13/libccd/configure.ac 2014-07-17 22:04:16.580595690 +0000
5@@ -5,7 +5,7 @@
6 AC_INIT([libccd], [1.0], [danfis@danfis.cz])
7 AC_CONFIG_SRCDIR([src/ccd.c])
8 AC_CONFIG_HEADERS([src/config.h])
9-AM_INIT_AUTOMAKE
10+AM_INIT_AUTOMAKE([foreign])
11
12 # Checks for programs.
13 AC_PROG_CXX
diff --git a/meta-oe/recipes-support/ode/ode/install.patch b/meta-oe/recipes-support/ode/ode/install.patch
new file mode 100644
index 000000000..2f6cdb008
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode/install.patch
@@ -0,0 +1,23 @@
1--- ode-0.9.orig/Makefile.am 2007-02-21 15:54:54.000000000 +0100
2+++ ode-0.9/Makefile.am 2010-08-21 16:15:55.000000000 +0200
3@@ -25,13 +25,13 @@
4
5 if USE_SONAME
6 install-exec-hook:
7- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
8- $(libdir)/libode.so
9- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
10- $(libdir)/@ODE_SONAME@
11- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
12- $(libdir)/@ODE_SONAME@.@ODE_REVISION@
13- /sbin/ldconfig
14+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
15+ $(DESTDIR)/$(libdir)/libode.so
16+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
17+ $(DESTDIR)/$(libdir)/@ODE_SONAME@
18+ ln -s @ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
19+ $(DESTDIR)/$(libdir)/@ODE_SONAME@.@ODE_REVISION@
20+ echo /sbin/ldconfig
21 else
22 install-exec-hook:
23 endif
diff --git a/meta-oe/recipes-support/ode/ode_0.13.bb b/meta-oe/recipes-support/ode/ode_0.13.bb
new file mode 100644
index 000000000..2dc82a8e1
--- /dev/null
+++ b/meta-oe/recipes-support/ode/ode_0.13.bb
@@ -0,0 +1,28 @@
1SUMMARY = "ODE is an Open Source Physics Engine"
2SECTION = "libs"
3HOMEPAGE = "http://www.ode.org"
4LICENSE = "LGPLv2.1 & BSD"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=1de906ee96808d9776dd72a5f9a79a22 \
7 file://LICENSE.TXT;md5=771782cb6245c7fbbe74bc0ec059beff \
8"
9# LICENSE-BSD.TXT is missing in 0.13 tarball, but COPYING still says it's dual licensed
10# and svn repo still contains LICENSE-BSD.TXT so maybe it will return in next tarball
11# file://LICENSE-BSD.TXT;md5=c74e6304a772117e059458fb9763a928
12
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tar.bz2 \
15 file://configure.patch"
16SRC_URI[md5sum] = "04b32c9645c147e18caff7a597a19f84"
17SRC_URI[sha256sum] = "34ce3e236e313bf109a0cb5546d2fca462aed99f29a42e62bc1463b803c31ef9"
18
19inherit autotools binconfig
20
21EXTRA_OECONF = "--disable-demos --enable-soname"
22
23FILES_${PN} = "${libdir}/lib*${SOLIBS}"
24
25PACKAGECONFIG ?= ""
26# if it isn't explicitly selected and "$build_os" == "$target_os", then configure will run
27# series of AC_TRY_RUN which won't work for cross-compilation and configure fails
28PACKAGECONFIG[double-precision] = "--enable-double-precision,--disable-double-precision"