summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-08-18 18:53:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:56:28 +0200
commit289217bbc3c5c53f486ab5615a6d6196e3c12cf2 (patch)
treef9551306e700a0ba0218177f3ec417f76d1f5759 /meta-oe/recipes-support/numactl
parentf2bec07b87b3f1118aa1d1f194d230920f1afe01 (diff)
downloadmeta-openembedded-289217bbc3c5c53f486ab5615a6d6196e3c12cf2.tar.gz
meta-oe: fix indentation
* remove tabs which sneaked in since last cleanup * meta-oe layers are using consistent indentation with 4 spaces, see http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl')
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.11.bb56
1 files changed, 28 insertions, 28 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.11.bb b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
index 199726fd0..dd159a3b1 100644
--- a/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
@@ -11,12 +11,12 @@ inherit autotools-brokensep ptest
11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9" 11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
12 12
13SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \ 13SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
14 file://fix-null-pointer.patch \ 14 file://fix-null-pointer.patch \
15 file://Fix-the-test-output-format.patch \ 15 file://Fix-the-test-output-format.patch \
16 file://Makefile \ 16 file://Makefile \
17 file://run-ptest \ 17 file://run-ptest \
18 file://0001-define-run-test-target.patch \ 18 file://0001-define-run-test-target.patch \
19 " 19"
20SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127" 20SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127"
21SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861" 21SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861"
22 22
@@ -24,34 +24,34 @@ SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e
24COMPATIBLE_HOST = "^((?!arm).*)$" 24COMPATIBLE_HOST = "^((?!arm).*)$"
25 25
26do_install() { 26do_install() {
27 oe_runmake DESTDIR=${D} prefix=${D}/usr install 27 oe_runmake DESTDIR=${D} prefix=${D}/usr install
28 #remove the empty man2 directory 28 #remove the empty man2 directory
29 rm -r ${D}${mandir}/man2 29 rm -r ${D}${mandir}/man2
30} 30}
31 31
32do_compile_ptest() { 32do_compile_ptest() {
33 oe_runmake test 33 oe_runmake test
34} 34}
35 35
36do_install_ptest() { 36do_install_ptest() {
37 #install tests binaries 37 #install tests binaries
38 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \ 38 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
39 mynode nodemap node-parse pagesize prefered randmap realloc_test \ 39 mynode nodemap node-parse pagesize prefered randmap realloc_test \
40 tbitmap tshared" 40 tbitmap tshared"
41 41
42 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test 42 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
43 for i in $test_binaries; do 43 for i in $test_binaries; do
44 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test 44 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
45 done 45 done
46 46
47 local test_scripts="checktopology checkaffinity printcpu regress regress2 \ 47 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
48 shmtest runltp bind_range" 48 shmtest runltp bind_range"
49 for i in $test_scripts; do 49 for i in $test_scripts; do
50 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test 50 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
51 done 51 done
52 52
53 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/ 53 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
54 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/ 54 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
55} 55}
56 56
57RDEPENDS_${PN}-ptest = "bash" 57RDEPENDS_${PN}-ptest = "bash"