summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/numactl/numactl_2.0.9.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl/numactl_2.0.9.bb')
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.9.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.9.bb b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
new file mode 100644
index 000000000..651277dab
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.9.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Development package for building Applications that use numa"
2DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
3to run other programs with a specific NUMA policy and a libnuma to do \
4allocations with NUMA policy in applications."
5LICENSE = "GPL-2.0 & LGPL-2.1"
6SECTION = "apps"
7RDEPENDS_${PN} = "perl"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
12SRC_URI[md5sum] = "136685c8eaf9d6569c351fe1d453b30c"
13SRC_URI[sha256sum] = "9ca033e6c14c0f26c20379b0cf9299429fd5a354a79c3c7880fd41ef69f7751c"
14
15SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
16 file://fix-null-pointer.patch \
17 file://Fix-the-test-output-format.patch \
18 file://Makefile \
19 file://run-ptest \
20 "
21
22# ARM does not currently support NUMA
23COMPATIBLE_HOST = "^((?!arm).*)$"
24
25do_install() {
26 oe_runmake DESTDIR=${D} prefix=${D}/usr libdir=${D}/${libdir} install
27 #remove the empty man2 directory
28 rm -r ${D}${mandir}/man2
29}
30
31do_install_ptest() {
32 #install tests binaries
33 local test_binaries="checkaffinity checktopology distance \
34 ftok mbind_mig_pages migrate_pages move_pages mynode \
35 nodemap pagesize prefered printcpu randmap realloc_test \
36 regress regress2 runltp shmtest tbitmap tshared bind_range"
37
38 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
39 for i in $test_binaries; do
40 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
41 done
42 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
43 install -m 0755 ${B}/numactl ${D}${PTEST_PATH}/
44}