summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-01-19 17:47:45 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:19 +0100
commita6b22d2d575c2de3bc9f5743523a8e1d9ed3ea05 (patch)
tree19b09551d9ddb02a6120aa11ea9c00cf66781ffb /meta-oe/recipes-support/numactl/numactl_2.0.11.bb
parent9d140fd1093d8313f9b9a3b173867ccd28a3da06 (diff)
downloadmeta-openembedded-a6b22d2d575c2de3bc9f5743523a8e1d9ed3ea05.tar.gz
numactl: update to 2.0.11
LIC_FILES_CKSUM changed do to adding version history. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl/numactl_2.0.11.bb')
-rw-r--r--meta-oe/recipes-support/numactl/numactl_2.0.11.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_2.0.11.bb b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
new file mode 100644
index 000000000..199726fd0
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl_2.0.11.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Development package for building Applications that use numa"
2DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
3to run other programs with a specific NUMA policy and a libnuma to do \
4allocations with NUMA policy in applications."
5LICENSE = "GPL-2.0 & LGPL-2.1"
6SECTION = "apps"
7RDEPENDS_${PN} = "perl"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
12
13SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
14 file://fix-null-pointer.patch \
15 file://Fix-the-test-output-format.patch \
16 file://Makefile \
17 file://run-ptest \
18 file://0001-define-run-test-target.patch \
19 "
20SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127"
21SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861"
22
23# ARM does not currently support NUMA
24COMPATIBLE_HOST = "^((?!arm).*)$"
25
26do_install() {
27 oe_runmake DESTDIR=${D} prefix=${D}/usr install
28 #remove the empty man2 directory
29 rm -r ${D}${mandir}/man2
30}
31
32do_compile_ptest() {
33 oe_runmake test
34}
35
36do_install_ptest() {
37 #install tests binaries
38 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
39 mynode nodemap node-parse pagesize prefered randmap realloc_test \
40 tbitmap tshared"
41
42 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
43 for i in $test_binaries; do
44 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
45 done
46
47 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
48 shmtest runltp bind_range"
49 for i in $test_scripts; do
50 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
51 done
52
53 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
54 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
55}
56
57RDEPENDS_${PN}-ptest = "bash"