summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/numactl/numactl
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/numactl/numactl
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/numactl/numactl')
-rw-r--r--meta-oe/recipes-support/numactl/numactl/Fix-the-test-output-format.patch59
-rw-r--r--meta-oe/recipes-support/numactl/numactl/Makefile7
-rw-r--r--meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch28
-rwxr-xr-xmeta-oe/recipes-support/numactl/numactl/run-ptest9
4 files changed, 103 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl/Fix-the-test-output-format.patch b/meta-oe/recipes-support/numactl/numactl/Fix-the-test-output-format.patch
new file mode 100644
index 000000000..8c309a4b5
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/Fix-the-test-output-format.patch
@@ -0,0 +1,59 @@
1[PATCH] Fix the test output format
2
3Upstream-Status: Pending
4
5Signed-off-by: Roy Li <rongqing.li@windriver.com>
6---
7 test/regress | 6 +++---
8 test/regress2 | 9 ++++-----
9 2 files changed, 7 insertions(+), 8 deletions(-)
10
11diff --git a/test/regress b/test/regress
12index 05eff5b..10d72f7 100755
13--- a/test/regress
14+++ b/test/regress
15@@ -73,6 +73,7 @@ probe_hardware()
16 if [ $numnodes -lt 2 ] ; then
17 echo "need at least two nodes with at least $NEEDPAGES each of"
18 echo "free memory for mempolicy regression tests"
19+ echo "FAIL: numa regress"
20 exit 1
21 fi
22 }
23@@ -206,10 +207,9 @@ main()
24 rm A B
25
26 if [ "$EXIT" = 0 ] ; then
27- echo '========SUCCESS'
28+ echo 'PASS: numactl regress'
29 else
30- echo '========FAILURE'
31- exit 1
32+ echo 'FAIL: numactl regress'
33 fi
34 }
35
36diff --git a/test/regress2 b/test/regress2
37index 6a254fa..9c97943 100755
38--- a/test/regress2
39+++ b/test/regress2
40@@ -6,12 +6,11 @@ VALGRIND=${VALGRIND:-}
41 export LD_LIBRARY_PATH=`pwd`/..
42
43 T() {
44- echo "$@"
45- if ! $VALGRIND "$@" ; then
46- echo $1 FAILED!!!!
47- exit 1
48+ if ! $VALGRIND "$@" 2>&1 1>/dev/null; then
49+ echo "FAIL: $1"
50+ else
51+ echo "PASS: $1"
52 fi
53- echo
54 }
55
56 # various tests
57--
581.7.10.4
59
diff --git a/meta-oe/recipes-support/numactl/numactl/Makefile b/meta-oe/recipes-support/numactl/numactl/Makefile
new file mode 100644
index 000000000..9a5134c3f
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/Makefile
@@ -0,0 +1,7 @@
1.PHONY: regress1 regress2
2
3regress1:
4 cd test ; ./regress
5
6regress2:
7 cd test ; ./regress2
diff --git a/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch b/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch
new file mode 100644
index 000000000..53952aef9
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch
@@ -0,0 +1,28 @@
1[PATCH] return 0 if distance_table is NULL
2
3Upstream-Status: Pending
4
5read_distance_table() maybe return 0, but distance_table is not set,
6if distance_table is used, and will lead to SEGFAULT
7
8Signed-off-by: Roy Li <rongqing.li@windriver.com>
9---
10 distance.c | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/distance.c b/distance.c
14index 4a26972..c6ca021 100755
15--- a/distance.c
16+++ b/distance.c
17@@ -113,6 +113,8 @@ int numa_distance(int a, int b)
18 int err = read_distance_table();
19 if (err < 0)
20 return 0;
21+ if (!distance_table)
22+ return 0;
23 }
24 return distance_table[a * distance_numnodes + b];
25 }
26--
271.7.10.4
28
diff --git a/meta-oe/recipes-support/numactl/numactl/run-ptest b/meta-oe/recipes-support/numactl/numactl/run-ptest
new file mode 100755
index 000000000..215f7c25b
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/run-ptest
@@ -0,0 +1,9 @@
1#!/bin/sh
2make regress1
3make regress2
4if numademo -t -e 10M; then
5 echo "PASS: numademo"
6else
7 echo "FAIL: numademo"
8fi
9