summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-07-11 13:47:00 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit2dae284c9e4fc4be7dbe846f984ee7cf647c7faf (patch)
treeb5158fad04acb4c0663ef29f8fb5de8d34b759a6 /meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
parent326e027816d7af4d4896e9e6d74842aa327352e0 (diff)
downloadmeta-openembedded-2dae284c9e4fc4be7dbe846f984ee7cf647c7faf.tar.gz
ntp: move systemd support to meta-systemd
Diffstat (limited to 'meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb')
-rw-r--r--meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb18
1 files changed, 1 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
index a3d719e30..89a272a36 100644
--- a/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
+++ b/meta-oe/recipes-support/ntp/ntp_4.2.6p3.bb
@@ -1,11 +1,6 @@
1require ntp.inc 1require ntp.inc
2 2
3PR = "r5" 3PR = "r6"
4
5inherit systemd
6
7SYSTEMD_PACKAGES = "${PN}-systemd"
8SYSTEMD_SERVICE_${PN}-systemd = "ntpd.service"
9 4
10SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ 5SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
11 file://tickadj.c.patch \ 6 file://tickadj.c.patch \
@@ -13,8 +8,6 @@ SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.g
13 file://ntpd \ 8 file://ntpd \
14 file://ntp.conf \ 9 file://ntp.conf \
15 file://ntpdate \ 10 file://ntpdate \
16 file://ntpdate.service \
17 file://ntpd.service \
18" 11"
19 12
20SRC_URI[md5sum] = "59876a9009b098ff59767ee45a88ebd2" 13SRC_URI[md5sum] = "59876a9009b098ff59767ee45a88ebd2"
@@ -28,17 +21,8 @@ do_install_append() {
28 install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d 21 install -m 755 ${WORKDIR}/ntpd ${D}/${sysconfdir}/init.d
29 install -d ${D}/${sysconfdir}/network/if-up.d 22 install -d ${D}/${sysconfdir}/network/if-up.d
30 install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d 23 install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/network/if-up.d
31
32 install -d ${D}${systemd_unitdir}/system
33 install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
34 install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
35} 24}
36 25
37PACKAGES =+ "${PN}-systemd"
38
39FILES_${PN}-systemd = "${systemd_unitdir}/system/"
40RDEPENDS_${PN}-systemd = "${PN}"
41
42FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace" 26FILES_${PN}-bin = "${bindir}/ntp-wait ${bindir}/ntpdc ${bindir}/ntpq ${bindir}/ntptime ${bindir}/ntptrace"
43FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd" 27FILES_${PN} = "${bindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd"
44FILES_${PN}-tickadj = "${bindir}/tickadj" 28FILES_${PN}-tickadj = "${bindir}/tickadj"