summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nss/nss
diff options
context:
space:
mode:
authorAndrej Valek <andrej.valek@siemens.com>2020-10-19 12:25:58 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-19 22:18:11 -0700
commitfc08abf6e0ee6fd3cf34cb5d67aff20d7879a671 (patch)
tree7c8c1a24943a2ad9f3610ef70dca7f3c856068a1 /meta-oe/recipes-support/nss/nss
parent8c80754a523db1b166e50f4c71ed6f89dc65bd16 (diff)
downloadmeta-openembedded-fc08abf6e0ee6fd3cf34cb5d67aff20d7879a671.tar.gz
nss: upgrade 3.56 -> 3.57
- Refresh freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch - Drop pkix-Do-not-use-NULL-where-0-is-needed.patch Signed-off-by: Andrej Kozemcak <andrej.kozemcak@siemens.com> Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/nss/nss')
-rw-r--r--meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch36
-rw-r--r--meta-oe/recipes-support/nss/nss/0001-pkix-Do-not-use-NULL-where-0-is-needed.patch46
2 files changed, 23 insertions, 59 deletions
diff --git a/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch b/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch
index bfc375e83..65e1500ae 100644
--- a/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch
+++ b/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch
@@ -10,22 +10,24 @@ Upstream-Status: Pending
10Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> 10Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
11 11
12--- 12---
13 nss/lib/freebl/Makefile | 4 ++++ 13 nss/lib/freebl/Makefile | 3 +++
14 nss/lib/freebl/gcm.c | 2 ++ 14 nss/lib/freebl/gcm.c | 2 ++
15 2 files changed, 6 insertions(+) 15 2 files changed, 5 insertions(+)
16 16
17diff --git a/nss/lib/freebl/Makefile b/nss/lib/freebl/Makefile
18index fe8c526..922f67c 100644
17--- a/nss/lib/freebl/Makefile 19--- a/nss/lib/freebl/Makefile
18+++ b/nss/lib/freebl/Makefile 20+++ b/nss/lib/freebl/Makefile
19@@ -126,6 +126,8 @@ else 21@@ -125,6 +125,8 @@ else
22 DEFINES += -DNSS_X86
20 endif 23 endif
21 endif 24 endif
22 ifdef NS_USE_GCC
23+ifdef NSS_USE_ARM_HW_CRYPTO 25+ifdef NSS_USE_ARM_HW_CRYPTO
24+ DEFINES += -DNSS_USE_ARM_HW_CRYPTO 26+ DEFINES += -DNSS_USE_ARM_HW_CRYPTO
25 ifeq ($(CPU_ARCH),aarch64) 27 ifeq ($(CPU_ARCH),aarch64)
26 DEFINES += -DUSE_HW_AES -DUSE_HW_SHA1 -DUSE_HW_SHA2 28 ifdef CC_IS_CLANG
27 EXTRA_SRCS += aes-armv8.c gcm-aarch64.c sha1-armv8.c sha256-armv8.c 29 DEFINES += -DUSE_HW_AES -DUSE_HW_SHA1 -DUSE_HW_SHA2
28@@ -150,6 +152,7 @@ endif 30@@ -166,6 +168,7 @@ endif
29 endif 31 endif
30 endif 32 endif
31 endif 33 endif
@@ -33,15 +35,23 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
33 35
34 ifeq ($(OS_TARGET),OSF1) 36 ifeq ($(OS_TARGET),OSF1)
35 DEFINES += -DMP_ASSEMBLY_MULTIPLY -DMP_NO_MP_WORD 37 DEFINES += -DMP_ASSEMBLY_MULTIPLY -DMP_NO_MP_WORD
38diff --git a/nss/lib/freebl/gcm.c b/nss/lib/freebl/gcm.c
39index c2cc18d..b77f573 100644
36--- a/nss/lib/freebl/gcm.c 40--- a/nss/lib/freebl/gcm.c
37+++ b/nss/lib/freebl/gcm.c 41+++ b/nss/lib/freebl/gcm.c
38@@ -21,7 +21,9 @@ 42@@ -18,6 +18,7 @@
43
44 #include <limits.h>
45
46+#ifdef NSS_USE_ARM_HW_CRYPTO
39 /* old gcc doesn't support some poly64x2_t intrinsic */ 47 /* old gcc doesn't support some poly64x2_t intrinsic */
40 #if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \ 48 #if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \
41 (defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6) 49 (defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6)
42+# ifdef NSS_USE_ARM_HW_CRYPTO 50@@ -27,6 +28,7 @@
43 #define USE_ARM_GCM
44+# endif
45 #elif defined(__arm__) && defined(IS_LITTLE_ENDIAN) && \
46 !defined(NSS_DISABLE_ARM32_NEON)
47 /* We don't test on big endian platform, so disable this on big endian. */ 51 /* We don't test on big endian platform, so disable this on big endian. */
52 #define USE_ARM_GCM
53 #endif
54+#endif
55
56 /* Forward declarations */
57 SECStatus gcm_HashInit_hw(gcmHashContext *ghash);
diff --git a/meta-oe/recipes-support/nss/nss/0001-pkix-Do-not-use-NULL-where-0-is-needed.patch b/meta-oe/recipes-support/nss/nss/0001-pkix-Do-not-use-NULL-where-0-is-needed.patch
deleted file mode 100644
index 432312da2..000000000
--- a/meta-oe/recipes-support/nss/nss/0001-pkix-Do-not-use-NULL-where-0-is-needed.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 1136cad77c2dc7d8e1daa317877676733e805f29 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 26 Aug 2020 17:30:40 -0700
4Subject: [PATCH] pkix: Do not use NULL where 0 is needed
5
6Clang finds this error
7
8pkix_logger.c:316:32: error: cast to smaller integer type 'PKIX_ERRORCLASS' from 'void *' [-Werror,-Wvoid-pointer-to-enum-cast]
9 logger->logComponent = (PKIX_ERRORCLASS)NULL;
10 ^~~~~~~~~~~~~~~~~~~~~
11pkix_logger.c:617:32: error: cast to smaller integer type 'PKIX_ERRORCLASS' from 'void *' [-Werror,-Wvoid-pointer-to-enum-cast]
12 logger->logComponent = (PKIX_ERRORCLASS)NULL;
13 ^~~~~~~~~~~~~~~~~~~~~
142 errors generated.
15
16Upstream-Status: Submitted [https://bugzilla.mozilla.org/show_bug.cgi?id=1661378]
17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18---
19 nss/lib/libpkix/pkix/util/pkix_logger.c | 4 ++--
20 1 file changed, 2 insertions(+), 2 deletions(-)
21
22diff --git a/nss/lib/libpkix/pkix/util/pkix_logger.c b/nss/lib/libpkix/pkix/util/pkix_logger.c
23index a916e6e..10f537a 100644
24--- a/nss/lib/libpkix/pkix/util/pkix_logger.c
25+++ b/nss/lib/libpkix/pkix/util/pkix_logger.c
26@@ -313,7 +313,7 @@ pkix_Logger_Destroy(
27
28 logger->callback = NULL;
29 PKIX_DECREF(logger->context);
30- logger->logComponent = (PKIX_ERRORCLASS)NULL;
31+ logger->logComponent = (PKIX_ERRORCLASS)0;
32
33 cleanup:
34
35@@ -614,7 +614,7 @@ PKIX_Logger_Create(
36
37 logger->callback = callback;
38 logger->maxLevel = 0;
39- logger->logComponent = (PKIX_ERRORCLASS)NULL;
40+ logger->logComponent = (PKIX_ERRORCLASS)0;
41
42 PKIX_INCREF(loggerContext);
43 logger->context = loggerContext;
44--
452.28.0
46