summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ne10
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-support/ne10
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-support/ne10')
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 2fb9d64f5..951086f77 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -21,10 +21,10 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)"
21COMPATIBLE_MACHINE_armv7a = "(.*)" 21COMPATIBLE_MACHINE_armv7a = "(.*)"
22 22
23python () { 23python () {
24 if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES', True).split()): 24 if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES').split()):
25 d.setVar('NE10_TARGET_ARCH', 'armv7') 25 d.setVar('NE10_TARGET_ARCH', 'armv7')
26 bb.debug(2, 'Building Ne10 for armv7') 26 bb.debug(2, 'Building Ne10 for armv7')
27 elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES', True).split()): 27 elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES').split()):
28 d.setVar('NE10_TARGET_ARCH', 'aarch64') 28 d.setVar('NE10_TARGET_ARCH', 'aarch64')
29 bb.debug(2, 'Building Ne10 for aarch64') 29 bb.debug(2, 'Building Ne10 for aarch64')
30 else: 30 else: