summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-support/multipath-tools
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
index 186f78b8f..d4d6c6ba9 100644
--- a/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_0.8.4.bb
@@ -58,7 +58,7 @@ S = "${WORKDIR}/git"
58 58
59inherit systemd pkgconfig 59inherit systemd pkgconfig
60 60
61SYSTEMD_SERVICE_${PN} = "multipathd.service" 61SYSTEMD_SERVICE:${PN} = "multipathd.service"
62SYSTEMD_AUTO_ENABLE = "disable" 62SYSTEMD_AUTO_ENABLE = "disable"
63 63
64TARGET_CC_ARCH += "${LDFLAGS}" 64TARGET_CC_ARCH += "${LDFLAGS}"
@@ -68,8 +68,8 @@ TARGET_CC_ARCH += "${LDFLAGS}"
68# that only works on ARM when thumb is disabled. Otherwise one gets: 68# that only works on ARM when thumb is disabled. Otherwise one gets:
69# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3' 69# Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
70# ../Makefile.inc:66: recipe for target 'debug.o' failed 70# ../Makefile.inc:66: recipe for target 'debug.o' failed
71ARM_INSTRUCTION_SET_armv4 = "arm" 71ARM_INSTRUCTION_SET:armv4 = "arm"
72ARM_INSTRUCTION_SET_armv5 = "arm" 72ARM_INSTRUCTION_SET:armv5 = "arm"
73 73
74# The exact version of SYSTEMD does not matter but should be greater than 209. 74# The exact version of SYSTEMD does not matter but should be greater than 209.
75# 75#
@@ -100,23 +100,23 @@ do_install() {
100 ${D}${sysconfdir}/multipath.conf.example 100 ${D}${sysconfdir}/multipath.conf.example
101} 101}
102 102
103FILES_${PN}-dbg += "${base_libdir}/multipath/.debug" 103FILES:${PN}-dbg += "${base_libdir}/multipath/.debug"
104 104
105PACKAGES =+ "${PN}-libs" 105PACKAGES =+ "${PN}-libs"
106FILES_${PN}-libs = "${base_libdir}/lib*.so.* \ 106FILES:${PN}-libs = "${base_libdir}/lib*.so.* \
107 ${base_libdir}/multipath/lib*.so*" 107 ${base_libdir}/multipath/lib*.so*"
108RDEPENDS_${PN} += "${PN}-libs bash" 108RDEPENDS:${PN} += "${PN}-libs bash"
109 109
110PROVIDES += "device-mapper-multipath" 110PROVIDES += "device-mapper-multipath"
111RPROVIDES_${PN} += "device-mapper-multipath" 111RPROVIDES:${PN} += "device-mapper-multipath"
112RPROVIDES_${PN}-libs += "device-mapper-multipath-libs" 112RPROVIDES:${PN}-libs += "device-mapper-multipath-libs"
113 113
114FILES_${PN}-dev += "${base_libdir}/pkgconfig" 114FILES:${PN}-dev += "${base_libdir}/pkgconfig"
115 115
116PACKAGES =+ "kpartx" 116PACKAGES =+ "kpartx"
117FILES_kpartx = "${base_sbindir}/kpartx \ 117FILES:kpartx = "${base_sbindir}/kpartx \
118 ${nonarch_base_libdir}/udev/kpartx_id \ 118 ${nonarch_base_libdir}/udev/kpartx_id \
119 " 119 "
120 120
121RDEPENDS_${PN} += "kpartx" 121RDEPENDS:${PN} += "kpartx"
122PARALLEL_MAKE = "" 122PARALLEL_MAKE = ""