summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb')
-rw-r--r--meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
new file mode 100644
index 000000000..055cfe64c
--- /dev/null
+++ b/meta-oe/recipes-support/multipath-tools/multipath-tools_git.bb
@@ -0,0 +1,70 @@
1SUMMARY = "The upstream project used to drive the Device Mapper multipathing driver"
2
3DEPENDS = "lvm2 libaio readline udev"
4
5LICENSE = "LGPLv2"
6
7SRC_URI = "git://git.opensvc.com/multipath-tools/.git;protocol=http \
8 file://multipathd.oe \
9 file://makefile_inc.patch \
10 file://always-use-libdevmapper.patch \
11 file://always-use-libdevmapper-kpartx.patch \
12 "
13# 0.5.0
14#
15#SRCREV = "82f391e787dc02e9d9294aa391137ab424bb83c4"
16#LIC_FILES_CHKSUM = "file://COPYING;md5=7be2873b6270e45abacc503abbe2aa3d"
17
18# 0.5.0 + commits thru 7/18/2014
19#
20#SRCREV = "0d72f46c12207a6b7b89f5ef4f5ab5f87ed8bc90"
21#LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
22
23# 0.5.0 + commits thru 9/12/2014
24#
25# includes important systemd related structure size fix
26#
27SRCREV = "aec68ab217fd2956443b27ceeb97dd6475267789"
28LIC_FILES_CHKSUM = "file://COPYING;md5=b06690e7a95c166eefe0199b39118eb1"
29
30inherit systemd
31
32
33S = "${WORKDIR}/git"
34
35PV = "0.5.0+git${@'${SRCPV}'.split('+')[-1]}"
36
37# The exact version of SYSTEMD does not matter but should be greater than 209.
38#
39EXTRA_OEMAKE = 'MULTIPATH_VERSION=${PV} DESTDIR=${D} syslibdir=${base_libdir} \
40 OPTFLAGS="${CFLAGS}" \
41 LIB=${base_libdir} libdir=${base_libdir}/multipath \
42 unitdir=/lib/systemd/system \
43 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "SYSTEMD=216", "", d)} \
44 '
45
46do_install() {
47 oe_runmake install
48
49 # Copy a sample conf file, but do not rename it multipath.conf.
50 #
51 cp multipath.conf.defaults ${D}${sysconfdir}
52
53 # We copy an initscript, but do not start multipathd at init time.
54 #
55 cp ${WORKDIR}/multipathd.oe ${D}${sysconfdir}/init.d/multipathd
56
57}
58
59FILES_${PN}-dbg += "${base_libdir}/multipath/.debug"
60
61# systemd and udev stuff always goes under /lib!
62#
63FILES_${PN} += "${base_libdir}/multipath \
64 /lib/systemd"
65
66PACKAGES =+ "kpartx"
67FILES_kpartx = "${base_sbindir}/kpartx \
68 /lib/udev/kpartx_id"
69
70RDEPENDS_${PN} += "kpartx"