diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/mime-support | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/mime-support')
-rw-r--r-- | meta-oe/recipes-support/mime-support/mime-support_3.48.bb | 74 |
1 files changed, 37 insertions, 37 deletions
diff --git a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb b/meta-oe/recipes-support/mime-support/mime-support_3.48.bb index f281f6d80..e730102b1 100644 --- a/meta-oe/recipes-support/mime-support/mime-support_3.48.bb +++ b/meta-oe/recipes-support/mime-support/mime-support_3.48.bb | |||
@@ -15,43 +15,43 @@ inherit allarch | |||
15 | docdir_append = "/${PN}" | 15 | docdir_append = "/${PN}" |
16 | 16 | ||
17 | do_install () { | 17 | do_install () { |
18 | install -d ${D}${sysconfdir} | 18 | install -d ${D}${sysconfdir} |
19 | install -d ${D}${libdir}/mime/packages | 19 | install -d ${D}${libdir}/mime/packages |
20 | install -d ${D}${docdir} | 20 | install -d ${D}${docdir} |
21 | install -d ${D}${sbindir} | 21 | install -d ${D}${sbindir} |
22 | install -d ${D}${bindir} | 22 | install -d ${D}${bindir} |
23 | install -d ${D}${mandir}/man1 | 23 | install -d ${D}${mandir}/man1 |
24 | install -d ${D}${mandir}/man5 | 24 | install -d ${D}${mandir}/man5 |
25 | install -d ${D}${mandir}/man8 | 25 | install -d ${D}${mandir}/man8 |
26 | install -m 644 mime.types ${D}${sysconfdir}/ | 26 | install -m 644 mime.types ${D}${sysconfdir}/ |
27 | install -m 644 mailcap ${D}${libdir}/mime/ | 27 | install -m 644 mailcap ${D}${libdir}/mime/ |
28 | install -m 644 mailcap.order ${D}${sysconfdir}/ | 28 | install -m 644 mailcap.order ${D}${sysconfdir}/ |
29 | install -m 644 mailcap.man ${D}${mandir}/man5/mailcap.5 | 29 | install -m 644 mailcap.man ${D}${mandir}/man5/mailcap.5 |
30 | install -m 644 mailcap.order.man ${D}${mandir}/man5/mailcap.order.5 | 30 | install -m 644 mailcap.order.man ${D}${mandir}/man5/mailcap.order.5 |
31 | # install -m 755 install-mime ${D}${sbindir}/ | 31 | # install -m 755 install-mime ${D}${sbindir}/ |
32 | # install -m 644 install-mime.man ${D}${mandir}/man8/install-mime.8 | 32 | # install -m 644 install-mime.man ${D}${mandir}/man8/install-mime.8 |
33 | install -m 755 update-mime ${D}${sbindir}/ | 33 | install -m 755 update-mime ${D}${sbindir}/ |
34 | install -m 644 update-mime.man ${D}${mandir}/man8/update-mime.8 | 34 | install -m 644 update-mime.man ${D}${mandir}/man8/update-mime.8 |
35 | install -m 755 run-mailcap ${D}${bindir}/ | 35 | install -m 755 run-mailcap ${D}${bindir}/ |
36 | install -m 644 run-mailcap.man ${D}${mandir}/man1/run-mailcap.1 | 36 | install -m 644 run-mailcap.man ${D}${mandir}/man1/run-mailcap.1 |
37 | # install -m 644 rfcs/* ${D}${docdir}/ | 37 | # install -m 644 rfcs/* ${D}${docdir}/ |
38 | install -m 644 debian/changelog ${D}${docdir}/changelog.Debian | 38 | install -m 644 debian/changelog ${D}${docdir}/changelog.Debian |
39 | install -m 644 debian/README ${D}${docdir}/copyright | 39 | install -m 644 debian/README ${D}${docdir}/copyright |
40 | install -m 755 debian-view ${D}${libdir}/mime/ | 40 | install -m 755 debian-view ${D}${libdir}/mime/ |
41 | install -m 755 playaudio ${D}${libdir}/mime/ | 41 | install -m 755 playaudio ${D}${libdir}/mime/ |
42 | install -m 755 playdsp ${D}${libdir}/mime/ | 42 | install -m 755 playdsp ${D}${libdir}/mime/ |
43 | install -m 644 mailcap.entries ${D}${libdir}/mime/packages/mime-support | 43 | install -m 644 mailcap.entries ${D}${libdir}/mime/packages/mime-support |
44 | cd ${D}${mandir}; gzip -9fv */* | 44 | cd ${D}${mandir}; gzip -9fv */* |
45 | cd ${D}${docdir}; gzip -9v * | 45 | cd ${D}${docdir}; gzip -9v * |
46 | cd ${D}${docdir}; gunzip copyright.gz | 46 | cd ${D}${docdir}; gunzip copyright.gz |
47 | cd ${D}${bindir}; ln -s run-mailcap see | 47 | cd ${D}${bindir}; ln -s run-mailcap see |
48 | cd ${D}${bindir}; ln -s run-mailcap edit | 48 | cd ${D}${bindir}; ln -s run-mailcap edit |
49 | cd ${D}${bindir}; ln -s run-mailcap compose | 49 | cd ${D}${bindir}; ln -s run-mailcap compose |
50 | cd ${D}${bindir}; ln -s run-mailcap print | 50 | cd ${D}${bindir}; ln -s run-mailcap print |
51 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz see.1.gz | 51 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz see.1.gz |
52 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz edit.1.gz | 52 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz edit.1.gz |
53 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz compose.1.gz | 53 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz compose.1.gz |
54 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz print.1.gz | 54 | cd ${D}${mandir}/man1; ln -s run-mailcap.1.gz print.1.gz |
55 | } | 55 | } |
56 | 56 | ||
57 | SRC_URI[md5sum] = "d6e5d715e331147352c50c158dbdec6d" | 57 | SRC_URI[md5sum] = "d6e5d715e331147352c50c158dbdec6d" |