summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mg
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/mg
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/mg')
-rw-r--r--meta-oe/recipes-support/mg/files/remove_ncurses_check.patch36
-rw-r--r--meta-oe/recipes-support/mg/mg_20110905.bb21
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch b/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch
new file mode 100644
index 000000000..16137da2b
--- /dev/null
+++ b/meta-oe/recipes-support/mg/files/remove_ncurses_check.patch
@@ -0,0 +1,36 @@
1diff -uwr mg-20110905/configure mg-20110905-changed/configure
2--- mg-20110905/configure 2011-09-05 13:36:16.000000000 -0500
3+++ mg-20110905-changed/configure 2014-08-14 10:46:14.168715425 -0500
4@@ -163,32 +163,6 @@
5 echo 'Fails.'
6 fi
7
8-
9-if [ ! -r /usr/include/term.h ]; then
10- note 'term.h'
11- if [ -r /usr/include/ncurses/term.h ]; then
12- echo "Found in /usr/include/ncurses"
13- extraflags="$extraflags -I/usr/include/ncurses"
14- else
15- for i in pkg local; do
16- if [ -r /usr/$i/include/term.h ]; then
17- echo "Found in /usr/$i/include"
18- extralibs="$extralibs -L/usr/$i/lib"
19- extraflags="$extraflags -I/usr/$i/include"
20- break
21- else
22- false
23- fi
24- done ||
25- {
26- echo 'Not found!' >&2
27- echo 'Do you have the ncurses devel package installed?' >&2
28- echo 'If you know where term.h is, please email the author!' >&2
29- exit 1
30- }
31- fi
32-fi
33-
34 note 'base and dirname'
35 if gcc_defines "__GLIBC__" || gcc_defines "__CYGWIN__" ; then
36 echo 'Not present, adding.'
diff --git a/meta-oe/recipes-support/mg/mg_20110905.bb b/meta-oe/recipes-support/mg/mg_20110905.bb
new file mode 100644
index 000000000..b9a4d3392
--- /dev/null
+++ b/meta-oe/recipes-support/mg/mg_20110905.bb
@@ -0,0 +1,21 @@
1SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
2HOMEPAGE = "http://homepage.boetes.org/software/mg/"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://version.c;md5=811e1b67a5cd60c12b218a2b7c1adbf2"
5DEPENDS = "ncurses"
6SECTION = "console/editors"
7
8SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
9 file://remove_ncurses_check.patch"
10
11SRC_URI[md5sum] = "2de35316fa8ebafe6003efaae70b723e"
12SRC_URI[sha256sum] = "1cd37d7e6a3eecc890a5718c38b8f38495057ba93856762a756ccee2f9618229"
13
14do_configure () {
15 sed -i Makefile.in -e 's,^prefix=.*,prefix=${prefix},'
16 ./configure
17}
18
19do_install () {
20 oe_runmake install DESTDIR=${D}
21}