summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_175.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-03-03 11:18:10 +0800
committerKhem Raj <raj.khem@gmail.com>2021-03-03 11:08:29 -0800
commit335ddbb02ff01349747b0645783776ea939cf3bc (patch)
tree5cad8d4cd3f04bce953cc8d1b1aa49f8f8554786 /meta-oe/recipes-support/mcelog/mcelog_175.bb
parent75f7473f4b6f0041c9ae466f433e18d506894a91 (diff)
downloadmeta-openembedded-335ddbb02ff01349747b0645783776ea939cf3bc.tar.gz
mcelog: Upgrade to 175
Rebase 0001-test-avoid-the-pfa-test-hang.patch to the new version. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_175.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_175.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_175.bb b/meta-oe/recipes-support/mcelog/mcelog_175.bb
new file mode 100644
index 000000000..ae810eff8
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog_175.bb
@@ -0,0 +1,36 @@
1SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
2DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
3and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
4and should run on all Linux systems that need error handling."
5HOMEPAGE = "http://mcelog.org/"
6SECTION = "System Environment/Base"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
9 file://0001-test-avoid-the-pfa-test-hang.patch \
10 file://run-ptest \
11"
12
13SRCREV = "7b776a8c005b60572f49797e81287540f99fff1f"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
17
18S = "${WORKDIR}/git"
19
20inherit autotools-brokensep ptest
21
22COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
23
24do_install_append() {
25 install -d ${D}${sysconfdir}/cron.hourly
26 install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
27 sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
28}
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}
32 cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
33 sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
34}
35
36RDEPENDS_${PN}-ptest += "make bash mce-inject"