diff options
author | Samuel Stirtzel <s.stirtzel@googlemail.com> | 2013-04-04 08:18:46 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-09 21:34:15 +0200 |
commit | c35842efb2bd9b6df13f58afea9f1a7c04d8d769 (patch) | |
tree | 02ae9b9872de94e0936fd9c40bb951821ffd132f /meta-oe/recipes-support/maliit | |
parent | b07f0a239e7ee2b81157399b6befa811a5009813 (diff) | |
download | meta-openembedded-c35842efb2bd9b6df13f58afea9f1a7c04d8d769.tar.gz |
maliit-framework: fix for Qt applications
fixes a linking issue and also sets the required variable for X based programms
Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/maliit')
-rw-r--r-- | meta-oe/recipes-support/maliit/maliit-framework/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch | 23 | ||||
-rw-r--r-- | meta-oe/recipes-support/maliit/maliit-framework_git.bb | 24 |
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch b/meta-oe/recipes-support/maliit/maliit-framework/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch new file mode 100644 index 000000000..c2291c6b7 --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-framework/0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | From cc33efdedbec9e9a55e9a0c6756516fd84d42e53 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
3 | Date: Fri, 1 Mar 2013 11:31:41 +0100 | ||
4 | Subject: [PATCH] Link to libmaliit-1,0 in inputcontext plugin | ||
5 | |||
6 | Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
7 | --- | ||
8 | .../input-context-plugin/input-context-plugin.pro | 2 ++ | ||
9 | 1 file changed, 2 insertions(+) | ||
10 | |||
11 | diff --git a/input-context/input-context-plugin/input-context-plugin.pro b/input-context/input-context-plugin/input-context-plugin.pro | ||
12 | index eefbe93..296e2fa 100644 | ||
13 | --- a/input-context/input-context-plugin/input-context-plugin.pro | ||
14 | +++ b/input-context/input-context-plugin/input-context-plugin.pro | ||
15 | @@ -15,3 +15,5 @@ CONFIG += plugin | ||
16 | |||
17 | INSTALLS += target | ||
18 | target.path += $$QT_IM_PLUGIN_PATH | ||
19 | + | ||
20 | +LIBS += -L../../lib -l"maliit-1.0" | ||
21 | -- | ||
22 | 1.7.9.5 | ||
23 | |||
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb index a164e781f..e61cca028 100644 --- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb +++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb | |||
@@ -10,6 +10,7 @@ inherit autotools qt4x11 gtk-immodules-cache | |||
10 | SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ | 10 | SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ |
11 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ | 11 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ |
12 | file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ | 12 | file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ |
13 | file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" | 16 | SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" |
@@ -65,4 +66,25 @@ do_install_append() { | |||
65 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf | 66 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf |
66 | } | 67 | } |
67 | 68 | ||
68 | S= "${WORKDIR}/git" | 69 | pkg_postinst_${PN} () { |
70 | #!/bin/sh | ||
71 | # should run online | ||
72 | if [ "x$D" != "x" ]; then | ||
73 | exit 1 | ||
74 | fi | ||
75 | echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile | ||
76 | } | ||
77 | |||
78 | pkg_postrm_${PN} () { | ||
79 | #!/bin/sh | ||
80 | # should run online | ||
81 | if [ "x$D" = "x" ]; then | ||
82 | exit 1 | ||
83 | fi | ||
84 | if [ -e "/etc/xprofile" ]; then | ||
85 | sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile | ||
86 | fi | ||
87 | |||
88 | } | ||
89 | |||
90 | S = "${WORKDIR}/git" | ||