summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/maliit
diff options
context:
space:
mode:
authorSamuel Stirtzel <s.stirtzel@googlemail.com>2012-10-17 14:37:52 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-24 08:25:39 +0200
commiteb66e508e33ccbec8299041265eef183913a3a8c (patch)
tree10559e5c0fdf95586b41db9fbddc17e294a04437 /meta-oe/recipes-support/maliit
parent80e475919c188b59928139c820ea8137ea05de9b (diff)
downloadmeta-openembedded-eb66e508e33ccbec8299041265eef183913a3a8c.tar.gz
maliit-framework: Clean up recipe and use gtk-immodules-cache.bbclass
To be merged after gtk-immodules-cache.bbclass hits oe-core Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/maliit')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb32
1 files changed, 7 insertions, 25 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
index 3f50d1bc5..534a3c85b 100644
--- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://wiki.maliit.org/Main_Page"
4LICENSE = "LGPLv2.1" 4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad" 5LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
6 6
7inherit autotools qt4x11 7inherit autotools qt4x11 gtk-immodules-cache
8 8
9 9
10SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ 10SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \
@@ -16,9 +16,8 @@ SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
16PV = "0.92.3+git${SRCPV}" 16PV = "0.92.3+git${SRCPV}"
17 17
18 18
19PACKAGES =+ "\ 19PACKAGES =+ "${PN}-gtk"
20 ${PN}-gtk \ 20GTKIMMODULES_PACKAGES = "${PN}-gtk"
21 "
22 21
23# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2. 22# Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2.
24RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4" 23RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4"
@@ -58,29 +57,12 @@ EXTRA_QMAKEVARS_PRE = "\
58 CONFIG+=local-install \ 57 CONFIG+=local-install \
59 " 58 "
60 59
61do_install() { 60EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
62 cd ${S} && (INSTALL_ROOT=${D} oe_runmake install)
63 61
62do_install_append() {
64 #Fix absolute paths 63 #Fix absolute paths
65 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-framework.prf 64 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf
66 cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-plugins.prf 65 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf
67}
68
69
70
71# Update the inputmethod modules in gtk
72pkg_postinst_${PN}-gtk() {
73if [ "x$D" != "x" ]; then
74 exit 1
75fi
76gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
77}
78
79pkg_postrm_${PN}-gtk() {
80if [ "x$D" != "x" ]; then
81 exit 1
82fi
83gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
84} 66}
85 67
86S= "${WORKDIR}/git" 68S= "${WORKDIR}/git"