diff options
author | Samuel Stirtzel <s.stirtzel@googlemail.com> | 2012-10-17 08:55:32 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-17 13:04:57 +0200 |
commit | d9b7d6b4cd6b959b3998ddfec9775b64ffa61fe0 (patch) | |
tree | a60ad43303088281e7324b7fe1190903e12e6838 /meta-oe/recipes-support/maliit | |
parent | 0caaa82c3d7e6b4704c27ad40e37c0eb5db7048b (diff) | |
download | meta-openembedded-d9b7d6b4cd6b959b3998ddfec9775b64ffa61fe0.tar.gz |
Maliit: Add initial recipes
Maliit is a Qt based virtual keyboard under liberal license (LGPLv2.1 / BSD)
The inputmethod framework from Qt is used and it supports gtk-immodules.
It can also be used without dependencies to GTK+ (separate package for GTK+)
Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/maliit')
4 files changed, 188 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch b/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch new file mode 100644 index 000000000..acd9a57a5 --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 33554f9b3fd493c7e28617fd01466ffa87251f27 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
3 | Date: Wed, 1 Aug 2012 13:21:51 +0200 | ||
4 | Subject: [PATCH] Fix MALIIT_INSTALL_PRF to allow the build with openembedded | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
9 | --- | ||
10 | config.pri | 8 +++++--- | ||
11 | 1 file changed, 5 insertions(+), 3 deletions(-) | ||
12 | |||
13 | diff --git a/config.pri b/config.pri | ||
14 | index b037b8c..43409f3 100644 | ||
15 | --- a/config.pri | ||
16 | +++ b/config.pri | ||
17 | @@ -161,9 +161,11 @@ contains(QT_MAJOR_VERSION, 4) { | ||
18 | QT_WIDGETS = gui widgets | ||
19 | } | ||
20 | |||
21 | -MALIIT_INSTALL_PRF = $$[QT_INSTALL_DATA]/mkspecs/features | ||
22 | -local-install { | ||
23 | - MALIIT_INSTALL_PRF = $$replace(MALIIT_INSTALL_PRF, $$[QT_INSTALL_PREFIX], $$PREFIX) | ||
24 | +isEmpty(MALIIT_INSTALL_PRF) { | ||
25 | + MALIIT_INSTALL_PRF = $$[QT_INSTALL_DATA]/mkspecs/features | ||
26 | + local-install { | ||
27 | + MALIIT_INSTALL_PRF = $$replace(MALIIT_INSTALL_PRF, $$[QT_INSTALL_PREFIX], $$PREFIX) | ||
28 | + } | ||
29 | } | ||
30 | |||
31 | defineTest(outputFile) { | ||
32 | -- | ||
33 | 1.7.9.5 | ||
34 | |||
diff --git a/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch b/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch new file mode 100644 index 000000000..830e6deb4 --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-framework/0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From fb6acbd2af9ed288c1c4f4200fc73d8d9955486a Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
3 | Date: Wed, 1 Aug 2012 13:33:10 +0200 | ||
4 | Subject: [PATCH] Fix QT_IM_PLUGIN_PATH to allow openembedded to build Maliit | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com> | ||
9 | --- | ||
10 | input-context/input-context.pri | 10 ++++++---- | ||
11 | 1 file changed, 6 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/input-context/input-context.pri b/input-context/input-context.pri | ||
14 | index d94e6a3..d460e70 100644 | ||
15 | --- a/input-context/input-context.pri | ||
16 | +++ b/input-context/input-context.pri | ||
17 | @@ -25,8 +25,10 @@ for(OPTION,$$list($$lower($$COV_OPTION))){ | ||
18 | |||
19 | QMAKE_CLEAN += $$OBJECTS_DIR/*.gcno $$OBJECTS_DIR/*.gcda | ||
20 | |||
21 | -QT_IM_PLUGIN_PATH = $$[QT_INSTALL_PLUGINS]/inputmethods | ||
22 | -QT_PREFIX = $$[QT_INSTALL_PREFIX] | ||
23 | -local-install { | ||
24 | - QT_IM_PLUGIN_PATH = $$replace(QT_IM_PLUGIN_PATH, $$QT_PREFIX, $$PREFIX) | ||
25 | +isEmpty(QT_IM_PLUGIN_PATH) { | ||
26 | + QT_IM_PLUGIN_PATH = $$[QT_INSTALL_PLUGINS]/inputmethods | ||
27 | + QT_PREFIX = $$[QT_INSTALL_PREFIX] | ||
28 | + local-install { | ||
29 | + QT_IM_PLUGIN_PATH = $$replace(QT_IM_PLUGIN_PATH, $$QT_PREFIX, $$PREFIX) | ||
30 | + } | ||
31 | } | ||
32 | -- | ||
33 | 1.7.9.5 | ||
34 | |||
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb new file mode 100644 index 000000000..3f50d1bc5 --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb | |||
@@ -0,0 +1,86 @@ | |||
1 | DESCRIPTION = "A virtual keyboard for touch-screen based user interfaces" | ||
2 | HOMEPAGE = "https://wiki.maliit.org/Main_Page" | ||
3 | |||
4 | LICENSE = "LGPLv2.1" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad" | ||
6 | |||
7 | inherit autotools qt4x11 | ||
8 | |||
9 | |||
10 | SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ | ||
11 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ | ||
12 | file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ | ||
13 | " | ||
14 | |||
15 | SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" | ||
16 | PV = "0.92.3+git${SRCPV}" | ||
17 | |||
18 | |||
19 | PACKAGES =+ "\ | ||
20 | ${PN}-gtk \ | ||
21 | " | ||
22 | |||
23 | # Maliit needs Qt configured with -accessibility, a patch for that was already sent and will get merged in post 1.2. | ||
24 | RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4" | ||
25 | |||
26 | RRECOMMENDS_${PN} = "maliit-plugins" | ||
27 | |||
28 | |||
29 | FILES_${PN} += "\ | ||
30 | ${libdir}/maliit/plugins-*/factories/libmaliit-plugins-quick-factory-*.so \ | ||
31 | ${libdir}/qt4/plugins/inputmethods/*.so \ | ||
32 | " | ||
33 | |||
34 | FILES_${PN}-dbg += "\ | ||
35 | ${libdir}/maliit-framework-tests \ | ||
36 | ${libdir}/gtk-*/*/immodules/.debug \ | ||
37 | ${libdir}/maliit/plugins-*/factories/.debug \ | ||
38 | ${libdir}/qt4/plugins/.debug \ | ||
39 | ${libdir}/qt4/plugins/inputmethods/.debug \ | ||
40 | " | ||
41 | |||
42 | FILES_${PN}-dev += "${datadir}/qt4" | ||
43 | |||
44 | FILES_${PN}-gtk +="\ | ||
45 | ${bindir}/maliit-exampleapp-gtk* \ | ||
46 | \ | ||
47 | ${libdir}/gtk-*/*/immodules/libim-maliit.so\ | ||
48 | " | ||
49 | |||
50 | EXTRA_QMAKEVARS_PRE = "\ | ||
51 | PREFIX=${prefix} \ | ||
52 | LIBDIR=${libdir} \ | ||
53 | QT_IM_PLUGIN_PATH=${libdir}/qt4/plugins/inputmethods \ | ||
54 | MALIIT_INSTALL_PRF=${datadir}/qt4/mkspecs/features \ | ||
55 | SCHEMADIR=${sysconfdir}/gconf/schemas \ | ||
56 | CONFIG+=disable-gconf \ | ||
57 | CONFIG+=disable-gtk-cache-update \ | ||
58 | CONFIG+=local-install \ | ||
59 | " | ||
60 | |||
61 | do_install() { | ||
62 | cd ${S} && (INSTALL_ROOT=${D} oe_runmake install) | ||
63 | |||
64 | #Fix absolute paths | ||
65 | cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-framework.prf | ||
66 | cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ./maliit-plugins.prf | ||
67 | } | ||
68 | |||
69 | |||
70 | |||
71 | # Update the inputmethod modules in gtk | ||
72 | pkg_postinst_${PN}-gtk() { | ||
73 | if [ "x$D" != "x" ]; then | ||
74 | exit 1 | ||
75 | fi | ||
76 | gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules | ||
77 | } | ||
78 | |||
79 | pkg_postrm_${PN}-gtk() { | ||
80 | if [ "x$D" != "x" ]; then | ||
81 | exit 1 | ||
82 | fi | ||
83 | gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules | ||
84 | } | ||
85 | |||
86 | S= "${WORKDIR}/git" | ||
diff --git a/meta-oe/recipes-support/maliit/maliit-plugins_git.bb b/meta-oe/recipes-support/maliit/maliit-plugins_git.bb new file mode 100644 index 000000000..278220def --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-plugins_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "Plugins for a virtual keyboard for touch-screen based user interfaces" | ||
2 | HOMEPAGE = "https://wiki.maliit.org/Main_Page" | ||
3 | |||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f29b21caa8e460097bfad9c026a33621" | ||
6 | |||
7 | inherit autotools qt4x11 | ||
8 | |||
9 | DEPENDS = "maliit-framework" | ||
10 | |||
11 | SRC_URI = "git://gitorious.org/maliit/maliit-plugins.git;branch=master" | ||
12 | |||
13 | SRCREV = "0760e585df494b394df1b887e5138ffef19c481f" | ||
14 | PV = "0.92.3+git${SRCPV}" | ||
15 | |||
16 | EXTRA_QMAKEVARS_PRE = "\ | ||
17 | PREFIX=${prefix} \ | ||
18 | LIBDIR=${libdir} \ | ||
19 | " | ||
20 | |||
21 | FILES_${PN} += "\ | ||
22 | ${libdir}/maliit \ | ||
23 | ${datadir} \ | ||
24 | " | ||
25 | |||
26 | FILES_${PN}-dbg += "\ | ||
27 | ${libdir}/maliit/plugins-*/.debug \ | ||
28 | " | ||
29 | |||
30 | S= "${WORKDIR}/git" | ||
31 | |||
32 | do_install() { | ||
33 | cd ${S} && (INSTALL_ROOT=${D} oe_runmake install) | ||
34 | } | ||