summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/maliit/maliit-plugins_git.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/maliit/maliit-plugins_git.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/maliit/maliit-plugins_git.bb')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-plugins_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-plugins_git.bb b/meta-oe/recipes-support/maliit/maliit-plugins_git.bb
new file mode 100644
index 000000000..3c040d87a
--- /dev/null
+++ b/meta-oe/recipes-support/maliit/maliit-plugins_git.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Plugins for a virtual keyboard for touch-screen based user interfaces"
2HOMEPAGE = "https://wiki.maliit.org/Main_Page"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f29b21caa8e460097bfad9c026a33621"
6
7inherit autotools qt4x11
8
9PNBLACKLIST[maliit-plugins] ?= "BROKEN: depends on broken maliit-framework"
10
11DEPENDS = "maliit-framework"
12
13RDEPENDS_${PN} += "qt4-plugin-iconengine-svgicon qt4-plugin-imageformat-svg"
14
15SRC_URI = "git://github.com/maliit/plugins.git;branch=master"
16
17SRCREV = "0760e585df494b394df1b887e5138ffef19c481f"
18PV = "0.92.3+git${SRCPV}"
19
20EXTRA_QMAKEVARS_PRE = "\
21 PREFIX=${prefix} \
22 LIBDIR=${libdir} \
23 CONFIG+=nodoc \
24"
25
26FILES_${PN} += "\
27 ${libdir}/maliit \
28 ${datadir} \
29"
30
31FILES_${PN}-dbg += "${libdir}/maliit/plugins-*/.debug"
32
33S= "${WORKDIR}/git"
34
35EXTRA_OEMAKE += "INSTALL_ROOT=${D}"