summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/maliit/maliit-framework_git.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/maliit/maliit-framework_git.bb
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/maliit/maliit-framework_git.bb')
-rw-r--r--meta-oe/recipes-support/maliit/maliit-framework_git.bb101
1 files changed, 101 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
new file mode 100644
index 000000000..3eb7f30df
--- /dev/null
+++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb
@@ -0,0 +1,101 @@
1SUMMARY = "A virtual keyboard for touch-screen based user interfaces"
2HOMEPAGE = "https://wiki.maliit.org/Main_Page"
3
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=5c917f6ce94ceb8d8d5e16e2fca5b9ad"
6
7inherit autotools qt4x11 gtk-immodules-cache
8
9PNBLACKLIST[maliit-framework] ?= "BROKEN: Wasn't updated to work with B!=S, maybe incorrectly inherits autotools"
10
11DEPENDS = "libxcomposite dbus gtk+3 gtk+"
12
13SRC_URI = "git://github.com/maliit/framework.git;branch=master \
14 file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \
15 file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \
16 file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \
17 file://0002-ut_maliit_glib_settings-fix-build-for-glib-2.36.patch \
18 file://maliit-server.desktop \
19"
20
21SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc"
22PV = "0.92.3+git${SRCPV}"
23PR = "r1"
24
25
26PACKAGES =+ "${PN}-gtk"
27GTKIMMODULES_PACKAGES = "${PN}-gtk"
28
29RDEPENDS_${PN} = "qt4-plugin-inputmethod-imsw-multi libqtsvg4"
30
31RRECOMMENDS_${PN} = "maliit-plugins"
32
33
34FILES_${PN} += "\
35 ${libdir}/maliit/plugins-*/factories/libmaliit-plugins-quick-factory-*.so \
36 ${libdir}/qt4/plugins/inputmethods/*.so \
37 ${datadir}/applications/maliit-server.desktop \
38"
39
40FILES_${PN}-dbg += "\
41 ${libdir}/maliit-framework-tests \
42 ${libdir}/gtk-*/*/immodules/.debug \
43 ${libdir}/maliit/plugins-*/factories/.debug \
44 ${libdir}/qt4/plugins/.debug \
45 ${libdir}/qt4/plugins/inputmethods/.debug \
46"
47
48FILES_${PN}-dev += "${datadir}/qt4"
49
50FILES_${PN}-gtk +="\
51 ${bindir}/maliit-exampleapp-gtk* \
52 \
53 ${libdir}/gtk-*/*/immodules/libim-maliit.so\
54"
55
56EXTRA_QMAKEVARS_PRE = "\
57 PREFIX=${prefix} \
58 LIBDIR=${libdir} \
59 QT_IM_PLUGIN_PATH=${libdir}/qt4/plugins/inputmethods \
60 MALIIT_INSTALL_PRF=${datadir}/qt4/mkspecs/features \
61 SCHEMADIR=${sysconfdir}/gconf/schemas \
62 CONFIG+=disable-gconf \
63 CONFIG+=disable-gtk-cache-update \
64 CONFIG+=local-install \
65 CONFIG+=nosdk \
66"
67
68EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
69
70do_install_append() {
71 #Fix absolute paths
72 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf
73 sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf
74
75 install -d ${D}${datadir}/applications
76 install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications
77}
78
79pkg_postinst_${PN} () {
80#!/bin/sh
81# should run online
82if [ "x$D" != "x" ]; then
83 exit 1
84fi
85echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile
86ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop
87}
88
89pkg_postrm_${PN} () {
90#!/bin/sh
91# should run online
92if [ "x$D" = "x" ]; then
93 exit 1
94fi
95if [ -e "/etc/xprofile" ]; then
96 sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile
97fi
98rm -f /etc/xdg/autostart/maliit-server.desktop
99}
100
101S = "${WORKDIR}/git"