summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lzip
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2012-02-20 07:54:29 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:57 -0700
commit452654d05d7e7991212509ea321367c73d6575d7 (patch)
treea9735ff3b1ec0892a8cd5ffdd1591a8aafb2119d /meta-oe/recipes-support/lzip
parentb75732e3cab46d159c770d4620b37360aa3a59ac (diff)
downloadmeta-openembedded-452654d05d7e7991212509ea321367c73d6575d7.tar.gz
lzip: add new recipe
- this recipe is imported from oe-classic and upgrade to latest stable version - it was only compile tested Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lzip')
-rw-r--r--meta-oe/recipes-support/lzip/lzip_1.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lzip/lzip_1.12.bb b/meta-oe/recipes-support/lzip/lzip_1.12.bb
new file mode 100644
index 000000000..68f9d0d46
--- /dev/null
+++ b/meta-oe/recipes-support/lzip/lzip_1.12.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Lzip is a lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3SECTION = "console/utils"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6
7SRC_URI = "http://download.savannah.gnu.org/releases/lzip/lzip-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "69a40172db5ce896b58d862c50fcd517"
10SRC_URI[sha256sum] = "eabc590d02d404dc1a1cc8e2777ed398370174b68edb22043c8ca0b209dfcd27"
11
12CONFIGUREOPTS = "\
13 '--srcdir=${S}' \
14 '--prefix=${prefix}' \
15 '--exec-prefix=${exec_prefix}' \
16 '--bindir=${bindir}' \
17 '--datadir=${datadir}' \
18 '--infodir=${infodir}' \
19 '--sysconfdir=${sysconfdir}' \
20 'CXX=${CXX}' \
21 'CPPFLAGS=${CPPFLAGS}' \
22 'CXXFLAGS=${CXXFLAGS}' \
23 'LDFLAGS=${LDFLAGS}' \
24"
25EXTRA_OEMAKE = ""
26
27B = "${S}/obj"
28do_configure () {
29 ${S}/configure ${CONFIGUREOPTS}
30}
31
32do_install () {
33 oe_runmake 'DESTDIR=${D}' install
34}
35
36BBCLASSEXTEND += "native nativesdk"