summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lzip
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-support/lzip
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-support/lzip')
-rw-r--r--meta-oe/recipes-support/lzip/lzip_1.15.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lzip/lzip_1.15.bb b/meta-oe/recipes-support/lzip/lzip_1.15.bb
new file mode 100644
index 000000000..3d646953b
--- /dev/null
+++ b/meta-oe/recipes-support/lzip/lzip_1.15.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Lzip is a lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3SECTION = "console/utils"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6
7SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
8
9# Only the latest version is available in .tar.gz format from savannah.gnu.org,
10# FreeBSD distfiles is known to have version 1.13.
11
12SRC_URI[md5sum] = "e83a364c8544fc66cccb552369d93220"
13SRC_URI[sha256sum] = "7cd3fcda68fc9900efcf7784313e3bdd1303fef1a0546db9723f5e5564dd05b6"
14
15CONFIGUREOPTS = "\
16 '--srcdir=${S}' \
17 '--prefix=${prefix}' \
18 '--exec-prefix=${exec_prefix}' \
19 '--bindir=${bindir}' \
20 '--datadir=${datadir}' \
21 '--infodir=${infodir}' \
22 '--sysconfdir=${sysconfdir}' \
23 'CXX=${CXX}' \
24 'CPPFLAGS=${CPPFLAGS}' \
25 'CXXFLAGS=${CXXFLAGS}' \
26 'LDFLAGS=${LDFLAGS}' \
27"
28EXTRA_OEMAKE = ""
29
30B = "${S}/obj"
31do_configure () {
32 ${S}/configure ${CONFIGUREOPTS}
33}
34
35do_install () {
36 oe_runmake 'DESTDIR=${D}' install
37 # Info dir listing isn't interesting at this point so remove it if it exists.
38 if [ -e "${D}${infodir}/dir" ]; then
39 rm -f ${D}${infodir}/dir
40 fi
41}
42
43BBCLASSEXTEND += "native nativesdk"