summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lvm2
diff options
context:
space:
mode:
authordengke.du@windriver.com <dengke.du@windriver.com>2016-11-16 13:41:30 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:45 +0100
commitaca16cee97bf870c293243ca2d21ec5efbe30623 (patch)
tree86b0b649a24a262ca5fb41e5af7cafa778153fae /meta-oe/recipes-support/lvm2
parentba0717b0cf4fd986104a07b131faf6986222420b (diff)
downloadmeta-openembedded-aca16cee97bf870c293243ca2d21ec5efbe30623.tar.gz
lvm2: 2.02.138 -> 2.02.166
Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lvm2')
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc12
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-_reopen_stream.patch139
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-reopen_stream.patch80
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0002-Guard-use-of-mallinfo-with-__GLIBC__.patch (renamed from meta-oe/recipes-support/lvm2/lvm2/0003-Guard-use-of-mallinfo-with-__GLIBC__.patch)19
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0002-use-PTHREAD_MUTEX_RECURSIVE-instead-of-PTHREAD_MUTEX.patch44
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0003-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch (renamed from meta-oe/recipes-support/lvm2/lvm2/0004-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch)15
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2/0004-tweak-MODPROBE_CMD-for-cross-compile.patch (renamed from meta-oe/recipes-support/lvm2/lvm2/0005-tweak-MODPROBE_CMD-for-cross-compile.patch)22
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb6
8 files changed, 120 insertions, 217 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index 74b72118f..7bd26c02e 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -2,18 +2,16 @@ SECTION = "utils"
2DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux." 2DESCRIPTION = "LVM2 is a set of utilities to manage logical volumes in Linux."
3DEPENDS = "udev" 3DEPENDS = "udev"
4LICENSE = "GPLv2 & LGPLv2" 4LICENSE = "GPLv2 & LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=12713b4d9386533feeb07d6e4831765a \
6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24" 6 file://COPYING.LIB;md5=fbc093901857fcd118f065f900982c24"
7 7
8SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \ 8SRC_URI = "ftp://sources.redhat.com/pub/lvm2/old/LVM2.${PV}.tgz \
9 file://lvm.conf \ 9 file://lvm.conf \
10 file://0001-implement-libc-specific-_reopen_stream.patch \ 10 file://0001-implement-libc-specific-reopen_stream.patch \
11 file://0002-use-PTHREAD_MUTEX_RECURSIVE-instead-of-PTHREAD_MUTEX.patch \ 11 file://0002-Guard-use-of-mallinfo-with-__GLIBC__.patch \
12 file://0003-Guard-use-of-mallinfo-with-__GLIBC__.patch \ 12 file://0003-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch \
13 file://0004-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch \ 13 file://0004-tweak-MODPROBE_CMD-for-cross-compile.patch \
14 file://0005-tweak-MODPROBE_CMD-for-cross-compile.patch \
15 " 14 "
16
17S = "${WORKDIR}/LVM2.${PV}" 15S = "${WORKDIR}/LVM2.${PV}"
18 16
19inherit autotools-brokensep pkgconfig systemd 17inherit autotools-brokensep pkgconfig systemd
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-_reopen_stream.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-_reopen_stream.patch
deleted file mode 100644
index f0b4e71da..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-_reopen_stream.patch
+++ /dev/null
@@ -1,139 +0,0 @@
1From 089c9c701a1b68b721f479dfc0c58c35b9dd4175 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 20 Jan 2016 04:39:53 +0000
4Subject: [PATCH 1/4] implement libc specific _reopen_stream
5
6musl defines stdin/stdio/stderr as constant types which means
7we can not assign to them as we are doing here but works ok with glibc
8therefore abstract out the _reopen_stream definition depending upon if
9we are using glibc or otherwise
10
11Origin:
12http://git.alpinelinux.org/cgit/aports/tree/main/lvm2/fix-stdio-usage.patch
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16Upstream-Status: Pending
17
18 lib/commands/toolcontext.c | 22 +++++++++++-----------
19 tools/lvmcmdline.c | 6 +++---
20 2 files changed, 14 insertions(+), 14 deletions(-)
21
22diff --git a/lib/commands/toolcontext.c b/lib/commands/toolcontext.c
23index a2f21b8..7f796e4 100644
24--- a/lib/commands/toolcontext.c
25+++ b/lib/commands/toolcontext.c
26@@ -1637,7 +1637,10 @@ static void _init_globals(struct cmd_context *cmd)
27 /*
28 * Close and reopen stream on file descriptor fd.
29 */
30-static int _reopen_stream(FILE *stream, int fd, const char *mode, const char *name, FILE **new_stream)
31+#ifdef __GLIBC__
32+#define _reopen_stream(stream, fd, mode, name) __reopen_stream(stream, fd, mode, name, &stream)
33+
34+static int __reopen_stream(FILE *stream, int fd, const char *mode, const char *name, FILE **new_stream)
35 {
36 int fd_copy, new_fd;
37
38@@ -1664,6 +1667,9 @@ static int _reopen_stream(FILE *stream, int fd, const char *mode, const char *na
39
40 return 1;
41 }
42+#else
43+#define _reopen_stream(stream, fd, mode, name) (freopen(NULL, mode, stream) != NULL)
44+#endif
45
46 static int _init_lvmetad(struct cmd_context *cmd)
47 {
48@@ -1741,7 +1747,6 @@ struct cmd_context *create_toolcontext(unsigned is_long_lived,
49 unsigned set_filters)
50 {
51 struct cmd_context *cmd;
52- FILE *new_stream;
53 int flags;
54
55 #ifdef M_MMAP_MAX
56@@ -1791,9 +1796,8 @@ struct cmd_context *create_toolcontext(unsigned is_long_lived,
57 if (is_valid_fd(STDIN_FILENO) &&
58 ((flags = fcntl(STDIN_FILENO, F_GETFL)) > 0) &&
59 (flags & O_ACCMODE) != O_WRONLY) {
60- if (!_reopen_stream(stdin, STDIN_FILENO, "r", "stdin", &new_stream))
61+ if (!_reopen_stream(stdin, STDIN_FILENO, "r", "stdin"))
62 goto_out;
63- stdin = new_stream;
64 if (setvbuf(stdin, cmd->linebuffer, _IOLBF, linebuffer_size)) {
65 log_sys_error("setvbuf", "");
66 goto out;
67@@ -1803,9 +1807,8 @@ struct cmd_context *create_toolcontext(unsigned is_long_lived,
68 if (is_valid_fd(STDOUT_FILENO) &&
69 ((flags = fcntl(STDOUT_FILENO, F_GETFL)) > 0) &&
70 (flags & O_ACCMODE) != O_RDONLY) {
71- if (!_reopen_stream(stdout, STDOUT_FILENO, "w", "stdout", &new_stream))
72+ if (!_reopen_stream(stdout, STDOUT_FILENO, "w", "stdout"))
73 goto_out;
74- stdout = new_stream;
75 if (setvbuf(stdout, cmd->linebuffer + linebuffer_size,
76 _IOLBF, linebuffer_size)) {
77 log_sys_error("setvbuf", "");
78@@ -2131,7 +2134,6 @@ int refresh_toolcontext(struct cmd_context *cmd)
79 void destroy_toolcontext(struct cmd_context *cmd)
80 {
81 struct dm_config_tree *cft_cmdline;
82- FILE *new_stream;
83 int flags;
84
85 if (cmd->dump_filter && cmd->filter && cmd->filter->dump &&
86@@ -2167,8 +2169,7 @@ void destroy_toolcontext(struct cmd_context *cmd)
87 if (is_valid_fd(STDIN_FILENO) &&
88 ((flags = fcntl(STDIN_FILENO, F_GETFL)) > 0) &&
89 (flags & O_ACCMODE) != O_WRONLY) {
90- if (_reopen_stream(stdin, STDIN_FILENO, "r", "stdin", &new_stream)) {
91- stdin = new_stream;
92+ if (_reopen_stream(stdin, STDIN_FILENO, "r", "stdin")) {
93 setlinebuf(stdin);
94 } else
95 cmd->linebuffer = NULL; /* Leave buffer in place (deliberate leak) */
96@@ -2177,8 +2178,7 @@ void destroy_toolcontext(struct cmd_context *cmd)
97 if (is_valid_fd(STDOUT_FILENO) &&
98 ((flags = fcntl(STDOUT_FILENO, F_GETFL)) > 0) &&
99 (flags & O_ACCMODE) != O_RDONLY) {
100- if (_reopen_stream(stdout, STDOUT_FILENO, "w", "stdout", &new_stream)) {
101- stdout = new_stream;
102+ if (_reopen_stream(stdout, STDOUT_FILENO, "w", "stdout")) {
103 setlinebuf(stdout);
104 } else
105 cmd->linebuffer = NULL; /* Leave buffer in place (deliberate leak) */
106diff --git a/tools/lvmcmdline.c b/tools/lvmcmdline.c
107index 6577977..a33258a 100644
108--- a/tools/lvmcmdline.c
109+++ b/tools/lvmcmdline.c
110@@ -1744,7 +1744,7 @@ static int _check_standard_fds(void)
111 int err = is_valid_fd(STDERR_FILENO);
112
113 if (!is_valid_fd(STDIN_FILENO) &&
114- !(stdin = fopen(_PATH_DEVNULL, "r"))) {
115+ !freopen(_PATH_DEVNULL, "r", stdin)) {
116 if (err)
117 perror("stdin stream open");
118 else
119@@ -1754,7 +1754,7 @@ static int _check_standard_fds(void)
120 }
121
122 if (!is_valid_fd(STDOUT_FILENO) &&
123- !(stdout = fopen(_PATH_DEVNULL, "w"))) {
124+ !freopen(_PATH_DEVNULL, "w", stdout)) {
125 if (err)
126 perror("stdout stream open");
127 /* else no stdout */
128@@ -1762,7 +1762,7 @@ static int _check_standard_fds(void)
129 }
130
131 if (!is_valid_fd(STDERR_FILENO) &&
132- !(stderr = fopen(_PATH_DEVNULL, "w"))) {
133+ !freopen(_PATH_DEVNULL, "w", stderr)) {
134 printf("stderr stream open: %s\n",
135 strerror(errno));
136 return 0;
137--
1382.7.0
139
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-reopen_stream.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-reopen_stream.patch
new file mode 100644
index 000000000..f09fd76b3
--- /dev/null
+++ b/meta-oe/recipes-support/lvm2/lvm2/0001-implement-libc-specific-reopen_stream.patch
@@ -0,0 +1,80 @@
1From ede7976da9431573b0104dbcfe91a32c02dbea13 Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com>
3Date: Tue, 25 Oct 2016 11:49:40 +0000
4Subject: [PATCH 1/4] implement libc specific reopen_stream
5
6musl defines stdin/stdio/stderr as constant types which means
7we can not assign to them as we are doing here but works ok with glibc
8therefore abstract out the _reopen_stream definition depending upon if
9we are using glibc or otherwise
10
11Origin:
12http://git.alpinelinux.org/cgit/aports/tree/main/lvm2/fix-stdio-usage.patch
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15Signed-off-by: Dengke Du <dengke.du@windriver.com>
16---
17Upstream-Status: Pending
18---
19 lib/log/log.c | 6 ++++++
20 tools/lvmcmdline.c | 6 +++---
21 2 files changed, 9 insertions(+), 3 deletions(-)
22
23diff --git a/lib/log/log.c b/lib/log/log.c
24index c933154..638839d 100644
25--- a/lib/log/log.c
26+++ b/lib/log/log.c
27@@ -161,6 +161,7 @@ static void _check_and_replace_standard_log_streams(FILE *old_stream, FILE *new_
28 * Close and reopen standard stream on file descriptor fd.
29 */
30 int reopen_standard_stream(FILE **stream, const char *mode)
31+#ifdef __GLIBC__
32 {
33 int fd, fd_copy, new_fd;
34 const char *name;
35@@ -207,6 +208,11 @@ int reopen_standard_stream(FILE **stream, const char *mode)
36 *stream = new_stream;
37 return 1;
38 }
39+#else
40+{
41+ return (freopen(NULL, mode, *stream) != NULL)
42+}
43+#endif
44
45 void init_log_fn(lvm2_log_fn_t log_fn)
46 {
47diff --git a/tools/lvmcmdline.c b/tools/lvmcmdline.c
48index 9a4deb7..f1f18e6 100644
49--- a/tools/lvmcmdline.c
50+++ b/tools/lvmcmdline.c
51@@ -1818,7 +1818,7 @@ static int _check_standard_fds(void)
52 int err = is_valid_fd(STDERR_FILENO);
53
54 if (!is_valid_fd(STDIN_FILENO) &&
55- !(stdin = fopen(_PATH_DEVNULL, "r"))) {
56+ !freopen(_PATH_DEVNULL, "r", stdin)) {
57 if (err)
58 perror("stdin stream open");
59 else
60@@ -1828,7 +1828,7 @@ static int _check_standard_fds(void)
61 }
62
63 if (!is_valid_fd(STDOUT_FILENO) &&
64- !(stdout = fopen(_PATH_DEVNULL, "w"))) {
65+ !freopen(_PATH_DEVNULL, "w", stdout)) {
66 if (err)
67 perror("stdout stream open");
68 /* else no stdout */
69@@ -1836,7 +1836,7 @@ static int _check_standard_fds(void)
70 }
71
72 if (!is_valid_fd(STDERR_FILENO) &&
73- !(stderr = fopen(_PATH_DEVNULL, "w"))) {
74+ !freopen(_PATH_DEVNULL, "w", stderr)) {
75 printf("stderr stream open: %s\n",
76 strerror(errno));
77 return 0;
78--
792.9.3
80
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0003-Guard-use-of-mallinfo-with-__GLIBC__.patch b/meta-oe/recipes-support/lvm2/lvm2/0002-Guard-use-of-mallinfo-with-__GLIBC__.patch
index 3d7176729..5baafab3e 100644
--- a/meta-oe/recipes-support/lvm2/lvm2/0003-Guard-use-of-mallinfo-with-__GLIBC__.patch
+++ b/meta-oe/recipes-support/lvm2/lvm2/0002-Guard-use-of-mallinfo-with-__GLIBC__.patch
@@ -1,30 +1,31 @@
1From e018d055603389b22cbc3bd68b1525f3048ebee7 Mon Sep 17 00:00:00 2001 1From 8706a6d33753d8b2cf5bb2a12bd6880b371ce337 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 20 Jan 2016 04:50:26 +0000 3Date: Tue, 25 Oct 2016 11:52:44 +0000
4Subject: [PATCH 3/4] Guard use of mallinfo() with __GLIBC__ 4Subject: [PATCH 2/4] Guard use of mallinfo() with __GLIBC__
5 5
6This API is glibc-only 6This API is glibc-only
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9Signed-off-by: Dengke Du <dengke.du@windriver.com>
9--- 10---
10Upstream-Status: Pending 11Upstream-Status: Pending
11 12---
12 lib/mm/memlock.c | 2 +- 13 lib/mm/memlock.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-) 14 1 file changed, 1 insertion(+), 1 deletion(-)
14 15
15diff --git a/lib/mm/memlock.c b/lib/mm/memlock.c 16diff --git a/lib/mm/memlock.c b/lib/mm/memlock.c
16index 969f1d7..405a7c0 100644 17index da90144..c1bf8fb 100644
17--- a/lib/mm/memlock.c 18--- a/lib/mm/memlock.c
18+++ b/lib/mm/memlock.c 19+++ b/lib/mm/memlock.c
19@@ -145,7 +145,7 @@ static void _touch_memory(void *mem, size_t size) 20@@ -150,7 +150,7 @@ static void _touch_memory(void *mem, size_t size)
20 21
21 static void _allocate_memory(void) 22 static void _allocate_memory(void)
22 { 23 {
23-#ifndef VALGRIND_POOL 24-#ifndef VALGRIND_POOL
24+#if !defined(VALGRIND_POOL) && defined(__GLIBC__) 25+#ifndef VALGRIND_POOL && defined(__GLIBC__)
25 void *stack_mem; 26 void *stack_mem;
26 struct rlimit limit; 27 struct rlimit limit;
27 int i, area = 0, missing = _size_malloc_tmp, max_areas = 32, hblks; 28 int i, area = 0, missing = _size_malloc_tmp, max_areas = 32, hblks;
28-- 29--
292.7.0 302.9.3
30 31
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0002-use-PTHREAD_MUTEX_RECURSIVE-instead-of-PTHREAD_MUTEX.patch b/meta-oe/recipes-support/lvm2/lvm2/0002-use-PTHREAD_MUTEX_RECURSIVE-instead-of-PTHREAD_MUTEX.patch
deleted file mode 100644
index 969a15287..000000000
--- a/meta-oe/recipes-support/lvm2/lvm2/0002-use-PTHREAD_MUTEX_RECURSIVE-instead-of-PTHREAD_MUTEX.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1From c8a1b669cbff3eee367fd4db3389e337bc4c98ba Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 20 Jan 2016 04:46:26 +0000
4Subject: [PATCH 2/4] use PTHREAD_MUTEX_RECURSIVE instead of
5 PTHREAD_MUTEX_RECURSIVE_NP
6
7PTHREAD_MUTEX_RECURSIVE_NP was used for compatibility with old glibc.
8Although due to the_GNU_SOURCES define the portable,
9PTHREAD_MUTEX_RECURSIVE will be available for Linuxes since at least
101998. Simplify things giving us compatibility with musl which
11apparently does not provide the non-portable define.
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15Upstream-Status: Pending
16
17 daemons/lvmetad/lvmetad-core.c | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/daemons/lvmetad/lvmetad-core.c b/daemons/lvmetad/lvmetad-core.c
21index 7af9bde..63707c2 100644
22--- a/daemons/lvmetad/lvmetad-core.c
23+++ b/daemons/lvmetad/lvmetad-core.c
24@@ -300,7 +300,7 @@ static struct dm_config_tree *lock_vg(lvmetad_state *s, const char *id) {
25 if (!(vg = dm_hash_lookup(s->lock.vg, id))) {
26 if (!(vg = malloc(sizeof(pthread_mutex_t))) ||
27 pthread_mutexattr_init(&rec) ||
28- pthread_mutexattr_settype(&rec, PTHREAD_MUTEX_RECURSIVE_NP) ||
29+ pthread_mutexattr_settype(&rec, PTHREAD_MUTEX_RECURSIVE) ||
30 pthread_mutex_init(vg, &rec))
31 goto bad;
32 if (!dm_hash_insert(s->lock.vg, id, vg)) {
33@@ -2890,7 +2890,7 @@ static int init(daemon_state *s)
34 ls->log = s->log;
35
36 pthread_mutexattr_init(&rec);
37- pthread_mutexattr_settype(&rec, PTHREAD_MUTEX_RECURSIVE_NP);
38+ pthread_mutexattr_settype(&rec, PTHREAD_MUTEX_RECURSIVE);
39 pthread_mutex_init(&ls->lock.pvid_to_pvmeta, &rec);
40 pthread_mutex_init(&ls->lock.vgid_to_metadata, &rec);
41 pthread_mutex_init(&ls->lock.pvid_to_vgid, NULL);
42--
432.7.0
44
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0004-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch b/meta-oe/recipes-support/lvm2/lvm2/0003-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch
index 2a3b84364..9ab1c06d2 100644
--- a/meta-oe/recipes-support/lvm2/lvm2/0004-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch
+++ b/meta-oe/recipes-support/lvm2/lvm2/0003-include-fcntl.h-for-O_-defines-and-fcntl-signature.patch
@@ -1,19 +1,20 @@
1From 9b793d5b4adc5d8b3684e7f66943e236eae7c2db Mon Sep 17 00:00:00 2001 1From b1ad91a059d99afd1ce25823b7c0a8d3ac63d2fd Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 20 Jan 2016 04:52:59 +0000 3Date: Tue, 25 Oct 2016 11:55:49 +0000
4Subject: [PATCH 4/4] include fcntl.h for O_* defines and fcntl() signature 4Subject: [PATCH 3/4] include fcntl.h for O_* defines and fcntl() signature
5 5
6On glibc _somehow_ this header gets pulled in indirectly 6On glibc _somehow_ this header gets pulled in indirectly
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9Signed-off-by: Dengke Du <dengke.du@windriver.com>
9--- 10---
10Upstream-Status: Pending 11Upstream-Status: Pending
11 12---
12 libdaemon/server/daemon-server.c | 1 + 13 libdaemon/server/daemon-server.c | 1 +
13 1 file changed, 1 insertion(+) 14 1 file changed, 1 insertion(+)
14 15
15diff --git a/libdaemon/server/daemon-server.c b/libdaemon/server/daemon-server.c 16diff --git a/libdaemon/server/daemon-server.c b/libdaemon/server/daemon-server.c
16index d9d60d1..433d100 100644 17index 6af6de9..a9590e7 100644
17--- a/libdaemon/server/daemon-server.c 18--- a/libdaemon/server/daemon-server.c
18+++ b/libdaemon/server/daemon-server.c 19+++ b/libdaemon/server/daemon-server.c
19@@ -18,6 +18,7 @@ 20@@ -18,6 +18,7 @@
@@ -25,5 +26,5 @@ index d9d60d1..433d100 100644
25 #include <errno.h> 26 #include <errno.h>
26 #include <pthread.h> 27 #include <pthread.h>
27-- 28--
282.7.0 292.9.3
29 30
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0005-tweak-MODPROBE_CMD-for-cross-compile.patch b/meta-oe/recipes-support/lvm2/lvm2/0004-tweak-MODPROBE_CMD-for-cross-compile.patch
index 8db320d5e..aaeaa725d 100644
--- a/meta-oe/recipes-support/lvm2/lvm2/0005-tweak-MODPROBE_CMD-for-cross-compile.patch
+++ b/meta-oe/recipes-support/lvm2/lvm2/0004-tweak-MODPROBE_CMD-for-cross-compile.patch
@@ -1,7 +1,7 @@
1From 72866782f83c8cf85b10017df461128af90cae6e Mon Sep 17 00:00:00 2001 1From 0012ea63f6070a5d41fa380970f9c30b953237d2 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Dengke Du <dengke.du@windriver.com>
3Date: Tue, 30 Aug 2016 22:33:47 -0400 3Date: Tue, 25 Oct 2016 11:59:40 +0000
4Subject: [PATCH] tweak MODPROBE_CMD for cross compile 4Subject: [PATCH 4/4] tweak MODPROBE_CMD for cross compile
5 5
6Lvm uses variable MODPROBE_CMD at runtime, so build time detection of modprobe 6Lvm uses variable MODPROBE_CMD at runtime, so build time detection of modprobe
7is incorrect. 7is incorrect.
@@ -16,23 +16,23 @@ filter=["r|/loop1$|","r|/loop2$|","r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loo
16Upstream-Status: Inappropriate [oe specific] 16Upstream-Status: Inappropriate [oe specific]
17 17
18Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 18Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
19Signed-off-by: Dengke Du <dengke.du@windriver.com>
19--- 20---
20 configure.in | 2 -- 21 configure.in | 1 -
21 1 file changed, 2 deletions(-) 22 1 file changed, 1 deletion(-)
22 23
23diff --git a/configure.in b/configure.in 24diff --git a/configure.in b/configure.in
24index 8e04782..77681b0 100644 25index cc77aab..a3579f2 100644
25--- a/configure.in 26--- a/configure.in
26+++ b/configure.in 27+++ b/configure.in
27@@ -1779,8 +1779,6 @@ if test "$UDEV_SYNC" = yes; then 28@@ -1853,7 +1853,6 @@ if test "$UDEV_SYNC" = yes; then
28 fi 29 fi
29 30
30 ################################################################################ 31 ################################################################################
31-AC_PATH_TOOL(MODPROBE_CMD, modprobe) 32-AC_PATH_TOOL(MODPROBE_CMD, modprobe)
32- 33
33 if test -n "$MODPROBE_CMD"; then 34 if test -n "$MODPROBE_CMD"; then
34 AC_DEFINE_UNQUOTED([MODPROBE_CMD], ["$MODPROBE_CMD"], [The path to 'modprobe', if available.]) 35 AC_DEFINE_UNQUOTED([MODPROBE_CMD], ["$MODPROBE_CMD"], [The path to 'modprobe', if available.])
35 fi
36-- 36--
372.8.1 372.9.3
38 38
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb
new file mode 100644
index 000000000..8476b01fa
--- /dev/null
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.02.166.bb
@@ -0,0 +1,6 @@
1require lvm2.inc
2
3SRC_URI[md5sum] = "c5a54ee0b86703daaad6e856439e115a"
4SRC_URI[sha256sum] = "e120b066b85b224552efda40204488c5123de068725676fd6e5c8bc655051b94"
5
6DEPENDS += "autoconf-archive"