summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lm_sensors
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-17 20:10:12 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:51 +0200
commit7414f34c9a5968b7a807eec72b3fc4b54a20fd1c (patch)
tree1f1122a7ec3764dc78eef59fb3048c0d9528e48f /meta-oe/recipes-support/lm_sensors
parent94670cce6b0aa7c9aa59715b967d2bc28bc122a5 (diff)
downloadmeta-openembedded-7414f34c9a5968b7a807eec72b3fc4b54a20fd1c.tar.gz
lm_sensors: Fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lm_sensors')
-rw-r--r--meta-oe/recipes-support/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch88
-rw-r--r--meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb6
2 files changed, 94 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch b/meta-oe/recipes-support/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch
new file mode 100644
index 000000000..fb3878dc3
--- /dev/null
+++ b/meta-oe/recipes-support/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch
@@ -0,0 +1,88 @@
1From 727524453f115ddc05109e9bbb3d0e60a7db9185 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 15:05:50 -0700
4Subject: [PATCH] prog: Do not limit sys/io.h header include to just glibc
5
6musl provides it too.
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 prog/dump/isadump.c | 6 ------
11 prog/dump/isaset.c | 6 ------
12 prog/dump/superio.c | 5 -----
13 prog/dump/util.c | 5 -----
14 4 files changed, 22 deletions(-)
15
16diff --git a/prog/dump/isadump.c b/prog/dump/isadump.c
17index e0e6f00..8794537 100644
18--- a/prog/dump/isadump.c
19+++ b/prog/dump/isadump.c
20@@ -36,13 +36,7 @@
21 #include "util.h"
22 #include "superio.h"
23
24-
25-/* To keep glibc2 happy */
26-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
27 #include <sys/io.h>
28-#else
29-#include <asm/io.h>
30-#endif
31
32 #ifdef __powerpc__
33 unsigned long isa_io_base = 0; /* XXX for now */
34diff --git a/prog/dump/isaset.c b/prog/dump/isaset.c
35index e743755..85a4f64 100644
36--- a/prog/dump/isaset.c
37+++ b/prog/dump/isaset.c
38@@ -32,13 +32,7 @@
39 #include <string.h>
40 #include "util.h"
41
42-
43-/* To keep glibc2 happy */
44-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
45 #include <sys/io.h>
46-#else
47-#include <asm/io.h>
48-#endif
49
50 #ifdef __powerpc__
51 unsigned long isa_io_base = 0; /* XXX for now */
52diff --git a/prog/dump/superio.c b/prog/dump/superio.c
53index 64ef27b..906fe55 100644
54--- a/prog/dump/superio.c
55+++ b/prog/dump/superio.c
56@@ -20,12 +20,7 @@
57 */
58
59 #include <stdlib.h>
60-
61-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
62 #include <sys/io.h>
63-#else
64-#include <asm/io.h>
65-#endif
66
67 #include "superio.h"
68
69diff --git a/prog/dump/util.c b/prog/dump/util.c
70index 874c1b9..197fa64 100644
71--- a/prog/dump/util.c
72+++ b/prog/dump/util.c
73@@ -11,12 +11,7 @@
74 #include <stdio.h>
75 #include "util.h"
76
77-/* To keep glibc2 happy */
78-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
79 #include <sys/io.h>
80-#else
81-#include <asm/io.h>
82-#endif
83
84 /* Return 1 if we should continue, 0 if we should abort */
85 int user_ack(int def)
86--
872.13.3
88
diff --git a/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb b/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
index dbc05a898..454a69f40 100644
--- a/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
+++ b/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
@@ -11,6 +11,7 @@ SRC_URI = "https://github.com/groeck/lm-sensors/archive/V3-4-0.tar.gz \
11 file://fancontrol.init \ 11 file://fancontrol.init \
12 file://sensord.init \ 12 file://sensord.init \
13 file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \ 13 file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \
14 file://0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch \
14" 15"
15SRC_URI[md5sum] = "1e9f117cbfa11be1955adc96df71eadb" 16SRC_URI[md5sum] = "1e9f117cbfa11be1955adc96df71eadb"
16SRC_URI[sha256sum] = "e334c1c2b06f7290e3e66bdae330a5d36054701ffd47a5dde7a06f9a7402cb4e" 17SRC_URI[sha256sum] = "e334c1c2b06f7290e3e66bdae330a5d36054701ffd47a5dde7a06f9a7402cb4e"
@@ -37,6 +38,11 @@ EXTRA_OEMAKE = 'EXLDFLAGS="${LDFLAGS}" \
37 CC="${CC}" AR="${AR}"' 38 CC="${CC}" AR="${AR}"'
38 39
39do_compile() { 40do_compile() {
41 sed -i -e 's:^# \(PROG_EXTRA\):\1:' ${S}/Makefile
42 # Respect LDFLAGS
43 sed -i -e 's/\$(LIBDIR)$/\$(LIBDIR) \$(LDFLAGS)/g' ${S}/Makefile
44 sed -i -e 's/\$(LIBSHSONAME) -o/$(LIBSHSONAME) \$(LDFLAGS) -o/g' \
45 ${S}/lib/Module.mk
40 oe_runmake user PROG_EXTRA="sensors sensord" 46 oe_runmake user PROG_EXTRA="sensors sensord"
41} 47}
42 48