diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-20 23:32:26 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-03-31 13:26:00 +0200 |
commit | df3d2beaf9e5d4cfc31b2b1e209dc1d8e3956fd3 (patch) | |
tree | cc9bd28ceea40c119ae42e55c5ac2f6e4deb70a3 /meta-oe/recipes-support/lio-utils | |
parent | f646f52eac00e934dd47c86ea269f1e4b70fd080 (diff) | |
download | meta-openembedded-df3d2beaf9e5d4cfc31b2b1e209dc1d8e3956fd3.tar.gz |
lio-utils: Fix GNU_HASH QA errors
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lio-utils')
-rw-r--r-- | meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch | 61 | ||||
-rw-r--r-- | meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | 4 |
2 files changed, 64 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch b/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch new file mode 100644 index 000000000..9608b7e75 --- /dev/null +++ b/meta-oe/recipes-support/lio-utils/lio-utils/0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | From 2cc2315eecaa48fd24792aaa889dc7d9fb96978b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 20 Mar 2017 22:18:44 -0700 | ||
4 | Subject: [PATCH] Makefiles: Respect environment variables and add LDFLAGS to | ||
5 | linker cmdline | ||
6 | |||
7 | Fixes QA errors about GNU_HASH | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | mib-modules/Makefile | 10 +++++----- | ||
12 | tools/Makefile | 2 +- | ||
13 | 2 files changed, 6 insertions(+), 6 deletions(-) | ||
14 | |||
15 | diff --git a/mib-modules/Makefile b/mib-modules/Makefile | ||
16 | index 0d54c9b..051d4d2 100644 | ||
17 | --- a/mib-modules/Makefile | ||
18 | +++ b/mib-modules/Makefile | ||
19 | @@ -17,13 +17,13 @@ TARG = iscsiTargetMib.so | ||
20 | OBJS = iscsiTargetMib.o iscsiMib.o scsiMib.o ipsAuthMib.o \ | ||
21 | iscsiAuthData.o | ||
22 | |||
23 | -CC = gcc | ||
24 | -CFLAGS = -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC | ||
25 | +CC ?= gcc | ||
26 | +CFLAGS += -I$(INCLDIR) -I$(INCLDIR)/agent -I$(INCLDIR)/agent/mibgroup -shared -fPIC | ||
27 | CFLAGS += -I../include -Wall -Werror | ||
28 | #CFLAGS +=$(AUTO_CFLAGS) | ||
29 | |||
30 | -LD = gcc -shared | ||
31 | - | ||
32 | +LD ?= gcc | ||
33 | +LDFLAGS += -shared | ||
34 | INSTALL = install | ||
35 | |||
36 | all: $(TARG) | ||
37 | @@ -32,7 +32,7 @@ all: $(TARG) | ||
38 | $(CC) $(CFLAGS) -o $@ -c $< | ||
39 | |||
40 | $(TARG): $(OBJS) | ||
41 | - $(LD) -o $@ $(OBJS) | ||
42 | + $(LD) -o $@ $(OBJS) $(LDFLAGS) | ||
43 | |||
44 | clean: | ||
45 | rm -f $(OBJS) $(TARG) | ||
46 | diff --git a/tools/Makefile b/tools/Makefile | ||
47 | index 79ed3cd..ffd9bf3 100644 | ||
48 | --- a/tools/Makefile | ||
49 | +++ b/tools/Makefile | ||
50 | @@ -6,7 +6,7 @@ ISCSI_NAME_OBJS = $(ISCSI_NAME_SRCS:.c=.o) | ||
51 | all:: $(ISCSI_NAME) | ||
52 | |||
53 | $(ISCSI_NAME): $(ISCSI_NAME_OBJS) | ||
54 | - $(CC) -o $@ $(CFLAGS) $(ISCSI_NAME_OBJS) | ||
55 | + $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(ISCSI_NAME_OBJS) | ||
56 | |||
57 | clean: | ||
58 | rm -f $(ISCSI_NAME_OBJS) $(ISCSI_NAME) | ||
59 | -- | ||
60 | 2.12.0 | ||
61 | |||
diff --git a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb index 35ba16141..3a6319c31 100644 --- a/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb +++ b/meta-oe/recipes-support/lio-utils/lio-utils_4.1.bb | |||
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://debian/copyright;md5=c3ea231a32635cbb5debedf3e88aa3df | |||
6 | 6 | ||
7 | PV = "4.1+git${SRCPV}" | 7 | PV = "4.1+git${SRCPV}" |
8 | 8 | ||
9 | SRC_URI = "git://risingtidesystems.com/lio-utils.git" | 9 | SRC_URI = "git://risingtidesystems.com/lio-utils.git \ |
10 | file://0001-Makefiles-Respect-environment-variables-and-add-LDFL.patch \ | ||
11 | " | ||
10 | SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f" | 12 | SRCREV = "28bd928655bdc7bd3cf380f0196630690c51e05f" |
11 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
12 | 14 | ||